ROCK install stalled

Not sure if I should post here or in the Roon Software>ROCK category but here goes:
I’m struggling with a ROCK install and looking for support.

Toshiba 512GB SSD m.2

I am sure I have prepared the BIOS correctly according to the Knowledge Base article.
There is a cautionary about making sure the m.2 slot is enabled but no instructions about how to do that. However, I can see the m.2 drive in the boot options so I assume it is enabled.

I have closely followed the directions for downloading the ROON OS and flashing it to a USB thumb drive using Etcher. The Knowledge Base instructions say not to unarchive the .gz file but the YouTube instructions from Hans B. say to unzip it. I tried it both ways with equal failure.

When I boot from the thumb drive I get partway through the Roon setup. I answer the series of questions and then the monitor reads

Preparing Disk
Installing RoonOS

and it hangs at that point with the cursor frozen, not blinking. I tried waiting 30+ min but it never moved.

I suspect the problem is either with the internal SSD or with the .img on the USB drive. I have tried 3 different thumb drives with the same result, so it may be the SSD.

I bought the NUC used. It had an unregistered copy of Win10 installed. When I first received it I started it in Win10 for a minute just to make sure it worked before I started messing with it. It looked okay. At this point, that drive has been wiped and there is no OS. I’m thinking that I may need to reformat the internal SSD. Now that I have tried and failed to install a dozen times, it may be corrupted.

Any advice appreciated.

Is it connected to the network when you are doing it?

I don’t have a NUC, but have looked into formatting on Linux and Windows. Windows uses NTFS and Linux knows several variants, although I have so far consistently been offered Ext4 with various distributions. The Roon community has also done some work on this:

Tried it both ways with no success.

Thanks for responding. May I ask why you asked? Which should it be: connected or disconnected?

Thanks for responding. This is my first encounter with a PCIe M.2 type drive. I don’t have a harness or another computer I can plug it into to format it. I’m thinking I will need to install Linux or something on an external drive and find a tool to wipe and format the internal drive. I expected the Roon OS utility to do that before installing, but as I said I have tried the install multiple times to failure so the drive may be corrupted.

I am fluent in Windows and MacOS and have tinkered around in Terminal, but I am in foreign territory here. This is out of my comfort zone, but that can be a good thing sometimes. I’m sure it’s been done before.

1 Like

The keyword is GParted

Search times in the net for GParted with it work probably nearly all Linuxer and your disks to partition, to increase, to reduce. There are many manuals for it.

A very small distribution for the bootable memory stick for the first preparation of the hard disk.

A good knowledge portal is:

A treasure trove for beginners and experts

It needs to be connected. I can’t imagine what is wrong here. Are you using USB2 or USB3 sticks? ROCK should simply install on an unpartitioned disk or write itself over anything that may be on the disk.

They are USB2.
Again, I ask you: Which should they be, USB 2 or 3 ?
Clearly the NUC is reading the stick, because it begins the Roon OS installation process.

This is all new to me. I’m going by the instructions from Roon and have read them so many times in the last 72 hours that I can almost do it from memory. The instructions are silent about whether the network should be connected and what type of USB stick should be used.

I wonder if the partition table needs to be cleaned up on the NVMe drive. Perhaps flash the thumb with x86_64 Native DietPi and boot from that. Once you are logged in, you can use lsblk to get the device name for the NVMe device. fdisk -l may help to confirm by size. For example, it might be /dev/sda. Once you know the device, you can clean the partition table and boot block with something like wipefs -a /dev/sda. Again, use the correct device path.

Type poweroff and then then retry the Roon OS installation.

Thanks for weighing in. I agree, it’s feeling like the SSD is corrupted in some way. When I have some time this weekend I’ll crack it open and reseat the drive and RAM.
I tried using Rufus to create a bootable USB with LinuxMint from my PC at work but that didn’t work, probably because I don’t know what I’m doing.

I can’t comprehend anything you wrote after the first sentence, but I’ll do some studying over the weekend. Thanks for trying to help.

1 Like

Kann die Bootmethode EFI (UEFI) statt LEGACY hier ein Problem sein. Wenn das Teil noch über UEFI verriegelt ist oder der LEGACY -Modus nicht zieht?

I have booted to an .iso of LinuxMint on a USB stick.

fdisk -l returns:

fdisk: cannot open /dev/loop0: Permission denied
fdisk: cannot open /dev/nme0n1: Permission denied
fdisk: cannot open /dev/sda: Permission denied

I tried it anyway, but of course it didn’t work

wipefs -a /dev/nme0n1
wipefs: error: /dev/nme01n: probing intialization failed: Permission denied

I tried installing LinuxMint on the SSD, which it did appear to install but I couldn’t get it to start on reboot.

I think the next step is to purchase a new M.2 SSD. Or, this NUC is a tall one that permits 2.5 drive so maybe I’ll see if I can find one laying around to try.

Thanks for your help.

If you are not familiar with Linux I would install Ubuntu on that machine. The Ubuntu distribution is well supported and well documented and has a full GUI.

Surf the web a bit, let it do updates, etc. This will format your drive properly during install and give you reasonable confidence the hardware is sane.

Then you can try ROCK again.

You must be root to run this command:
sudo fdisk -l

you probably need to be root to run wipefs as well.

Linux Mint is a fine OS as well… but Ubuntu is a bit heavier and we want to really exercise the machine to make sure all is in order. I would actually install one of these OSs to your NuC and boot from the internal drive and use it for a bit as a good test.

1 Like

This is why I suggested booting from DietPi instead. If you had done so, the commands would have worked because you would have been logged in as root, a privileged account that has the necessary access.

And, that’s the wrong device name. From the output above, /dev/sda is almost certainly the NVMe SSD that needs cleaning.

Okay, thanks to everyone for telling me what I didn’t do that I should have. Would anyone like to tell me what I can do? For instance, how does one “log in as root” in Linux Mint?

It looks to me like the failed installations created three partitions on the SSD. So I think I need to reformat the entire drive, not just /sda. How do I log in as root in Linux Mint? I looked at the DietPi distro and it appears to require Rufus, which is not working for me. I used Etcher to flash the L Mint .iso to USB, and it seems to work fine. So I’d rather not start over.

Thanks for responding. To be clear, I am running Linux Mint from a USB stick. I installed L Mint on the internal SSD but am unable to start it. What I want to do is reformat the entire SSD, but I can’t figure out how to do that from L Mint.

Yes. I’m aware. I just don’t understand why you are using Linux Mint when I suggested DietPi. You won’t be able to boot from the NVMe drive until you properly clear it. I hope you’ll consider following the process I suggested. Until you do, there’s not much more I can do to help. Sorry.

Rufus is not required to flash the DietPi image to a thumb drive. Etcher will work fine. You are not trying to install DietPi on the internal drive of the NUC. You just want to boot DietPi and use the commands I provided to clear the internal NVMe SSD.