Rock loses access to network share every time it shuts down

The music is stored on a Synology NAS and the NUC8i5BEK2 is connected by an ethernet cable.

It connects successfully to the music as a network share and runs very well, until the Rock shuts down.
Then it cannot see the NAS folder anymore and says “The drive is not available. Check the drive or edit if it has been moved” for all the directories".
NAS drive is visible to other computers and hasn’t moved. The password is unchanged.

The problem, sounds like this:

from several years ago, but no solution was posted. The problem is presumably known to Roon.

If I browse the directory, it looks like this:

If I then delete and recreate the share, it finds it and everything works after rescanning, although this can take a while, but happily all the metadata is correctly assigned.

Is there a fix for this?

Is there a particular reason you shut the NUC down? Many of us leave them on permanently.

If the NAS has a fixed or reserved IP address try that instead of the \\mediastation\music

You maybe could also try using smb://mediastation/music or smb://aaa.bbb.ccc.ddd/music

can you post the ROCK network settings in the GUI too…maybe the network entries are a bit odd or the DHCP service is not getting a great selection.

As others have said try using it’s IP address instead of its name and see if that sticks.

Thanks for your various replies.

@ged_hickman1 today, I moved it while reorganising, but there are power outages if a circuit breaker trips etc. or my cleaner sometimes unplugs the wrong thing. I would expect it to switch off once every week or two.

@wizardofoz @Simon_Arnold3 the IP address is relatively stable, but I do change these so I would avoid using it if I can, whereas the name is forever.

@wizardofoz The Rock has a static IP address, outside the range of normally-allocated DHCP addresses.
It looks like this

Next time it happens I will switch an smb:// format.
It is not clear to me whether Linux or the network treats this differently.
I had thought they were completely interchangeable, but worth a try.

Add the gateway IP address to the dns address 1st then the one you have after a space.

The reason could be is the DNS server you have is a public one and won’t do resolutions on your local network, but your router can (in fact it will do both typically too) so it needs to be first and in there as you are using names and not ip’s for resolution.

So it looks like your dhcp service is also not adding the router as a dns entry

2 Likes

So you mean the DNS address becomes
192.168.1.1 195.186.4.162

You are correct that the second is a public DNS server and I hope it can’t do resolutions on my local network, although with all the revelations about national security services, who knows.

@wizardofoz
Yes Mr Fix It, that seems to have fixed it.
Thanks.

1 Like

You can click solution in the 3 … menu :smiley: and no the public DNS will not do local resolution. You could also add a generic DNS too like 8.8.8.8 or 1.1.1.1 on there also.

Just curious here, why would the Google (8.8.8.8) or the Cloudflare (1.1.1.1) DNS servers work when the ISP DNS server does not? They’re all public DNS servers, surely?

Or did you mean simply to add these to the local DNS server address in this text field?

As an option to the ISP one which I assume is the only one he had and his router which should always be there.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.