ROCK no longer connects after network change to Unifi/Ubiquiti UDM-Pro

Core Machine (Operating system/System info/Roon build number)
I had the latest version.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue
Since updating my network (changed from Orbi to Ubiquiti), Roon refuses to connect to the ROCK, which still has an IP address.

I can’t even connect to the ROCK through the Finder or by typing the IP address into Safari.

In the past, rebooting the ROCK would fix stuff like this.

Any ideas? Thanks.

Can you describe in more detail what had changed in your home network setup … devices model numbers etc.

How is ROCK and your Mac connected!

Has the subnet of your LAN changed?

How is the ROCK NUC obtaining its IP address, DHCP or static?

Can you try running a network scanning app like Fing to see what it can discover.

Before, I had an Orbi 45. Now, I have a Ubiquiti USW-24-PoE and a Dream Machine Pro. The NUC is hardwired by Ethernet through two switches. Two of my Macs connect wirelessly over the LAN. One Mac connects through the Ethernet LAN. My iPhone connects over the wireless LAN. Not sure what you mean by “subnet.” I can see the NUC’s IP address, though. Don’t know how the ROCK NUC obtains its IP address. The UniFi interface allows me to switch on a feature called “Use Fixed IP Address.” Should I?

I also have four U6-LR-USes, which are wireless access points.

Fing (on my iPhone) found some information about the NUC, such as its IP address and its hostname (rock.localdomain), but it can’t find a MAC address. A couple of hours ago, Roon on my iPhone started working, but now I am back to being unable to use it wirelessly–it can’t connect.

Thanks for your help.

I have just been able to log in to Roon from my wired Mac, using the ROCK’s IP address. Is there any information from there that will help fix this problem? Roon still can’t connect to the ROCK. Thanks.

I’ll only mention the rules:

Everything have to be on the same subnet.

Multicast packets have to be passed.

Must not use VLAN.

I don’t know enough about Ubiquiti. Someone please change the thread title to include Ubiquiti. Hopefully the Ubiquiti experts here can help.

I use Ubiquiti / Unifi and just migrated to a UDM-Pro

I had everything working on a USG3P previously so just imported my setup from a backup. You have started from scratch I assume.

Peter is right you need everything in the same subnet ie the same first 3 IP address numbers… Unifi probably defaulted to 192.168.1.X

@Andrew_Stein can PM me if you like and we can chat offline. Im also in a Mac ecosystem


Hi. Looks like everything is on the same subnet. Last night, or perhaps early this morning, Roon finally discovered the NUC ROCK, and everything looks good.

My concern is that Roon could revert to not finding the NUC, as happened when I had my Orbi (and the router that preceded it). For some reason, everything would work for some time but then suddenly stop working. I am hoping that the Ubiquiti products will prove more robust.

But I do wonder why this lack of connectivity occurred in the first place (and why even then it worked briefly before flaking out for a day or two).

Should I set certain features a certain way to keep things connected?

Incidentally, the NUC is not the only device that took awhile to work properly on my LAN (and WLAN). Other devices took a day or more to snap into place. Some devices still haven’t migrated over. I don’t know why.

Thank you for your help.

After the network infrastructure change, did you power cycle all network devices including your phones and iPad?

You should reserve IP addresses for the computers and endpoints.

also check your DNS settings - external and internal

When you created the WiFi network are you sure you didn’t put it on it own vlan? Iit needs to be a part of the existing lan the rest of the wired network is on. It’s easy to so this in the Unifi UI. They all should have matching first 3 set of numbers if on same vlan You can check this in the Unifi interface.

You say it did the same previously on the Orbi gear then this might point to something else on your network. What are the switches you are using where they in use previously? If so try removing one to the core as an experiment, if no luck try removing both of possible, try a new cable as a faulty one can cause all sorts of issues.

In Rocks Web UI if you can get this up on the wired in pc check that the network section is set to DHCP.

In the Unifi interface, try turning off IGMP Snooping if it’s disabled, turn on mDNS and make sure block all multicast data from lan to wifi is definitely off. If you used their auto optimisation for WiFi I found it cases more issues than it solves as it blocks multicasts.

Hi. Thank you for the detailed reply. Due to some personal issues, I haven’t had a chance to look in to this situation until now.

Each device is on the same LAN (to the extent each device has the same first three set of numbers). The same is true for most clients but not all. Two out of around fifteen clients are not on the LAN. How can I get them on the LAN?

That said, it appears that all Bluesound devices (the only ones Roon is controlling) are on the same LAN.

Tonight, I noticed that Roon is having trouble streaming tracks, particularly those over 44 Khz, over the LAN. The tracks will stutter, stop, and restart, and I will get a message that Roon is having trouble with network traffic. (“An audio file is loading slowly…”)

I had switched my main switch. That switch of switches (sorry) seems to have caused these network issues. My switch is now a Ubiquiti USW-24-PoE. I’m not sure what it has done to the traffic.

The ROCK UI apparently had been set to DHCP, but I have clicked to Static IP and back to DHCP just in case that might get it to work.

I just turned off IGMP snooping. (It had been on.)

I had auto-optimize network on, and the info box says that turning that option on blocks multicast. ("Determines and sets these options for optimum performance:

  • Block multicast and broadcast traffic for high density WiFi networks
  • Increase ARP timeout for high density WiFi networks

When enabled this overrides any manually set values.")

How can I block multicast if I turn off auto-optimize network?

Again, thanks for your help.

I just implemented your suggestions, and so far so good. It is streaming well now. Edit: Started stuttering again. I will try to implement the below suggestions from Ubiquiti.

Ubiquiti recommended:

"Try the following suggestions and check if it helps

Disable the IPS, IDS, Smart Queues and GeoIP filtering feature from the Unifi controller.

To disable the IPS and IDS options, navigate to Settings>>Threat Management

To disable Smart Queues, navigate to Settings>>Networks>>Edit WAN>> Under Common Settings uncheck Smart Queues

To disable GeoIP Filtering, go to Settings>>Routing & Firewall>>GeoIP Filtering

To disable the BETA GUI, you can navigate to Settings>>System Settings>>New Settings>>Disable>>Apply Changes"

Whatever I did that Ubiquiti suggested caused my Roon to disconnect. :slight_smile: And the strange part (a strange part?) is that I can log in to the Roon through its URL. It is online, and I can make it reboot.

And now Roon is back. Strange how it comes and goes like a house cat.

I have noticed with these Ubiquiti devices that it often takes significant time before a client joins the network and functions properly. Sometimes, it will take a day or two.

I have a fully Unifi/Ubiquiti network and no issues…multiple zones LAN & Wifi, multiple remotes LAN & Wifi and have used many different CORE Server machines all LAN … all just works.

Granted I am a networking guy so have clear setup objectives.

IGMP snooping is ON
DHCP snooping is ON

Smart Queues is OFF

IPS is ON - I use a UDM-Pro which can support this at gigabit rates (a USG-3P or 4 Pro will not)

I use DHCP reservations for all fixed devices like endpoints and servers, NAS, controllers etc.
mobile devices mostly use DHCP like phones, tablets etc. guests use DHCP. These are all wifi

I have over 50 devices on my network at any one time. 7-9 switches and 5 AP’s

Document your network, every device setting like Fixed or DHCP with an address if you define one.

DNS is typically set in the DHCP for at least the local UDM and one or external services typically including

I also set static addresses for all Server machines and NAS with specific DNS setting.

For my system I have DHCP mode is set to DHCP Server, IGMP Snooping is on, DCHP Name servers are set to use my two ISP ones and then and so have 4 to cover any outages on one or the other, mDNS on, IPS off, the USG router I use isn’t up to it without loosing too much of the bandwidth I pay for. Smart queues off (this again reduces bandwidth as its a QoS setting and not a good one). DPI is on as I like to see all the stats.

For wireless aps, I have seperate sssid for 2.4ghz and 5ghz both use HDCP and use the same vlan as the lan, Multicast Enhancement is on, Enable Fast Roaming is on, Multicast and Broadcast filtering off you don’t need this in a home environment unless you have a lot of multicast traffic and it will stop discovery of certain devices.

Works perfectly with all this set. Ensure your on the latest controller software and firmware. Looks like the removed the automatic settings in the latest controller software for wireless which is a good thing as this just made things not play ball more than not.

Switches I dont mess with unless I need to set ports to another vlan or in one case turn off RSTP for one port as the delay on startup was causing issues with it getting a DHCP address. The manufacturer is working on fixing it for this device so I can reenable it in the future.

I set reserved IP addresses for all servers in the controller software and my DHCP range for the main Lan is set to start after the first 10 reserved allocations. So anything below this I use to set to a reserved IP.

Something wrong there if this is happening. Sounds like something is blocking discovery. What devices are these? I had issues with IGMP and Chromecasts on some firmware it seems to have been resolved now. Ensure your on latest for all switches. Or have IGMP Snooping off and see if it improves.

Thank you. How do you set DHCP snooping on? I see another setting that mentions DHCP must be on to work, but I can’t find where to set DHCP snooping.

One device is a Logitech Circle (wireless). Another is a Fujitsu scanner. That scanner stops connecting every time I have a power outage–even before I switched to Ubiquti.

If you your blocking multicast on WiFi that would possibly account for it not showing, does it still do it with it off? I have found logitech stuff temperamental network wise, my Harmony hubs would not connect wirelessly to my Unifi APs until I switched to having seperates ssid for 5ghz and 2ghz.

I think I tried turning that feature off and on, but I will check again.

I did an experiment with the sound, however, and found something interesting. I use Bluesound components in my system. The BluOS app on my iPhone had no trouble playing the tracks that Roon stuttered and stopped on. I even swapped between the Roon app and the BluOS app on the same tracks, and BluOS handled them fine while Roon sputtered. So I think that Roon is somehow contributing to the problem.

Curiously, my ROCK NUC sits in the same room as my NAS, and both connect to the same switch in that room. That switch (a fairly cheap brand) then feeds to the main switch (the Ubuiti USW-24-PoE), which distributes audio throughout the house. I don’t know why the NUC has trouble while the BluOS doesn’t. I also have one of my Bluesound components–a Node 2i–on that cheaper switch in the same room.

Again, the NUC has long been glitching, so that Roon loses the connection, even before I swapped my main switch with the Ubiquiti switch. But, with the previous switch, it never stuttered or stopped during play. Only since I have introduced the Ubiquiti USW-24-PoE and the Dream Machine Pro has it exhibited the stuttering and the stopping.

I thought about replacing that cheaper switch with Ubiquiti’s $200 16-port switch. Maybe the whole system would behave better with a Ubiquiti component. We have a number of other hard-wired devices, including computers, in that room. One computer seems to work fine, but another has had poor connectivity since I introduced the Ubiquiti components. I even had to disable its Ethernet connection in favor of a wireless one.

The whole thing is strange. I appreciate everyone’s help.