Rock Not connecting to my Network

Roon Core Machine


Networking Gear & Setup Details

BT Smart Home Hub

Connected Audio Devices

ROCK connected to Home Hub by ethernet

Library Size


Description of Issue

On booting up the ROCK I get this screen

Accessing my home hub manager

The hub manager will not let me make any changes

How do I fix it please?

What cable are you using and have you tried changing it?

Scratch that. Have you rebooted the Smart Hub?

Thanks Henry,

I have changed the cable but problem remaining

And yes I have rebooted hub and rock several times

Thank you for your interest

Set at its default settings the Super Hub should just dispense IP addresses to everything set to DHCP. You could try the command to reset the IP on the ROCK machine. I can’t remember it off the top of my head.
Edit: See if this does anything.

Thanks again Henry

However, if I press enter on the screen as shown above - nothing happens

Try rebooting with the keyboard attached and try again.

Done that thanks Henry - still no reaction when I press enter

I’m at a loss then I’m afraid. :slightly_frowning_face:

Thanks Henry for having a go

I am also stuck

Best wishes


Is the ROCK/NUC connected directly to the BT Hub via a single ethernet cable, or does the connection path go via a switch?

Single ethernet cable Geoff thanks

It is really hard to take the cable out of the ethernet port on the ROCK - could there be an issue with the actual port?

Could well be. Both the Hub and the NUC are saying that there’s no network connection. Shouldn’t be that hard to unplug the cable. Is this a standard Cat5/6 cable, or something special? Also, do you see any activity on the port LEDs?

Chord company C streamer - but also tried a bog standard cable and it’s the same – no, no lights flashing

Is DHCP definitely on? My BT Smart Hub shows ‘DHCP’ where yours shows ‘static’:-


Good catch, I think that’s the issue…

Thanks MIchael

Here is a current screenshot

Which is different from before - but still not connected

Could you try changing ‘Always use this IP address’ to ‘No’, then rebooting the router? Maybe there’s a clash on the network.


So did you have a static IP address set up on the NUC at some point in the past? Strange that resetting the network settings on the NUC (as suggested by Henry) has apparently not had any effect…

Yes we did have a static ip address - but I tried as Henry suggested and pressing enter did not allow me to enter anything - so I could not reset them