ROCK not responding to mDNS queries [resolved 1.0.75]

Just installed ROCK and almost everything went well :grinning: however 1 thing is not going as expected…
On my MacBook running Sierra I cannot access the SMB share. ROCK is displayed in the ‘shared’ tab but when I click the (pc) icon I get a message that the server does not exists or is currently inaccessible


edit: I can see the drive using “connect to server” and then typing in the ip address and navigating to the storage folder.

@support is this normal? It’s not really straightforward

Hi Steve,

Can you try to press CMD-K in Finder (or use Go > Connect to Server from the menus) and enter:

smb://rock/data

and press Connect:

When asked, connect as Guest.

If this fails, enter

smb://ip.address.of.rock/data

Hi @RBM connect to server using ip address and then navigating to the storage works but smb://rock/data gives the same error message

That’s probably your router not advertising the name – or maybe it’s just slow.

For now, just use the IP address. If it really bothers you, you can add

ip.address.of.rock rock

to the /etc/hosts file on your Mac.

I hoped smb://rock/data… would work as the ip address could always change in the future and then I have to add it again.

For now I added the it to my start up items and I can connect as a registered user using GUEST as name

You can get around it by reserving the IP address in your router.

Try rock.local instead of just rock

Running Sierra 10.12.5 Beta on a MacBook Pro and the Roon SMB share shows up and is accessible with no issues.

Did not have to map to it or anything. Nice work guys!

Hi @danny,

unfortunately this is not working… same error server does not exists or is currently inaccessible

the rock.local thing is not working… but rock should be working if you on a mac or windows machine

Hi @danny,
Both rock and rock.local are not working. I can only connect using the ip address.
I’m on a macbook pro running Sierra. In finder I can see ROCK as a share and can click on the icon (pc). However I cannot connect to the server. The error that I receive is that the server does not exists or is currently inaccessible.

Steve

can roon find it and can you get to the web gui the ip?

Sure. Roon finds it and I can accesss the server in finder using the ip address but only using the ip address. Device name does not work. Also ROCK is visible as a bonjour device (pc icon) but inaccessible

I don’t know if this matters or not, but I have my router assign the NUC that ROCK Is running on a static IP address.

I realize this should not make a difference.

@stevev1,
Try to restart your router. Stupid things like this often help …

hi @Arie_van_Boxel,
Did a restart of the Airport Extreme… alas :slight_smile:
Thanks for the suggestion though. It was worth a shot

Hi @stevev1 — Thank you for the report and the continued feedback, both are very appreciated!

Moving forward, to help aide in our evaluation of this behavior you are experiencing, may I very kindly ask you to please provide the following information:

  1. A brief but accurate description of your current setup as seen here.

  2. Please provide the details of your network configuration/topology as well as providing further insight into any networking hardware you are implementing. Based on the information provided thus far, I see you are using an Airport Extreme but would like to have a broader understanding of what the chain of communication looks like across your network.

-Eric

@stevev1: is it pingable?

In terminal:

ping rock

or

ping rock.local

ugh, this router… it does no local dns and its netbios resolution stinks.

well it’s what I use and likely many others as well …:confused: