ROCK not updating

I have Roon installed on an Intel NUC which I can see on the network. It looks like an update is required, but it is not happening automatically. This is when I start Roon on a windows laptop:

If I try to connect to the IP with Chrome I get “Not found”

Not Found

If I try my Android App I get a “Incompatible versions” message, and “Checking for update…”.

Thanks for your help!

I literally just went though this same issue. Looked exactly like what you are showing.

Take a look here for the solution I found:

Specifically, this section helped me:

Once the app was updated and after a few reboot of the ROCK it straightened itself out.

Edit: Once you tap “join” as it says in the instructions you need to wait a bit and then check for updates for the Roon remote app.


The second images you posted shows your Roon core is on early access 1159 but your phone is on 1148. You need to follow the instructions posted on this site to install Test Flight and update your phone Roon Remote to the early access version using Test Flight or whatever app Android uses if not an iPhone.

By the way, you typed in the wrong IP address.


He said it was on Android so not TestFlight but the instructions I posted above.

I did not notice the error in the IP on the first screen shot. good catch.



Now I’m getting the incompatible version error on the PC. I got excited about ARC beta a while back. Might be best to get off early access now.

1 Like

Ha! Thanks. My bookmark worked for years. Looks like it got a new address…


The KB link I posted has download links for what you would need to fix all this, Or, it also has the instructions to leave the early access. Mine straightened itself out after several reboots and restarts of the server and the app on the PC.


I reinstalled Roon and the PC is good now. Thanks for your help!


I am having the same problem. I followed the directions in the KB and installed the file into /Data/Reinstall and have rebooted several times. I still see that I am still have (build 1159) early access.

Sigh. In all these years I’ve never had a problem. I wish I hadn’t joined the ARC beta.

Yeah, something changed recently that stopped the production (non-beta) app from working with the early access OS.

I have two IOS users here with the production app and their eyes glazed over when I started talking about early access. So I reverted back to production. Click that link above and scroll down to How do I leave?. It isn’t too bad.

Sadly, that’s exactly what I did. I followed the How to leave process. I’ve also deleted and reinstalled the app on my PC twice.

I also rebooted my Nucleus Plus.

Fwiw, once you get all your devices on early access, they should all stay that way. If you core is stuck, you can try getting your PC and other remotes into EA. My issue was not getting them all on one or the other earlier.

1 Like

I see. Your ROCK OS is still earlyaccess, so if you moved the correct .bin file all you need to do is navigate to the ROCK ip address in your browser and click Reinstall.

Hi Patrick, that’s the problem, I did do just what you suggest. I followed the directions exactly as they are written in the KB.

I downloaded the “roon-production.bin”. Placed it in the “Reinstall” directory. I then went to the System Status Page and chose “Reinstall” under “Operating System”.

Strange. Maybe it’s a glitch in the Windows app? Have you tried reinstalling the latest Windows download?

1 Like

Interesting - I just reinstalled the EA Windows Remote client, and of course as soon as I launced it, the Win client connected to my Core. Looking at “About”, the Core and the Remote both show EA.

Odd, I am 100% positive I put the “.bin:” in the Reinstall directory. I just looked and it’s not in there any longer.

1 Like

Once you click Reinstall that .bin file disappears.

Yes, that’s what the KB says, and that’s what happened.

Just out of interest, I downloaded the EA Core file just to see what it is named. It is named “roon-earlyaccess.bin”. So I know I downloaded the correct file earlier “roon-production.bin”.

Bizarro maximus.

Patrick - By the way, I appreciate your willingness to help. Very cool of you.

1 Like

It may be a caching problem that goes away after reinstalling the windows app - something Roon might want to check out.

It is impressive how quickly this community responds when someone is having problems!

1 Like