ROCK NUC Core to Devialet D400 no longer works with build 528

System no longer works with build 528.

Nuc Core is visible in Roon until I switch on the Devialet D400 - its connected with a USB lead.
Once the D400 is on Roon loses connection with the Core

Seems to be build 528 that’s caused it. All was fine before this, now the system is unusable.

Any ideas?

Hi @samg,

Are you able to play to other endpoints okay?

Can you describe your current networking setup?

Is it both TIDAL and local content exhibiting this issue?

Thanks for the reply.

Yes I can play through my Samsung phone as an endpoint…with the D400 switched off.

Network is a BT hub with the Core plugged into the ethernet port on an extender in a mains socket (nothing else in that socket) in tbe room with my hifi. There are no issues finding the Core over wifi from the phone which I use as the Roon control, or from my macbook which also has the Roon app installed. .

The issue seems to be specifically with the interaction with the.Core and Devialet D400. They are connected via USB. It worked fine until this most recent build update.

I have disabled tbe wifi on the D400 in case that was causing conflicts but it made no difference.


I have a newly built Nuc Rock Core connected directly to a Devialet D400 via USB.

It was all working fine last weekend, now it’s not.

Roon can find the core on the network, but when I power on the Devialet the connection to the core is lost. Switch off the devialet and Roon finds the Core appears again.

The only change may be the update to Roon v1.7, build 528.

Any ideas what’s gone wrong?
Thanks in advance

Hello @samg,

What Roon Remotes are you using to connect to your ROCK?
Is the behavior the same from all of them?
Have you tried a different USB port/cable yet?

Hello Noris
I have a macbook and an android phone that I use as the remotes. The behaviour is the same with both of them, and I have tried two different usb cables and again the behaviour is the same.
There are two usb connections on the Nuc, both do the same thing.
Ive also tried different ethernet cables to connect to the network.

Is this a problem with the 528 build release?

Is your Devialet connected to the network also (WiFi and/or cable)?
If yes, then it may be an IP conflict between Devialet and ROCK…

Hello. Yes - wifi, I’ll change the configuration tomorrow and remove the wifi connection. Thanks for the suggestion.

Reconfigured the D400 to switch wifi off and no difference. Roon loses contact with the ROCK core when the devialet is switched on. Muscle still plays but I cant see the core in the Roon App.
Was fine until build 528, can I reverse this?

Should say music still plays…

System currently unusable. Cheesed off!

Hello @samg,

Let’s escalate this and get this over to the tech team. I’m enabling diagnostics mode on your account which will allow our support servers to communicate with your ROCK machine.

The next time you experience this failure, please reply to this thread with the local time that it occurred and I will request logs for the period surrounding the failure.

Thanks for your patience, we’ll get to the bottom of this shortly.


Hello John
Thank you for trying to resolve this.

I loaded Roon from the app on my phone at 1902, connection to Core made ok, and switched the D400 on at 1903. Connection to Core dropped 1903.

I tried to select a track once D400 switched in and nothing possible but the track playing last time I tried at the weekend was still playing through the D400 when the connection Roon-Core had been lost

Hope this makes sense

JFYI, I am using build 528 with a D220 Pro on WiFi without issues.

Hi @samg,

Thanks for letting us know the timestamps, we have enabled diagnostics mode for your account and what this action does is automatically upload a log-set to our servers for analysis.

I spoke to the technical team regarding these logs, and we’d like to try an Operating System reinstall to see if it helps with this behavior. To perform this, can you please:

  1. Create a Backup of your current Roon database. The ROCK database shouldn’t be impact here, but it a good idea to make one just-in-case.

  2. Open your ROCK Web UI

  3. Press the “Reinstall Operating System” button on the top left-most side of the WebUI:

  1. Verify if there is any change in behavior with the Devialet following the Operating System reinstall

Any questions regarding the above process, just let us know, thanks!

Hello Noris
Thank you…will do

1 Like

Reinstalled and no difference. Roon finds the core and when D400 is switched on the connection is lost

Is is possible to revert the build level back to the previous version, there were no problems then?

I’m not sure about the D400, but with a D220/D440, either ethernet or wlan can be active, but not both simultaneously. Plugging in an ethernet cable disables wlan. Why not try unplugging the network cable and configuring wifi, which works perfectly with my D440?

Hi @samg,

No, downgrading versions of Roon is unfortunately not supported.

Can you please reproduce this behavior and let us know the timestamps once more? We would like to check to see if there was a change in behavior in logs since reinstalling the ROCK OS.