ROCK on NUC NUC7i7BNH - Install Problem

Hi Eric,

Same problem here with a nuc 7 i7 and bios 63 and image file. I also don’t know witch version, but dowloaded it from the site were teh installation notes are. If theres a solution can you let me know. I want to buy a license for life but need solution first.

best regards, jelmer

1 Like

Hi All,

Same problem. NUC717BNH. Tried many, may time. BIOS 63, used instructions on the ROON ROCK page. I have formatted USB FAT, downloaded the image file from ROON ROCK multiple times/ In Win 10 I see the USB has two items - an apparently empty identity folder and a file 46.4 MB titled roon.tar.bz2. When I go to NUC, I hit F10 to make it boot from USB and get the now all too familiar “Failed to load ldlinux.c32”. I rebooted NUC and F2 into the BIOS to try to insure the NUC was booting from the USB drive. Rebooted NUC. Same error.

I know all are giving this their best effort to address, and I appreciate it. After buying a lifetime membership to ROON, buying the NUC7i7BNH (8GB RAM), 128 GB M.2 SSD, I am down about $1200 (with membership) and still can’t get the NUC to load from the USB Drive. I am stuck at step 5 at

Any and all help appreciated. I have become a big ROON fan and was excited about having a NUC. The excitement is fading and frustration is setting in. Multiple USB drives. Multiple Flashes with Etcher. No luck.

Thanks, Arthur

1 Like

Hi all,

I’ll add my voice to the chorus. Same situation as Arthur above, same NUC, same consistent error message. Looking forward to the solution.

Cheers, Chris

1 Like

Hi Again,

No, I have not identified a solution, but in rereading through this thread it seems that v1.4 would install, and then auto-update to 1.5. Can someone confirm this is correct? If so, is there someplace where I can download v1.4?

This is not my first home-built rodeo. I have built ~8-10 systems, from home PCs to Windows Home Server (yes, I am old), to high-performance workstations (I am a scientist in a high tech area with ~ 20 workstations in my lab), plus having 6 dedicated virtual servers at work. My favorite is my uber-high end home system just recently built for my Vive VR system. It worked perfectly from Second 1 of Minute 1 of Day 1. The one thing I have zero experience in is Linux, as all my instruments run Windows (dang-it). So, while I am far from perfect (ask my wife) I have several, but not all of the fundamentals of PCs under reasonable control (but not an IT jock). Perhaps that is why I am a bit frustrated - it seems I should be able to make this work, but I seem to be missing something fundamental.

I love ROON. It wonderfully integrated my lossless music collections with my Tidal subscription. I love its integration with SONOS (I was an early adopter). What really sold me was ROON’s integration with my Audeze headphones. It led me to buy a Chord Mojo.

I am really looking forward to having my ROON ROCK NUC system running. Until then I feel like I am stuck in a Three Stooges movie (NUC-NUC-NUC). OK - sorry about the terrible pun :slight_smile:

Thanks in advance.



1 Like

I think the issue is being addressed as @eric noted and some time to get things tested and updated to the download site is and will be detailed as and when its done.

1 Like

@eric thanks in advance

My thanks to you and your team. Many of us are looking forward to the fix.


I too am having the same issue. I have downloaded the file multiple times, I have tried flashing from 2 different computers, 2 different flash drives, flashing zipped and unzipped.

The image file is roonbox-linuxx64-nuc3-usb-factoryreset-100000158 and downloaded from

The NUC7i7BNH is updated with bios 0063 set on legacy. The thumb drive once flashed shows roon.tar.bz2 file and a folder named “identity”. The folder is empty. The error message is “Failed to load ldlinux.c32”.

Please help! Thank you.

1 Like

Sorry for the trouble here, guys. We should have a fix for this soon.


All – The fix mentioned in Mike’s previous is now available. Please re-download the ROCK image and verifying what the experience is like during the install process.


1 Like

5 posts were split to a new topic: NVME + NUC (ROCK) causing kernel panic

Dear Eric,

I tried the new version and it went very well.
My Roon Rock is running.

Thanks for your support.


Thank you! Worked perfectly - up and running on a Zotac mini pc! I had all the same issues with the previous download earlier today.

Yay. Mine has also worked. Busy upgrading now and importing music…

Thank you!

Thank you for the fix I was able to install the NUC.

Worked perfectly here too. Thanks!

Now is working well, many thanks to all Roon staff @mike @eric and @support team

I was able to install on a NUC7i7DNH Dawson Canyon and it works great.
Thanks for all of the work on this.

Thank you for the update. The Roon Core now installs easily.