ROCK on NUC NUC7i7BNH - Install Problem

Hi Guys
I’m trying to install ROCK (last version) on my NUC7i7BNH with BIOS version 0063 (I have tried many older version too). I followed the instructions to turn off UEFI boot, enable Legacy, enable USB Boot, SATA drive is listed first. I then used Etcher on my Mac to create the ROCK image on on several USB sticks of varying sizes (all > 1GB).
When trying to boot to the USB image on the NUC, the error message “Failed to load ldlinux.c32” always appears.

I think this is not a new topic but I can’t found the solution yet!

Any ideas of where to proceed next?

Marcos Galuzzi

I am having the same issue and I’m on a NUC7i5BNH with BIOS version 0063.

here a link to thread, says Solved by downloading new image… which tells me that you may have a corrupted image and need to download it again.

I tried that and it didn’t work. I even tried doing it from a different computer. Still didn’t work.

I can see the ldlinux.c32 within the boot directory on the drive.

Also, I have tried using etcher to flash the drive. I have tried using dd from my linux machine. I still get the same result no matter what I do.

lets add @support so they can chime in.

Where are you downloading the new image from? We did have an issue here but the current image should be fine.

Can you let us know the exact steps you’re taking to download and flash the NUC with the newest image? Then maybe @support will be able to recommend next steps here, Melissa (and @Marcos_Martins_Galuz)

Thanks guys, appreciate your patience!

Just to update, a friend gave me an older version of it (100000069 to be exact) and it worked for install.

1 Like

I have download it from here (
Used Etcher to flash IMG file, select the USB stick, then select Flash.
Placed the newly flashed USB stick in the NUC and boot it up. After this I got the error…

@Melissa_Mesler could you send me these older version to try it here?
I would really appreciate!

I am having the same problem having followed the same steps with my NUC7i3.

All – Thank you for the feedback and sorry for the troubles. We are actively looking into this issue and I will be sure to update this thread accordingly once our tech team has updated my report.

In the meantime, if you could please confirm that the following is definitely not working for you I would greatly appreciate it!

Version 00000157 / BIOS version 000063.


It definitely didn’t work for me. I tried MANY times. But version 00000069 did. And I flashed the drive in the same exact manner using Etcher.

Hi @eric
Build 00000157 BIOS 000063

BIOS 00000069 ?
For Intel® NUC Kit NUC7i7BNH
BIOS Update [BNKBL357.86A]

Version: 0063 (Latest) Date: 4/13/2018

sorry my info is wrong… correct version is Build 00000158 (lastest version available in Roon Labs site)

Please excuse my newbie ignorance. How do I see which version I am trying? I downloaded this today from the roon rock setup page: roonbox-linuxx64-nuc3-usb-factoryreset.img.gz.

If you unzip the .gz or just open it in your zip program of choice (like 7zip) you will see the version number in the .img file name like this:

LOL mine is a very old one.

Actually the latest version I downloaded doesn’t have the version number. It just says “roonbox-linuxx64-nuc3-usb-factoryreset.img”

Interestingly enough, when I download it again today and I gunzip it, it shows the version now. Hmmm… Maybe they had a bad image up.