ROCK on NUC slow and I don't know why

Have ROCK installed on NUC717DNFE.
Use a ReadyNAS 212.

Scans are frequent and even when not scanning starting a new song takes too long should be immediate. 10-30 seconds to start a new song :frowning:

Switched to NUC from MacBook Pro Roon. Did not see the same issues with MacBook Pro and ReadyNAS.

Should I get an external SSD and see if I have the same issues or install Ubuntu 16.04 and see if the Roon Software performs more acceptably.

I’ve moved your post to the Support category, and flagged @support for you. It sounds like a networking issue between the NUC and your NAS to me, but they should be able to help you better.

One thing, if you want to move your music off your NAS to an external drive attached to the NUC, you don’t need to use an SSD. An ordinary HDD is perfectly suitable for music. The only reason you might want to go for an SSD is that they are silent - no mechanical noise.

What RAM and SSD?

16GB RAM
128G M2 SSD

I will crack it open if you want model names since it is all preinstalled by simplyNUC.

https://simplynuc.com/7i7dnfe-full/

Yes HDD would be fine and so should the NAS. The noise was what I was trying to avoid which is the reason for a fanless NUC. I ran the NAS on MoOde over wireless to RPi and MacOS using Jriver for a few years and no issues or slowdowns other than the NAS crashing once or twice.

The ReadyNas 212 is only 2GB RAM Quad core 1.4GHz High Performance ARM Cortex A15
3TB x 2 HDD’s (RAID 1)

2xGigE into dual channel router.

Hi @Donald_Skanes,

Can you describe your network setup here? What networking hardware is in use and how are all of your devices connected?

Can you verify how many tracks you have in your library?

Does this occur for all endpoints? Are the endpoints networked as well or are they connected to the NUC via USB?

My switch/router is a Netgear AC5300 Nighthawk X8 where my Netgear ReadyNAS 212 is connected. To get to my “music” room I have powerline TP-Link AV600 600mps or just use wifi for some things such as a shield and LG TV for the apps, Roku’s, apple TVs etc.

My internet connection is from Comcast Xfinity and is GigE speed (968mbs or so) not that this matters.

I just now found a lot of latency to my NUC due to a loose RJ45 connection. Was showing approximately 115ms latency now showing about 6. So I will try this today to see if this fixes some issues. Right now it is scanning and I wish I could turn that off somehow.

8473 Tracks so not really huge but growing as you would expect.

Another problem…
I am directly connecting my NUC to a Singxer digital interface via USB which connects to a Gustard X20 DAC using I2S. This link drops occasionally and disappears from the Roon config. When that happens I switch to directly connecting to Gustard X20 USB to NUC.
Right now for example the Singxer connection is not showing as a roon connection. This seems to be a different issue than the network problem but also frustrating as it is my favorite connection. I am not sure what sequence I used before to get it back but I think I restarted everything after scanning stopped or something like that.

I have a RPi 3 (with HiFi Berry +) bridged also and I connect that to either the X20 Dac or digital interface when the direct conection disappears from NUC. So this would be over ethernet connection using power line.

Also have a Marantz SA8005 I connect to as another alternative DAC.

I will find out soon if the bad RJ45 connection was my network problem. I would assume so but there is this other issue with the Digital interface dropping off. And when scanning starts I need to just do something else such as listen to vinyl.

I am Unix system admin as a profession and am wondering if I should switch to Ubuntu 16.04 Desktop from Rock. I would have more control over the NUC and be able to analyze problems easier than with the rock. Seems like rock is using 10gig of disk space and I have 128. Can’t tell how much memory but I have 16G. Probably less than 4 being used.

Thanks for any help or direction. I love the ROON product and anything I can do to improve I am willing to participate.

I am open to switching to SSD external drive if the network or NAS is not sufficient for my setup. More expense but whatever works to optimize my listening experience.

Seems I still have some latency issues. >100ms seems high and I am looking into how I can improve that. I guess local external drive would be a quick fix.

Powerline adaptors cause problems with roon and the usual recommendation is not too use them.

1 Like

Yeah seems the latency over power line is un-predicable in my case. Latency ranges from 6 to hundreds of ms over time. Not good.

I got rid of mine and went mesh wireless. Why didn’t I do it earlier?

1 Like

Swapped out the power line for a AC3000-Nighthawk X6S Tri-Band WiFi Mesh Extender.
Latency now < 6 ms to the NAS and there should be plenty of bandwidth using the ethernet from the extender.

Have a 2TB HDD as a backup plan that I wasn’t utilizing so I may try that if things are bad.
I was going to buy an external SSD but the salesman at Fry’s talked me out of it thinking the prices would drop soon.

I still wonder if I would have more control using Ubuntu 16.04 and roon server. I may do this yet.

Hi @Donald_Skanes,

How are things going since you switched to this configuration? Is there any improvement?

It would definitely be a good data point to know how things go when the library is directly connected on a drive instead of accessed over the network.

Have you noticed any patterns in when this occurs? If you reboot the Singxer does it appear in Roon again?

The scanning issue seems to have stabilized now that I am not messing with the network and with the wifi mesh extender rather than powerline. The latency seems more consistent between the NAS and NUC which seems to be helping. I have two channels running at the moment and no delays in changing songs. One channel going directly from the NUC to the DAC X-20 USB and I have the RPi bridged to the Singxer to the DAC X-20 via I2S and of course they both sound amazing as I expect. The route from the NAS to NUC to RPI is also stable.

I may try the HDD yet after I test the NAS config a few days.

I have not been able to get the Singxer to show up again in Roon when going from the NUC to Singxer to DAC. It shows up if I go from RPi to Singxer to DAC though which is odd. I don’t know how to get it working again but I swear it was working for a couple of days. The only thing I can think was I tried the HDMI from NUC to a NAD T187 and never got that working just yet and that’s about when the NUC to Singxer problem started happening which could be just a coincidence.

Trying the HDD the scan was very fast within a few minutes for my library. Not sure why I am so stuck on NAS when this may be a better solution. I don’t expect any glitches or slowdowns since it is directly attached even though it is USB.

I guess the latency/bandwidth isn’t a factor which is to it’s advantage. Would internal SATA SSD make any noticeable difference since it is lower latency?

I tried reinstalling the OS from the System status page but had problems reconnecting so I then reinstalled Rock from USB.
Still could not see the Singxer from the NUC in the list. Also just reset the database and that also did not seem to help bring the connection back. Very strange, not sure what that problem could be.

Hi @Donald_Skanes,

I have enabled diagnostics on your account so our technical staff can get some more insight into what’s going on here. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to pass the diagnostics over to the team for further analysis.

Thanks any ideas about why the direct connection from core to Singxer to DAC would be appreciated. I did try again to swap the USB over to the Singxer SU1 but did not display.

The core to HDMI I am not sure either but this is lowest priority. 5 HDMI connections show and there are only 2 ports. I tried connecting to my NAD T187 and tried enabling all of them but no audio. I didn’t spend much time on that.

Hi @Donald_Skanes,

We’ve received the diagnostics report and I’ve passed them to the tech team for analysis. They’ve asked me to confirm with you what model Singxer USB interface are you using?

In regards to the multiple HDMI interfaces, this is actually what the ALSA interface is reporting to us on the NUC. Each NUC is different, so it may take enabling the zones until you find the one that works in order to get HDMI to work correctly.

The model is same as
https://www.shenzhenaudio.com/singxer-su-1-usb-digital-interface-with-xmos-xu208-cpld-dsd256-dop.html?p=4

Singxer SU1 XMOS XU208

https://download.shenzhenaudio.com/Singxer/
Note the above Shenzen Audio page has a link to a driver on it. Is there a way to install/update the driver on ROCK?
Maybe not needed since I found this…
1:windows7,windows8;32/64bit,need install dirver. 2:Native Mac os 10.6 and later,without driver.
3:Native Linux with NAC2 compliant Kernel, without driver. 4:Android OS 4.2 and above, need support OTG function.

I did update the firmware few months ago.

HDMI 0 now working on the NAD T187 and also sounds very nice…