ROCK on NUC stopped reading USB attached HDD

Roon Core Machine

NUC7i7BNH with 8Gb RAM running ROCK version 1182

Networking Gear & Setup Details

Connected Audio Devices

USB 3 TB HDD with power

Number of Tracks in Library

~40,000 tracks

Description of Issue

Roon is not reading the attached HDD so only Tidal and Qobuz albums are showing. HDD has been checked by attaching to a desktop PC.

Did you try and power cycle the NUC?


Roon Core Machine

NUC7i7BNH 8GB ram 256 GB internal SSD running ROCK version 1182

Networking Gear & Setup Details

Ethernet and Wifi. Ethernet on TP Link router. Wifi using TP Link Deco X60 Mesh

Connected Audio Devices

Attached powered HDD on USB port.

Number of Tracks in Library


Description of Issue

Worked well for many years but suddenly stopped reading the attached Hard Drive library.

@Subroto_Banerjee, please avoid posting the same request multiple times. Thanks.

Yes I turned it on and off. I rebooted it too. Restarted the Roon server.

Sorry. Didn’t mean to.

1 Like

Hi. Any update on my query?

Is the HDD formatted as NTFS? When you checked it on the PC, did you run a chkdsk /f ? After doing this, did you do the proper “remove safely” procedure?

1 Like

Also, for testing purposes, do you have another external USB drive to plug into the NUC to verify your USB ports.


This has been used for a couple of years and worked fine. Just stopped working with the NUC in the past couple of weeks. Nothing else was plugged in or removed from the USB ports. Just stopped working.

Please answer the questions of @Suedkiez:

  • Is the HDD formatted as NTFS?
  • When you checked it on the PC, did you run a chkdsk /f ?
  • After doing this, did you do the proper “remove safely” procedure?

The HDD is formatted as NTFS.
I have run chkdk /f on my desktop. My disk was ok.
I am able to see all my music files and the directory for them on my desktop PC.
The last backup on a subdirectory on the HDD shows January 11, 2023.
The last music saved to the music directory is December 26, 2022.

For whatever reason, the ROCK is not seeing the music directory.

OK, some things ruled out then - this was a very common issue after the RoonOS build 254 update.

This leaves for now:


Does that mean that in Roon > Settings > Storage it can’t find the music storage folder / is not possible to add it because it can’t find the disk here?

You didn’t confirm that you had removed the drive safely from your Windows PC before reconnecting it to your ROCK/NUC. Did you?

Geoff, I don’t understand the relevance of your question. The HDD stopped being recognized by the ROCK while attache to it. The only change I made was to change the ethernet cable to the ROCK. When I later checked the HDD on my PC, I took care to stop the drive before removing it. I checked it again after and it still works fine

You didn’t say this earlier. So you did in fact follow the steps given in that Microsoft support article to remove the HDD from your PC safely?

My ROCK is installed on a barebones NUC. How is Microsoft relevant when we talk about my HDD attached to the ROCK? Again, as I repeat, the HDD works by itself. The ROCK doesn’t see it.
Should I try deleting the path for storage on my Roon set up and then try seeing if the ROCK finds it?

I had this over the Xmas holiday after a couple of house power outs.

I had to put the attached USB drive into another PC and do a drive repair (which the PC detected was required). After that the USB drive was good to go again on the ROCK NUC.

I concluded that the hard power cycles had left the drive in a weird state.

1 Like

Because when you attached the HDD to your Windows PC to check it, and run the chkdsk command, it is important that you remove it again from the PC safely - and not simply unplug it.

If you don’t follow the steps to remove it safely then there’s the strong possibility that the HDD still won’t be seen by your Roon Core when you reconnect it to your NUC - which seems to be the case…

Thank you for the explanation. However that still doesn’t resolve my original issue.
I will just try to delete the path to the storage in Roon settings and try to see if the Rock will see the drive.