ROCK on Skull Canyon NUC: No HDMI output to Denon AVR

I cannot get ROCK 1.5 to output over my Skull Canyon NUC HDMI connection to my Denon AVR.

I understand Skull Canyon (NUC6i7KYK) is not one of the supported NUCs, but I have not found information on this forum where it says that it doesn’t work. I have found a topic where there is a problem with the HDMI 2.0 output that is fixed with an HDMI 2.0 firmware update from Intel. I downloaded the update but the instructions seem to be for a NUC running windows. I don’t know how to run this update with ROCK installed on the NUC.

Does anyone have information on how to install this update?

Are there any other suggestions for fixing this problem?

Detailed system information:
ROCK OS, Version 1.0 (build 158) stable
Roon Server Software, Version 1.5 (build 339) stable
Audio Connection, HDA Intel PCH HDMI 0 (ALSA)
NUC, Skull Canyon (NUC6i7KYK) with single HDMI connection
Denon AVR-X6200W

Does the HDMI channel show up in Roon at all? On my NUC running ROCK, it shows up as the HDA Intel PCH HDMI 0 channel:

Yes, I tried the HDA Intel PCH HDMI 0 on my setup, just like in your screen shot. In fact, I tried all three without success.

Here are a few more details.

Thread about the HDMI 2.0 firmware update:

My Denon AVR connection:
I have the HDMI cable from the NUC connected to my Denon DVD connection. When DVD is selected on the Denon, the front panel indicators for channel source show no channel inputs are being received. This leads me to believe that the NUC is not outputting a signal on the HDMI connection.

It may be down to the device settings. I have a Denon 3808, and I needed to have the following settings made in Roon for proper stereo/multichannel playback:

Thanks for the screen captures. My settings match yours, which I believe I got from one of your posts on another thread.

One other thing occurs to me - the issue may be caused by the display device that you have attached to the HDMI output of your Denon.

For example, for years we had a Panasonic LCD TV attached to the Denon, and Roon and the Denon worked fine. We’ve just got a Samsung Q9F, and this has caused a number of problems with the HDMI handshake. For example, on the old TV I could see the text message from ROCK giving the device address. With the new TV, that message does not appear. Even worse, the Denon won’t see Roon (no indication of the input channels on the Denon display - the same issue as you describe). I now just make sure that the TV is switched off when I use Roon with the Denon. You may need to reboot your NUC as well.

I have a Vizio TV connected, but most of the time I leave it off when I play music. I recently had the NUC power disconnected so it has a fresh reboot.

I have a Sony receiver which I will try with the NUC to see if that will connect via HDMI.

I looked at the Intel HDMI 2.0 firmware upgrade link more closely and noticed that the date of release was 2016. I purchased my NUC this past March, so I don’t know that it already has that fix in it. I don’t know how to check for that right now.

First, I tested with a second HDMI cable to make sure it wasn’t a bad cable. No change.

Next, I connected the NUC HDMI to my less expensive Sony AVR with no speakers connected, only headphones, and got 2 channel sound. I knew then that at least 2-ch sound was being broadcast over the NUC HDMI.

I connected the NUC HDMI to several different HDMI ports on the Denon AVR; none worked. I plugged in headphones but no change. I set the ROCK device setting to 2-ch and no change.

I then plugged the NUC HDMI into the HDMI Input on my Oppo UDP-205. I selected ‘HDMI In’ as the input on the Oppo and ‘BluRay’ as the input on the Denon AVR and it worked. I can play 2-ch and multi-channel, PCM and DSD files. The TV will act as the monitor and show the ROCK message, so I will have to turn off the TV when I do this to avoid burn-in.

I guess there is some kind of incompatibility between the NUC and Denon AVR-X6200W HDMI connections.

Thanks for your suggestions, Geoff.

I was one of the unfortunate people who upgraded the DAC firmware on their UDP-205 from 0112 to 0118 and lost the capability of playing native DSD files from ROCK. As far as I know, Roon has not come out with an update to fix the problem.

Given that the AVR-X6200W is not the latest model in the Denon range, it really should be working with the NUC. There must be something that we are missing. It hasn’t got audio pass-through mode set on, has it? Have you tried different HDMI cables?

I don’t recall seeing an “audio pass-through” option anywhere in the setup menu.

I did try another HDMI cable that is rated for 4K video, but it made no difference.

I haven’t installed the HDMI 2.0 firmware update, so I consider that a possibility. I guess that takes me back to my original question: How do I install the update on a NUC with ROCK installed?

When I first got the NUC, I updated the BIOS before installing ROCK. That was no problem. Hopefully, someone who has performed the HDMI 2.0 firmware upgrade on a NUC with ROCK can comment on this.

I think you’ll find Audio Pass-through under the HDMI menu in the Denon (that’s where it lives in my Denon). It’s possible that you do need to install the HDMI 2.0 firmware update. I haven’t done that on my NUC, but then my Denon is older than yours.

And, yes, if the Intel update will only run on Windows, then it looks as though you’re going to have to temporarily install Windows just to get the update done. PITA, I’m afraid.


Here’s a picture of my setup. The HDMI Control is ON.

I didn’t find an audio specific setting.

Regarding the NUC HDMI 2.0 firmware upgrade:

Here’s my thread on the Intel Communities forum that gives lots of good details:

Basically, I had to run the HDMI 2.0 firmware upgrader program to find out what version of firmware was installed on the LSPcon IC. To do that, I had to install Windows 10.

Fortunately for me, I had created an image of my NUC with Windows 10 before I installed Roon ROCK on it. First, I created a current image with ROCK, then loaded the previous Windows 10 image and updated the BIOS from 053 to 055. I updated Windows and all drivers and ran the HDMI 2.0 firmware upgrader to verify the LSPcon IC firmware version, which did not require an upgrade. I also installed JRiver MC and experimented with that. I then created a new Windows 10 NUC image before reinstalling the ROCK image back onto the NUC. It booted up without any issues and I was back up and running with Roon.

I connected the HDMI cable to the Denon AVR and the results were the same as before. I found the HDMI settings that Geof pointed to but I didn’t change anything because it looked to be configured correctly. Is it?

At this point, until further information comes to light, I will connect the HDMI cable to the Oppo UDP-205 since it works without any issues.

That “Pass Through Source” setting in the Denon 6200W is set to “Last” - what happens when you change this to an alternative (unused?) HDMI input? (I don’t have this setting available on my older Denon)

In addition, you have the HDMI Pass Through setting “On”. I have it “Off” on my Denon.

I’ll try that now.

If you can’t get it working with the Denon, and fall back to the Oppo; then be aware that the Oppo will NOT accept multichannel input via RAAT over HDMI, only stereo…

Here’s my setup:


  1. Changed AVR setup.
  2. Turned off NUC.
  3. Turned off AVR.
  4. Turned on AVR and waited for complete startup.
  5. Set AVR input to HDMI connection (DVD).
  6. Turned on NUC. (the NUC bootup screen showed on my TV but the ROCK screen never appeared.)
  7. Set Roon to the HDMI setup.
  8. Played 2-ch 44.1KHz FLAC file but no sound was heard.

I don’t recall seeing the NUC bootup screen before. I get the ROCK screen when it is plugged into the Oppo.

OK, let’s try two things…

  1. set the Video Output from Auto to Monitor 1 (assuming your monitor is on monitor 1). Power cycle both the Denon and the NUC and see what happens.

  2. Last resort time - I’ve seen a NUC needing to be directly connected to a monitor and rebooted to correct HDMI handshake problems. Try that, and then reconnect to the Denon. You really need to see the ROCK text appear on the attached monitor - that will indicate that the HDMI handshake has completed correctly.

I tried both, but no luck.

I connected the NUC to an HDMI port on my TV and the NUC bootup screen was visible but not the ROCK screen. The Oppo HDMI connection is the only one that shows the ROCK screen.

Damn. Sorry, but I’m out of ideas here. And sorry that it’s still not working for you. I hope that someone else has a flash of inspiration…