ROCK Searching for network address

Yes, I believe this version should be compatible.

The NUC7i7BNH is technically a Baby Canyon , but the Ubuntu doc does list the following, so it does sound like the image is still compatible:

1 USB 2.0 or 3.0 flash drive (4GB minimum for Dawson Canyon NUCs, 2GB for older generations)

Okay here we go…I attempted to install Ubuntu onto my Intel NUC. It failed to install…I know it failed to install because I saw a screen that came up and said something like “if you see this screen your ubuntu install has failed”. I have no idea why the install failed. I went into single user mode and I was able to get a shell prompt. I ran this command…journalctl -xb I think this command dumps the system logs?? It printed out about 5000 lines of stuff that I didnt understand. Some of the lines were in red which is probably bad. If there is a way to take those 5000 lines of stuff and put them onto a USB drive I would be happy to send it to anybody who thinks it would be usefull to see it. Not sure how to proceed from here. I’m still sitting in single user mode at a shell prompt so if there are any commands you want me to run please let me know. I hope this is helpful to someone. Thanks --Tim

Okay so the root cause of ROCK not working was that it was unable to get the MAC Address (Apparently in the Linux world it is called Serial). I now have ubuntu running in single user mode and I have a terminal shell up. Are there any ubuntu commands that will show you the Serial? If ubuntu is ALSO unable to get the Serial then I will be convinced that I now have a worthless NUC. I still dont understand though how BIOS is able to display a good serial. Woudlnt BIOS, ROCK, and ubuntu all use the same methodology for getting the Serial? – Thanks Tim

Purely as a data point… I have a NUC7i5BNH with BIOS version 0081 and ROCK Version 1.0 (build 183) running without issue.

2 Likes

Thanks Wake, That is one seriously valuable data point!! Part of my problem here is that I need to convince Intel that my NUC hardware is bad so they will replace it under their warranty program. They have not been very good about this which is very unfortunate.,

Victor at Intel warranty support needs to know…

would you mind telling me if the people from Roon labs gave you any inside about what was the drivers that you currently have, or if you already had all the necessary drivers up to date?

I have a NUC7i7BNH with BIOS version 0081 and ROCK Version 1.0 (build 183)
I would assume that since this is the latest version of ROCK it would contain the latest versions
of the necessary device drivers Can support confirm this? Also what is your opinion on my ubuntu questions posted earlier. Is there an ubuntu command that will show me the MAC address (Serial??) of my NUC? Will this command function correctly in single user mode?

Thanks --Tim

Hi @TKelly,

We aren’t aware of any driver issues in the latest build of ROCK, and others have confirmed that this BIOS and the latest RoonOS build is working properly on their end.

Since Ubuntu is also having difficulties installing here, this would further suggest a hardware issue at play here.

You should be able to find the serial number and mac address from terminal by using these two commands, listed in the guides below:


If you wish to help clarify if the Ethernet port is playing a factor into this issue, you could try using a USB -> Ethernet adapter with ROCK.

Generally speaking these kinds of adapters have worked in the past when troubleshooting broken Ethernet ports, so if you happen to have an adapter around it would be a good test to eliminate one possible hardware aspect.

So for S&G on a Saturday morning, I just updated my bios to 0081, so add another data point, I now have a NUC7i7BNH with BIOS version 0081 and ROCK Version 1.0 (build 183) stable running without issue.

1 Like

Okay thanks for doing that!! I was able to partially install ubuntu so that I could get a terminal (shell) in single user mode. I did a couple commands ifconfig -a and ip link show. Looks like ubuntu is also unable to get the MAC address so I’m convinced that my NUC is dead. Hopefully this will convince intel to replace my NUC. They have a 3 year warranty. thanks everybody! --tim

I now have the same problem. NUC is a NUC10FNH and Roon installed fine after tweaking to get Legacy usb startup to work. Roon Core functions, but no serial. I do get the webpage, but also it shows no serial. I had to use a usb-to-lan adapter to get so far; the NUC’s lan did not get any connection. I don’t feel this is a hardwareproblem. Any suggestions what to do next?

So here is what I discovered was the root cause of my problem. ROCK was unable to get the Serial Number which is really the MAC address. It turns out that in the BIOS settings I had the LAN disabled. Try enabling your LAN in the BIOS and hopefully it will be able to get the Serial number (MAC Address). I figured this out because I returned what I believed was a faulty NUC. Intel was kind enough to send me a new NUC. I had the same identical problem on the new NUC so I knew it was NOT faulty hardware. After being up all night and lots of coffee I realized that the LAN was not enabled. Hope this helps somebody!

Tim, thanks for your post, but I suspect that @Jan_de_haaij has a different issue. He’s using a NUC10, and we know that ROCK does not yet have the LAN driver for the NUC10 models installed (Intel have changed the hardware from what was in earlier generations). Therefore he’s had to use a USB LAN adaptor. I think the BIOS settings would only apply to the on-board LAN, not an adaptor, and it does seem as though the LAN is working (he’s got the Web Administration Page showing).

However, it appears as though ROCK is not taking the MAC address of the LAN Adaptor and using it for the Roon Serial Number, but is continuing to look at the on-board LAN hardware. Since this is not working, then the serial number is not being set.

This raises the question (in my mind) as to what others who are using NUC10 models with ROCK are seeing as their Roon serial numbers?

Thanks for answering the question. A LAN driver issue makes perfectly sense I’d think. Are there any known experiences as to how long the ROON team takes to provide updates in similar cases? Apart from the hassle installing ROCK (getting Legacy USB to operate) I think the NUC10’s are compatible for ROON ROCK. Even though I now understand why ROON haven’t listed the 10th gen’s as compatible… One small addition: I wonder what other people see when thay open the ROON webpage. I see a very limited set of options and am curious whether it is normal or due to the missing MAC address (later I might try to add a picture of it).

Hi @Jan_de_haaij,

As you have noted, a NUC10 is not a supported model, so there may be issues that you experience with this model type. According your your WebUI screenshot, it also appears that you are missing the codec package, here are instruction on how to resolve this codec aspect:
https://kb.roonlabs.com/Roon_OS_Missing_Codecs

Thanks Noris, I managed to include the codecs and all is working fine. So when Roon provides the LAN driver, the USBtoLAN converter can go and the serial will be shown (I suppose).

1 Like

And in the mean time a serial is showing. Strangely enough after installing a 2tb internal disk, which was very easy to install. I’m starting to enjoy the qualities of Roon and are going to pay for the lifetime version. I would encourage everyone to go for the NUC10, so Roon will hurry to provide the LAN drivers for it to prevent complaining customers. Apart from the need of an USBtoLan adapter, it works briliantly now. Now my Akasa Turing FX should arrive… By the way, am I imagining the sound improvement from the Meridian C10/Ensemble to NUC/Roon/Meridian210?

1 Like

In the mean time my NUC10 works without any problems, even not using an USB to LAN adapter. I learned from reviews that there is no sensible reason to buy a NUC10 vs a NUC8. So, I was a bit foolish to want to have the latest NUC. Just buy a NUC 8 and it’s cheaper as well. Roon furthermore -coming from Sooloos- works very satisfying.

1 Like

NUC10 is now an officially supported platform, no need to use a USB -> Ethernet adapter any longer:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.