ROCK Searching for network address

Hi @TKelley,

Thank you for letting me know the NUC model and additional info and apologies for the slight delay in getting back to you here, I wanted to discuss proper troubleshooting next steps with the technical team.

As for the next steps here - would it be possible for you to try to install Ubuntu on this NUC (as a test) to see if other operating systems are working as expected?

This will help clarify if there are any hardware issues or if this behavior is stemming from another aspect. Thanks!

Hi Noris,
I would be happy to try installing ubuntu onto my NUC. If you can send me a link with install instructions and a link to which ubuntu to download / install I can do it. I am an embedded software developer so I dont need complete details just a little direction / guidance. You guys hiring? I’m almost positive this problem is that ROCK is for some reason not able to get the MAC address out of my Intel NUC7i7bnh. In the BIOS it looks like a valid MAC address. When ROCK boots up the "Serial: " field is blank. (See my screenshot in prior posts). An earlier post made me think that the Serial field is actually the MAC address of the NUC. I am using BIOS version 0081. Thanks --Tim

If you’re not a Linux guy, then WIN10 will also give you information about your Ethernet port.
You don’t have to buy a license to use WIN10.

The iOS app Fing will tell you if your machne is on the network.

I have a machine with five Ethernet ports. When I first put ROCK on it, I got the same ‘Searching for network address’ as you. As it turned out, I had the Ethernet cable plugged into an unenabled port.

I know that you only have one Ethernet port, but it sounds to me like that port is bad.
The fact that it doesn’t show up as connected in your router is further proof.

Have you ever connected to the internet using this NUC?

Just another user kibitzing here, feel free to ignore.

Hi @TKelley,

I have not installed Ubuntu myself on a NUC, but Googleing reveals the following guides:

I understand your concern here and I will mention it to QA. If there are other hardware issues at play though, we are hoping that testing on a different OS will help reveal them.

Pardon me for jumping in, but is this NUC the one that you started using back in September 2018? And you’ve just updated the BIOS with version 0081 that was released in January 2020?

If the answer to both is yes, then presumably the NUC and ROCK were working perfectly up to the point that you updated the BIOS?

Since you say that you’ve confirmed that your ethernet cable and router port are both good, then either your NUC ethernet hardware has coincidentally failed when you upgraded the BIOS, or there’s something about the latest BIOS causing an issue with ROCK. Trying an alternative OS may help shed some light on what’s going on.

I’m sorry I do not have time to install uBuntu onto my NUC. Just dont have the time. Geoff yes same NUC as September 2018. I recently got it out of the garage and installed the latest BIOS and the latest ROCK and apparently they do not work together. I’m convinced this a ROCK problem with that version of BIOS. When ROCK boots up apparently it displays the MAC address of the NUC in the "Serial: " field? Why not display "MAC Address: " on the screen instead of the serial number. That is very misleading and confusing. Can anybody confirm that it IS the mac address that is displayed in the Serial: field when ROCK boots up? Also my ROON experience has been dead in the water for several days now. Why is this taking so long? It is VERY reproducable and it is a well defined problem. Unfortunately not totally impressed with Roon’s support and handling of my dead NUC.,

Just checked mine and it is indeed the mac address that is showing in the serial number on the Rock screen.

Possibly it’s because you are the only person to have reported this so far, and you may not have noticed, but I suspect that the Roon team have their hands full in dealing with an issue that has arisen with the latest release of Roon and certain combinations of versions of Android and a subset of graphics hardware. This issue is affecting a lot of people, so I think it is understandable that the team seem to be addressing this with a greater priority.

We also won’t know until someone else installs version 0081 of the BIOS onto a working NUC with ROCK whether your issue is in fact reproducible.

OK, its snowing here today and I have nothing better to do, so -

I have a NUC7i5BNK with BIOS 0081 on it.

It’s my general purpose NUC; e-mail, surfing, spreadsheets, etc.

I removed the WIN10 M.2 drive and installed a blank M.2 drive on which I installed ROCK.

Once ROCK booted up, it returned a network address without a problem.


So, not ‘very’ reproducible on a machine other than yours.
Either your BIOS install was somehow compromised, which is unlikely, or your Ethernet port has gone south.

What can they do unless you try another OS to begin to determine if it’s your Ethernet port or ROCK software?

You can install WIN10 from here. For what you need to do you don’t need a license.

The whole process shouldn’t take more than 30 minutes.

Once WIN10 starts to install it will try to call home, you will soon know whether it’s a ROCK or a hardware problem.

Again, just another kibitzing user. As always, feel free to ignore.

1 Like

That’s great Slim, but I dont have a NUC7i5BNK . I have a NUC7i7BNH. Its on their list of supported NUCs. Thats why I bought it. You need a MAC address before you can connect to a network correct? So why is ROCK printing out a completely blank MAC address on the "Serial: " field on the screen? (See my previous screenshot). If I’m going to shell out $600+ for a Roon license I have expectations that it shouldn’t take a week to resolve a relatively simple problem. When I go into BIOS setup, BIOS is able to display a valid MAC address. Is there a way to enable (turn on) debugging messages in ROCK?

All GEN7 NUCs should get the same 0081 BIOS, regardless of the CPU. The BNK vs. BNH designation just refers to the case type.

From the Intel website -
With the Core i3 and i5 models, the only difference between the two “BNK” and “BNH” models is that the latter unit is slightly larger to include an additional SATA 3 port for a 2.5-inch hard drive or solid state drive measuring up to 9.5 mm thick. By default, both the BNK and BNH units provide an M.2 SSD slot for SATA 3 or PCIe x4 Gen 3 NVMe or AHCI SSDs that play host to the operating system installed by the user. The Core i7 unit automatically comes with both storage connections.

Dunno, but if I had to make a guess - I would say it’s because your Ethernet port or chip (more probable) is no good.

I think, if you would just do as suggested by myself and others and try to put another OS on your machine you will start to find the problem. Easy enough to do.

1 Like

Hi @TKelley,

I brought up your case with QA today and they have inquired if this NUC has ever worked with another Operating System?

As @xxx tested on the 0081 BIOS with no issues, this is starting to look like it might be a hardware issue, and testing the NUC on a different OS is the proper next step in troubleshooting.

You seem to be the only one affected by this behavior and we don’t yet know if this NUC ever worked properly on any OS, so this is something that should be confirmed first.

When your NUC boots up ROCK is there a valid MAC address that is printed out in the "Serial: " field.?
When I go into my BIOS setup, BIOS displays a valid MAC address in the “Onboard LAN MAC Address”
in the Other Information Box. I’m not going to assume my ethernet port is bad until I see ROCK display my NUC’s MAC address in the serial field. If BIOS is a able to determine my MAC address ROCK should be able to. Thanks --Tim

Suit yourself.

Can someone please send me a screenshot of ROCK booting up and successfully connecting to the network? – Thanks Tim

What’s the matter? Don’t you trust me? Maybe you want a newspaper with today’s date in the picture.
In my post above. :roll_eyes:

That looks like a perfectly good MAC address being displayed in the Serial: field on your screen. So how come when ROCK boots up on my NUC it does not display anything in the Serial: field? This IS what the problem is. This happens even before ROCK tries to connect to the network. Also you are booting up Rock build 175 which is NOT the latest build of ROCK. I installed the latest ROCK which is build 183.
Thanks! I do appreciate your help. I’m just a little cranky because I have made zero progress and its been a week.

Yeah, no problem. We’ve all been there.

I used Build 175 because that’s what I had on hand. Unfortunately, I’ve put my NUC back to its normal WIN10 configuration, so no more testing from me.

Maybe @support can comment on whether there would be any relevant difference between ROCK 175 vs. 183.

Good luck.

If you were able to get BIOS 0081 working with ROCK build 175 then the obvious next questions is where can I get Rock build 175?? Hello ROON support?? Anybody home?? Can you please send me ROCK build 175?? Thank you --Tim

Hi @TKelley,

We cannot provide older RoonOS builds, downgrading is not supported.

The best course of action in your case would still be to try another operating system and verify that the NUC hardware is working properly, as we still have not confirmed this yet.

Once we have verified the hardware aspect we can proceed with troubleshooting further in a ROCK environment.