Rock synonlogy nas

I cant connect to my nas synology ds 112+. i do not know w´what to do

Hi @Soren_Otzen_Kristens ---- Thank you for the post and sharing this observation you’ve made with us. The feedback is appreciated!

Moving forward, our knowledge base lays out the best way(s) (procedurally speaking) to use network storage devices with Roon (As Storage / As Core). May I kindly ask you to give the article a read, and let me know what you’ve tried thus far, as well as, providing a description of your current setup as seen here.


1 Like

You really need to provide some more information on your environment and what you are trying to accomplish.
And, there is no such thing as a “Rock Synology NAS”.
So i am thinking that you maybe has installed Roon Core natively on your Synology? And you are having issues connecting the Roon Server on the NAS?


Hi Eric and Mike.

My system looks like this. Roon Rock on Nuc i5. I have a synology nas (DS112+) and i would like to to use this nas and the Music files on it, as libery. I am haveing trouble to find out what to whrite in Roon in the add network share folder. The ip adress is but it does not connect. I tryed with " smb;"

Kind regards.

Mvh. Søren Otzen Kristensen

Hi @Soren_Otzen_Kristens ---- Thank you for the follow up and clarifying how you are intending to make use of the Synology DS112+ NAS. Very appreciated!

I don’t know if you gave either of the articles I shared in my post a read, but the following should be able to aide in achieving what you want: Roon Knowledge Base - What’s the best way to configure my NAS for Roon.

Let me know how it goes, and if additional assistance is required, I will be glad to lend a hand!


Sorry about the late reply but you could try this:

smb://<Share name>

<Share name> should be something like “Music” or “Multimedia”

I was hoping someone with a ROCK could chip in though…

Hi Eric.

Yes i did read it, but i does not work in my case… i am ofcorse makeing something wrong, but i can’t find out what!! This is how my nas is setup.

Kind regards.

Hi Mikael.

Thankyou. It looks right, but it dos not work. I am shure that i am missing something :-/…

Hi @Soren_Otzen_Kristens ----- Thank you for touching base with me, appreciated.

Moving forward, to help me identify what could be the issue here, would you kindly provide the following:

  1. Are you able to access the NAS outside of the application via the OS on which ever device you are using as a Roon Remote?

  2. Can you verify that the NAS is set to use either SMBv3 or SMBv2 and confirm that ASP is not being used.

  3. When you entered the NAS’s information into Roon, did you enter your username and password as well?

  4. Are you seeing an error message when you attempt to mount the NAS drive in Roon?


Hi Eric.

It just did not work.

I have connected a ssd harddisk to the the Nuc with rock. Problem Solved. Thankyou for your help anyway. :-).