Rock won't install on NUC from USB

Roon Core Machine

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

I recently bought a used NUC 7i7 to run Rock OS, after moving on from running a Core on a very old Mac Mini. The used NUC came pre-installed with Windows 10. I’ve followed all the steps related to configuring BIOS and writing the Rock OS reset image to multiple USB sticks, but the NUC keeps booting to Windows.

I can see the USB drive listed as a bootable option in the BIOS pages, and it is an option on the f10 boot menu page. When I select the “BOOT” option for the USB from the boot menu it simply takes you back to the previous page. Every other approach just boots Windows.

I would have thought the USB flash drive or image was to blame, but I’ve tried a few of those now.

I have a feeling the solution is very basic, but so far no luck. Any suggestions would be appreciated.

Welcome to the Roon community, @Peter_Lucas.

A couple of things to try…

  • The BIOS menu is accessed using F2.
  • The NUC may use Fast Boot, so follow these steps:
  1. Power down the NUC,
  2. Press and hold the power button for three seconds, and
  3. Press F3 to disable fast boot.
1 Like

You may also have to disable Secure Boot

Thanks Martin-- I turned off fast boot in the Power Settings control panel. When holding the power button to get me to the different f-key options f3 is not listed, so hopefully getting to this through Windows accomplishes the same goal.

However, Windows still boots even when I select the USB from the f10 boot menu—

Thanks Suedkiez-- Secure Boot is unticked. All boots still lead to Windows.

You don’t say if Windows is currently on a SATA or M2 drive. Rock installs to an M2 drive, and only needs the smallest you can find (~128 or 256GB). Perhaps try a new (or reformatted) M2 drive. If the only bootable device is your USB installer, the BIOS will probably boot from it!

You need to start the NUC and enter the BIOS using F2. Go to Advanced > Devices and check that the USB device is detected.

Thanks Mike. I’ll give that a try.

Understood. In the visual Bios menu I can see the USB drive listed as a boot option, and can reorder this along with the other available boot drives. When I restart, however, selecting USB from the boot menu still takes me back to Windows…

Since F2 worked for you, we can rule out Fast Boot, as this disables the keyboard during booting.

What I’d try next, is use an Ubuntu live image; if that boots okay, you can delete all partitions on the M2 drive, e.g.:

ls -Flai /dev/disk/by-id/
sgdisk --zap-all $DISK

<DISK> is the M3 drive output by the ls command. Then try the ROCK image again.

Thanks Martin— I will give that a try.

1 Like

You can try Rufus instead of Etcher to create the USB boot drive.

Thanks Martin-
I’ve now booted from an Ubuntu live image and removed the disk partitions. The NUC no longer boots to Windows. However, when I start up the machine now I get a message of “Reboot and select proper Boot device or insert boot media and press a key.” Neither inserting a USB with Rock OS nor going through the Boot menu work.

I’ve tried a number of USBs with the Rock OS image, having used both Etcher and Rufus (to Dan’s suggestion) and none will work to boot from…

Yeah, there isn’t a proper image on your boot drive, so it was booting from the OS it could find, which was Windows. That’s been the problem from the beginning.

Don’t know why that happens, but I’ve found Etcher to be the most unreliable. Rufus usually works.

Trying creating the boot drive with nothing else running on the machine.

Are you using EFI or legacy boot?

That does sound right-- that there is not a proper boot image on the USB drive. I’ve tried installing the image on 8 different USB flash drives now, using Etcher on my Mac, as well as Rufus and Etcher on the NUC (when Windows was on it). I still can’t get a working Rock image to boot from. I’ve used Legacy and UEFI. I will try on a brand new USB now, as the others were all reformatted.

IIRC, the new images are for UEFI, but that should not affect the installation media. Trying another USB thumb drive is a good idea.

So I tried with a brand new USB and still no luck. After starting up to the boot menu with f10, I selected the USB with the Rock image as the boot drive, and was taken back to the “select a proper boot device” message.

I wonder if somehow my settings are off on Etcher. It seems strange that I could flash a boot image for Ubuntu with no problem. I used Etcher for that image…

Do you have Etcher set up to validate the boot creation? I’ve seen it give false negatives, but never false positives, i.e. if it says the creation was good, it probably was.

You could try Etcher on a different machine. Work or a friend’s machine?

Rufus is the more reliable.

Etcher does validate with a positive, yes. I used a Macbook air for Etcher, as well as the NUC itself when Windows was running. I used Rufus and Etcher on the NUC to burn the boot image. Both apps on both machines have yielded the same result. It is strange that creating the Ubuntu image worked fine (with Etcher on the mac) while no arrangement is working for the Rock image…

Have you re-downloaded the file since trying a new USB thumb drive? I’d try that, and check the MD5. This is what I get: 26fb50b5f34a788d81479cb7bbf2b822 on two machines.