Rolling Stones In Mono DSD64 Download - Roon Split in 2 Albums [Fixed]


As the title suggests, I have downloaded Rolling Stones In Mono DSD64 from Acoustic Sounds and Roon has split this into 2 Albums. My NAS has one file source for this 186 track download. 11 Discs in one and 6 Discs in the other album although they look exactly the same! There is some over lap of same tracks too.

I did have trouble with this the other day as Roon somehow corrupted tracks 44-99.
During the initial web download from Acoustic Sounds, 4 tracks didn’t download properly but I managed to get all tracks on the computer.

As 44-99 were missing because Roon dumped them in corrupt skipped files, I had to go back to supplier to reset my download again.

All done today and as per first paragraph, 2 separate albums.

I have tried deleting file from Roon and NAS, copying all files (tracks) with reset and wiped file info. This puts all files created on same date. All to no avail however.

Any ideas on how to fix this nonsense? Not too many issues considering I have over 3200 albums successfully in Roon.

Hi @Mike_L ---- Thank you for the report and sharing your feedback with us.

To help aide in my evaluation of this behavior may I kindly ask you to please provide me with a screenshot highlighting what you are seeing in Roon (in regard to this issue) and a brief but accurate description of your current setup as seen here.

Looking forward to your feedback!

Hi Eric,

Roon Core is on Lenovo Tiny Media PC
Windows 10 Pro 64 bit, Version 1703, Build 15063.138
i7 6700T CPU @ 2.81GHz
Network music stored on Synology NAS DS1813+ (32TB)
43,304 Tracks
Through LAN, Gigabyte Switch to MSB MK2 Renderer
Played through MSB Signature DAC V to SGR MT3.2s

This is what I am seeing. Two Albums instead of one.


Hi @Mike_L ---- Thank you for touching base with me and taking the time to answer my questions/provide me with requested screenshot. Very appreciated!

Moving forward, can you verify for me if you have been noticing this behavior regularly or is this the first instance? The reason I am asking is because if this is a consistent issue for you then we should try to do some deeper digging into what may be causing this to occur.

If this appears to be isolated to just this album, I would recommend selecting the two entries and merging them into a single album.

Looking forward to your feedback!

Hi Eric, Thanks for your response.

I am one week into Roon. I have tried importing this album twice into Roon with the same result despite re-editing the creation date of the music files. This is the first instance in regard to this issue so I cant comment on its nature.

The files are all sequential from track 1-186 with same creation date on the NAS.

This album is almost 24GB is size, perhaps that is an issue for Roon?

Should no further investigation be required do you have a link to merging the two Roon albums to one?

Thanks Mike

Hi @Mike_L ---- You can easily merge the albums by performing the following procedure:

  1. Navigate to the albums and select them both by right clicking on them. You can see in my example below that they will both be highlighted.

You will also notice at the top of the screen you will be shown how many albums have been selected and given the option to “play” or choose a different function from the “3dot” menu.

  1. Open the “3dot” menu and select “edit”.

  1. Once the “Album editor” window is open you will see the “Merge Albums” feature.

Let me know how it goes!

Thanks Eric, merged with no problems at all. :slight_smile:

1 Like