roo6D - The wireless high-end physical volume knob for Roon

I am thoroughly enjoying my SpaceMouse with Roo6d. Is it possible to disable the skip-forward and skip-reverse functions? I find that sometimes when I’m adjusting the volume I clumsily activate the skip features. I never skip in-between songs so disabling it is desirable. I tried to set the skip interval to 0 but that isn’t allowed.

Thanks for great project.

Today I decided to upgrade my Raspberry PIs to version 2.2. My primary reason for this was my rooDial (I have two) and roo6D were not not following Zone Playback, although this was set to Yes in the settings.
Now I am faced with a new issue. Although I have revoked and re-added my roo6D license a few times, my roo6D shows to be in a disconnected state.

Screen Shot 2022-03-05 at 12.48.55 PM

Has anyone experienced this issue? and if so, what did you do to resolve it, please. Any direction would be helpful.

Hm, is the space mouse dongle properly inserted? Did you try to switch off/on the space mouse?

The Spacemouse is inserted correctly. As stated in my original post, I have two rooDial devices, each connected to its own Raspberry Pi Zero W. I also have a new Nuimo that is connected to a Raspberry Pi 4.
I have moved the roo6D to a different Raspberry Pi (Zero W and Pi 4) and the roo6D shows disconnected in each case. All other devices (rooDial and rooNuimo) work fine.
To clarify, the receiver is inserted correctly, the Spacemouse is turned on and the roo6D is licensed.
I have plugged the receiver into my Mac mini to confirm the Spacemouse is paired and working correctly. I have also removed the pairing within the 3DConnexion app and paired it back to the receiver successfully.
I am truly stumped.

Me too :thinking:
Please try to connect the SpaceMouse with the USB cable to the Pi and report your findings.

As suggested, I unplugged the receiver and plugged in the Spacemouse to the Raspberry Pi Zero W; however, it still shows disconnected in Roon.

  • Reboot your Raspberry
  • Please find the ip number of your Raspberry. It is in the license Manager all down at the end of the menu.
  • open your browser
  • enter http://[IP of your Raspberry]/log.html

Mail what you see there to info (AT) definiteAudio (DOT) de

One more question. Did you run multiple Raspberrys with rooExtend at the same time?

Best DrCWO

I have two rooDial devices, each connected to its own Raspberry Pi Zero W running rooExtend. The Spacemouse is installed in one of these Raspberry Pis. I also have a new Nuimo that is connected to a Raspberry Pi 4 also running rooExtend.
In short I have two Raspberry Pi Zero W and one Raspberry Pi 4, all three running rooExtend 2.2.
Yesterday I revoked all licenses, wiped all configurations and reloaded rooExtend 2.2. I also completely wiped my PC running Roon Core and reinstalled Roon. Today I plan to install one rooExtend at a time to see if I can narrow down where the issue lies.
At this point I am starting fresh and from the ground up.

Yes, this is also what I would recommend. Start with one Raspberry Pi with rooExtend and see if it will work.
Best DrCWO

I wiped my PC, installed a fresh copy of Ubuntu with a fresh install of Roon Server. I have additionally installed one single Raspberry Pi Zero W 2 with a rooExtend 2.2. No other Raspberry PI are running at this time. I enabled this rooExtend in Roon Extensions and added only one license (roo6D) for the Spacemouse.
Unfortunately the roo6D shows disconnected on a fesh install of rooExtend and Roon.

Screen Shot 2022-03-07 at 2.51.16 PM

Considering that the Spacemouse works on both my Mac mini and Windows laptop, I am inclined to think that the issue lies with the roo6D licensing. Does rooExtend communicate with a license server? Is it possible to “reset” the license?

Thank you in advance.

Can you try a different USB port? I have a vague memory that the SpaceMouse dongle did work for me only on one of the two Pi Zero W 2 ports.

Thank you for your quick reply.

The Raspberry Pi Zero W 2 only has one extra USB port. The other is in use for the power supply. The power supply cannot be moved.
However, I have connected to Spacemouse to all all three Raspberry Pis with the same results. in each attempt, I have revoked the roo6D license before moving it to another Raspberry Pi. I have even gone as far as wiping and installing a fresh install of rooExtend. Additionally, I have also used a different MicroUSB to USB A adapter cable, but with the same results.
In the Raspberry PI 4 the receiver was connected directly into a USB port.

I am happy to report that the Spacemouse issue is resolved. Somehow, in the process of upgrading the rooExtend software I managed to damage the receiver. While the receiver continued to work in Windows and Mac, it stopped working on any of my Raspberry Pi 4 and Zero W devices. I have no idea how or why, but the fact remains that a replacement receiver is now working as expected.
Thank you for your prompt responses.

Take care.

1 Like

Question and possible feature idea:

Been loving my 6d with rooExtend. Im not sure why everyone with Roon doesn’t get one of these - its that good. I did discover something today - I grouped my main listening with my bedroom in Roon so I could listen regardless of which room I was in since I was doing projects that involved moving rooms frequently. I discovered that when grouped, the 6d won’t control the volume, due to the Zone Changing from ‘McIntosh Integrated’ to ‘McIntosh Integrated +1’. If I set the grouped ‘+1’ as the controlled zone in Roon, nothing happens when using the 6d. Of course, when controlling volume in Roon, multiple controls stack on top of each other so you can independently control both rooms.

Would it be possible to enhance rooExtend with the 6d to allow for this scenario? From my perspective, desired behavior would be to continue to control the zone where the 6d is located and let the grouped areas be controlled from the Roon client. I suppose further enhancement would allow the user to set in the setup if they wanted to control the primary zone, or both zones, from the 6d. I don’t think Id use this, but someone else might enjoy the flexibility.


Hi Andrew,
first, happy to hear that you love your 6D!
When you group zones, you have to select the newly created (+1) zone in the roo6D extension. Did you do that?
I just tested this and it worked for me, i.e. i grouped two zones, went to settings->extensions->roo6D and selected the newly created (+1) zone. Changing the volume now changes the volume in both grouped zones.
Maybe we could make it more convenient, i.e. when the currently selected zone is grouped, the new grouped zone will automatically be selected.

Yes, I did select the new ‘+1 Zone’. I thought I articulated in my post, but evidently I wasn’t clear :slight_smile: When selecting the new zone, nothing happens to either zone. In my scenario, one zone is using DSP volume and one is using Device Volume - that shouldn’t matter though should it?

No, this should not matter. Strange - let me test a few things.
What rooExtend Version do you use? Most current rooExtend version is 2.2.1 and roo6D 1.2.1

Tested various grouped zones and all work for me. Maybe update to the latest rooExtend version 2.2.1. Also note, that there is a roo6D extension setting “Change volume at playback only” that you might want to toggle.

Well I have no idea what changed, but it’s working perfectly now. I did try to update to the latest version, but the PI Zero W would just blink its LED every second. When I put the current SD card back in, the zoned volume control started working immediately. I’ll try again sometime later to do the upgrade, but since I have zero problems it not top priority.

Your suggestion to make the zone auto-populate in rooExtend when grouped is a good one. Look forward to seeing if that comes in a future upgrade.

Blinking instead of flashing means there is no connection the your Roon Core
If you run it wireless you have to reconnect to your WiFi after the upgrade?