rooExtend – The easy start with Roon Extensions

You used a deep Link to the DIY page. The „official“ links are for:

Best DrCWO
From Ngorongoro Crater, Tanzania :+1:

1 Like

I already have a RPI 4 running RooExtend and am using it successfully with RooPlay, RooWatch and RooNumio. I’d like to use a second RooNumio in a different room, so just tried putting RooExtend onto an additional RPI (as I understand that I can’t run two Numio’s from the same RPI). Everything boots up fine on the second RPI until it finally comes to a line of text saying “login”. I have no idea what to do here, but I seem to recall having to do something at this point on the first RPI I set up. Can anyone advise?

I’ve tried booting it wired and wirelessly with the same result. When wired I can’t see it on my network, and wirelessly it doesn’t seem to be broadcasting a wireless signal to connect to (per the instructions).

Hi, @Ewan_Gunn.

I’ve set a number of these up and I’ve not seen the behavior you’re describing. I set them up headless so I actually don’t know if they hit a login prompt. When cabled, they grab a DCHP address and come up in Roon without fuss. When not cabled, they broadcast their own SSID and accept connections using the password in the setup doc.

Is there any chance at all that you flashed the wrong image or something like that? I hope you’re not insulted that I’ve asked this - just trying to rule out the simple stuff.

Don’t worry - I’m definitely not insulted. It’s almost always something really simple and obvious with these things :slight_smile:

It’s a RPI Model B+ V1.2 (so it may just simply be too old) and I flashed with “” per the instructions. It’s purely for the second Numio, so I thought an old model Pi might cope, but it could be the age of the Pi is the issue here. That said, everything seemed to be running fine with lots of ticks right up until it asked for a login.

Your Pi B+ is listed as compatible but, I believe, requires a bluetooth dongle: rooExtend - Google Drive

I wonder if the boot sequence halts if a dongle isn’t connected. It might, but that’s just a guess.

Good idea, I’ll give that a try. Thanks so much for your help.

1 Like

Hi @Ewan_Gunn,
what you encounter is the normal behavior :+1: +

You don‘t have to log in at all. If you see the login prompt open Roon and go to Settings/Extensions. There the License Manager of the second PI should show up. You have to enable it and then you can enter licenses in the License Manager.
I recommend entering a name for the device in the License Manager for example „Bedroom“ and „living room“ in the second so you can tell the two devices apart.

Pi B+ V1.2 ia OK but with this device you nee an additional Bluetooth antenna.

Best DrCWO
From Africa, Sansibar

I’m going to hope that @DrCWO figured out your issue. I got the impression from your initial post that you were able to determine that the Pi wasn’t actually on your network. I believe he’s assuming that it is. Either way, keep us posted! :slight_smile:

This is a very good hint and may be the reason why I see the curl error 35.

I don’t have any context for this curl error. I don’t see it mentioned in this thread. I @Ewan_Gunn is getting to the login prompt but his device isn’t connecting on a wired network and isn’t broadcasting an SSID, is it possible that the issue is that he is on a Pi B+ v1.2 that doesn’t have an external bluetooth antenna attached?

I’m just guessing here that if the boot/startup process fails due to an issue initializing Bluetooth, perhaps network initialization never completes. This is just a guess, of course.

SSID is always broadcasted even if there is no external BT antenna. If you are not connected to wired Ethernet it should show up. But you need to have WiFi which Pi 2 did not have…

Sorry, but I got tied in knots again about the functionality to save licenses to a USB stick. I’m doing this because I’d like to go from 2.3.2 to 3.0.5. The manual clearly says the USB stick must be formatted “FAT or NTFS … (not FAT32)”. I tried NTFS, since the only FAT option I saw was FAT32. The Roon → Settings → Extensions → rooExtend happily said mounting … writing … unmounting … remove stick - but no files appeared on the stick when I checked later.

After a bit of Google digging, I discovered you can’t format FAT unless the volume is 4GB or less. Not having anything that tiny hanging around the house, I had to do some more digging to discover how to partition the stick. Did that, formatted it FAT, and the license files finally appeared on the stick. Wow! Even more confusing: later I tried a 32GB ExFAT stick just to see what would happen, and it successfully wrote the license files to that stick. Not sure why the first stick gave so much trouble and the second one none at all. Is ExFAT supported now? Thanks.

Brian if you are keeping it on the same Pi and have your original license code then just burn a new memory card and paste the code into Roon when all set up.

I have been doing this up to the latest version, and don’t need to anymore as it has the auto update feature.


I’m not sure why the documentation indicates that you can’t use FAT32. exFAT is newer and is most commonly used for removable memory cards - it makes sense that it works. FAT is old and uses 16-bit addresses and offsets which is why the size limitation exists. NTFS is a Windows file system and is rarely (read this as never) the right thing to use for scenarios like this.

If anyone reads this in the future, I think you’ve conclusively figured out that exFAT works and that’s what people should use.

1 Like

It’s all a bit strange - I’ve tried it wired and wireless and it’s not showing up on the network / broadcasting a network in either scenario. I’ve ordered a bluetooth usb and will see if that makes a difference, but it might just be the case that there’s something not quite right with the network adaptor on the Pi. I’m sure it used to work though.

Yeah, thanks. That’s why I’m looking to upgrade to v3.


I’ve been running 2.3.2 on Pi Zero W with ZEXMTE for some time. I just upgraded to Pi 4 B model with the latest 3.0.6. Now, the surface dial wakeup time is noticeably slower. Before, it was nearly instantaneous with volume up/down and pause/play. Now it takes about a second for the dial to wake up and connect. I had to go back to 2.3.2 on Pi Zero. Any idea why there is a difference in BT wake time?

Known issue caused by new ARMv8 Linux. Currently not yet an idea why but hope I will find out…

Best DrCWO
From Africa, Sansibar

Renter here. Landlord upgraded wifi to 5G. So RooExtend does not work any longer. one month into 1 year subscription on RooWatch

Sorry for that :cold_sweat:
This is a protection mechanism that isolates the WiFi between the users.

You can fix this by using a WiFi to LAN adapter that catches the landlords WiFi and connect it to your own WiFi access point.
After this you can connect to your WiFi and it will work again.

Best DrCWO