rooExtend – The easy start with Roon Extensions

But wait, BT audio as Playback should be there. Go to Settings/Audio it should show up… :+1:

You mean under Roon Settings/Audio? Can’t see any BT related devices I’m afraid…


is the issue with the Surface Dial fixed too?


I have done the test. Still not solved in V3.1.3.
I had to go back to V.2.3.3 Beta 5 to have a normal Surface Dial interaction.
Kind regards, Frank.

1 Like

Thank You @Frank_M. Hopefully @DrCWO will fix this annoying issue soon.

Not yet, but will come. I am a bit busy with marketing activities for the rooExtend-Box at the moment. Visited the German STERO magazine yesterday and next week I am at ATR (my sales representative) meeting a guy from Roon.

But don’t worry, this is on top of my list.

Best DrCWO

1 Like

:exclamation::exclamation: rooExtend v3.1.4 is out :exclamation::exclamation:

It will autoupdate rooExtend on your Raspberry Pi between 2Am and 4AM of your local time.
No manual intervention is necessary.

  • This fixed the CD-playback issue in rooPlay that occurred in v3.1.3.

  • Also the USB-Backup messages in the status line of the License Manager - that fooled some users -have been removed by default. Now there is a switch in the License Manager to enable USB license backup/restore. Default is “No”.

Best DrCWO


I’m sorry to report that Chromium display stopped to work completely.
rooExtend 3.1.4
Service and RPI restarts don’t help.
Service is started but display is not visible in Roon and reports:

Mar 17 23:26:50 xxx rooExtendChromium[3202]: (==) Log file: “/var/log/Xorg.0.log”, Time: Fri Mar 17 23:26:50 2023
Mar 17 23:26:50 xxx rooExtendChromium[3202]: (==) Using system config directory “/usr/share/X11/xorg.conf.d”
Mar 17 23:26:50 xxx rooExtendChromium[3202]: error: XDG_RUNTIME_DIR not set in the environment.
Mar 17 23:26:51 xxx rooExtendChromium[3202]: (II) modeset(0): Initializing kms color map for depth 24, 8 bpc.
Mar 17 23:26:51 xxx rooExtendChromium[3202]: error: XDG_RUNTIME_DIR not set in the environment.

Hi @Piotr_Pekala,
my first guess is that this is affected by a worn out SD card.

I will start with a fresh burnt v3.1.0 SD-Card and then letting the update get in. On my test machine anything looks fine but I will check this in the evening.

Best DrCWO

Hi @Piotr_Pekala,
I think I was right, your SD-Card got broken.

Right now I downloaded the image of v3.1.0 from my download page. Next I ran an update and anything was fine. Display shows the Roon logo and after connection the Roon artwork.

So please do the same as I did and you will be fine again.

To simplify the setup of licenses and settings just save your current settings on a USB-memory-sick before re-flashing the SD-Card. Saving to USB is disabled by default in v3.1.4. So please go to the License Manager and enable it before inserting the USB-stick.

After this copy the image to your SD-card (better a new one). Insert the SD-card and the USB-stick and power on the Pi. Please watch the status line of the License Manager. It tells you when to remove the USB-stick.

Best DrCWO

After two reflashes I know what was the reason :slight_smile:
That was neither update-related nor SD card related. And the error messages show up exactly the same when it works and doesn’t work.

Display doesn’t work after change of RPI hostname (via your web GUI) to anything other than rooExtend.

BTW, there is still a problem with USB backup/restore when you are using rooNuimo:

  • it looks like rooNuimo settings are not being backup (no such entry in log)
  • some settings are being restored at a first boot but the disappear when you replace rooDial with rooNuimo and then no license keys nor settings from previous installation are visible

This is quite an interesting finding :hugs: I never thought that there my be an interconnection. In my Living Room I use a different network name but no HDMI output. In my study with HDMI monitor it is always rooExtend :face_vomiting:

But issues with USB stick sounds strange. I will also take a look at that.

Thanks‘s for the help, I will get into it end of next week as I have to travel the next days.

Best DrCwO

1 Like

As I could not find an answer yet I would like to take up this question and ask:
What is the default user (pi ?) and password for rooExtend?

I have rooHead (rooExtend 3.1.4) running on a RASPI 4B and I am thrilled!


For normal operation you don‘t need the credentials. Just start Roon, go to Settings/Extensions snd there you will find rooExtend.
Best DrCWO

Thanks for your reply, but I’d like to assign a static IP address and want to disable WLAN and Bluetotth - as I am running a wired connecion.
That’'s probably beyond “normal operation”! :persevere:


I got the Amazon USB hub and would like to try RooControl. However, I do not have the On/Off button in the Roon UI.

How can I enable it?
Best OW

1 Like

Maybe this is of interest to one or the other here:

My RASPI 4B is equipped with a HiFiBerry add-on board - Digi2 Pro (S/PDIF out with cinch and TOSLINK).

Until now I had supplied my RME DAC “Babyface Pro” with music from Roon running HiFiBerry OS, connected via optical TOSLINK cable (2 GENELEC monitors + subwoofer connected to it). That’s a very nice setup if I wanted to listen to music in my study without turning on the computer. The Mac Studio is connected to the Babyface Pro via USB.

Now I have installed a rooExtend system on this RASPI to enjoy rooHead.
To my great surprise, my Digi2 Pro add-on card is supported out of the box by rooExtend:
So I can still control the rooExtend RASPI from Roon and play music via optical TOSLINK cable without having to configure anything - very cool!


I have both the Digi version and analogue version of these and I had no idea about this. Thanks for the heads up :+1:


Hi @Otto_Wilhelm,
there is a detailed chapter for that in the Quick Installation Guide.
It says you have to add it in the device settings. See screenshot below.

Best DrCWO


The products are amazing we use rooWatch, rooHead, rooDial.
They all work perfectly.

The thing we don’t like is the very 10 seconds ping to the cloudflare dns
Could this be removed ?

Thnx and regards,

1 Like