Roon 1.2 - No audio devices found [Solved]

I get an no audio devices found message whenever i start up roon, refreshing devices briefly shows the devices correctly for a split second then disappears. Setting permissions correctly in the eset antivirus firewall doesn’t seem to fix the issue. Thank you
windows 10 pro 64bit version 1607
Roon 1.2 build 161 stable 64bit

What happens if you turn the firewall completely off?

no difference, i’m pretty sure it’s unrelated to my anti-virus however I can’t be certain

Hi @James_Lock ----- Thank you for the report and my apologies for the troubles here. In order to evaluate this issue properly, I’d like to gather the following information from you. Please see below.

  1. I see you have started to list some details about your setup ( windows 10 pro 64bit version 1607 / Roon 1.2 build 161 stable 64bit) :+1: May I kindly ask you to expand on this information as seen here. The more detailed you can be the better.

  2. Can you please provide a description of your network configuration/topology, as well as providing some insight into any networking hardware you may be implementing.

  3. Have you always experienced this issue while using Roon or did this just appear recently? If it is indeed a recent development, can you think of any changes to your setup that may have had influence on this behavior? OS updates? New applications? Driver / Firmware updates? New gear?


I’m using a laptop called an MSI GS40 6QE Phantom:
I’m connected to my home network but also using a NordVPN Proxy, however I don’t think that is causing the problem. It’s been a while since I have used the Roon software I purchased however I do seem to remember having this problem the last time i used the application about three months ago.
Pictures of the issue are included below.

I’m not using an external DAC, just headphones plugged in to the headphone port of the laptop, my router is a BT home hub 5, audio devices will briefly flash up for a split second if I refresh but will then disappear. A restart of the software or laptop does not fix the problem.

Hi @James_Lock ----- Thank you for the follow up and the feedback! My apologies as I should’ve mentioned this earlier :dizzy_face:

I see you in your earlier post that you tried disengaging the eset antivirus firewall, which offered no change in behavior here. Have you tried disengaging any active Windows firewalls yet?

The reason I ask is because Roon is always doing some form of networking even if it is all done from a single unit. The symptoms you are experiencing would appear to point to something going on in your network configuration. We’ve found in the past that the best method for handling network troubleshooting is to simplify everything, add pieces back in, and see where the issue occurs .


I disabled Nahimic 2 audio software and that worked for me.