Roon 1.3 on sonictransporter i5 unstable (connection loss, hangs)

Hi @support

Since yesterday I am running roon 1.3 (build 218) on a sonictransporter i5 (used to run on a laptop). My audio files are stored on a synology NAS. Both are plugged into a gigabit LAN. My remotes are ipad and an android phone.
I have 1200 albums and 25000 tracks.

The application is not stable:

  • This morning I had to reboot the sonictransporter because the remotes could not connect at all.
  • The remotes are disconnected and reconnected, disconnected, reconnected, and so on.
  • Browsing through the collections is sometimes painfully slow. It is hard to reproduce, although listing the compositions of JS Bach (I have them all, and different versions, so it is a big list), mostly fails: I get a spinning wheel, and the list is never completed.
  • A lot of the time when looking for an artist or a composer, autocompletion does not work.
  • Launching searches (very) often does not complete: all I get is the roon logo. When this happens I sometimes try another remote, which works for a couple of seconds or minutes, until this one starts to hang too.
  • Restarting the roon service sometimes helps, but only for a while.

Conclusion: roon is a wonderful product, but my instance is useless.

Hi @Kristof_Baute ---- Thank you for the feedback and my apologies for the troubles here. To help better evaluate this behavior you are reporting to us may I kindly ask you for the following:

  1. Can you verify if you are noticing this behavior mainly with multi disc albums or is it with any content you are accessing in your collection?

  2. You mentioned that you use to run Roon on a laptop, were you noticing any of these behaviors previously? Furthermore, in your troubleshooting of this issue, have you tried (temporarily of course) running Roon on the laptop again to see if the experience is the same as with the ST i5?

  3. May I ask you to please expand on the description of your current setup as seen here, being sure to also provide us with the details of your network configuration/topology as well as insight into any networking hardware you are implementing.


Hi @Eric,

I can reproduce the issue.

  1. Connect tidal. If I disconnect tidal it is much harder to reproduce. Don’t know if it is related to the total number of tracks and albums, or the service itself, or the specific composer with favorites in tidal.
  2. Go to a composer with a lot of compositions. Looks like around 150 is the limit. See the spinning wheel. If I really want to crash it, I go to Bach, with +1000 compositions. (Almost all of them are local files btw, only a handful, less than 10, are Tidal albums)
  3. Try something else, browsing or searching, and see the roon logo forever and/or timeouts. Or error messages like:
    ‘No results found for “Ludwig van Beethoven” Please make sure your words are spelled correctly …’ or ‘Error loading page. Please check your network connection’ or ‘There was network error in accessing the composer’.
    The remote has become useless at this point.
  4. However I still can start another remote and use it until I go to one of the composers-with-a-lot-of-compositions. Then I will crash this remote.
    At a certain point, a process or thread or something finishes or timeouts and the remotes become responsive again.

To answer your questions

  1. It occurs accessing composers and their compositions. But the ones with the biggest number of compositions are also the ones with the most multidisc albums.
  2. I have the problem only on ST5, not on my laptop.
  3. My setup:
  • Synology NAS with 800 albums and 16000 tracks
  • Roon server on both ST i5 and laptop running windows 10
  • Gigabit LAN between ST, NAS and endpoint
  • Endpoint: RPi with PianoDAC+
  • Tidal with another 550 albums and 9000 tracks
  • Remotes: on ipad iOS 10.3.1, on nexus 5 (android 6.0.1), on windows 10



Did additional tests.

  • Added about 7000 local tracks, resulting in more occurrences of the issue, even without tidal. Looks like the # tracks is a factor, not tidal itself.
  • Multidiscs are not the trigger. It happens with composers with no or little multidiscs too. So it’s # compositions that counts.
  • When a remote hangs on a composer and I kill it and reopen it, it returns to that composer, hanging again or still hanging. This is very inconvenient. I have to keep trying for minutes until an attempt is successful, or I have to restart the Roon core service. I can use parts of the remote: settings, internet radio, support, tags and playlist. But the cool stuff (discover, recent, genres, tidal, artists, albums, tracks, etc…) hangs on the Roon logo.

I have to remember I cannot browse Bach, Mozart or Schubert :confused:

Hi @Kristof_Baute ----- Thank you for the follow up and sharing the results of your testing with me.

Would it be possible for you to provide me with a sample of some content that is giving you this issue via a dropbox download link so I can see if we can reproduce in house?


Seems to have same problem.

Roon Server Log
cat /var/roon/RoonServer/Logs/RoonServer_log.txt

04/21 02:26:59 Debug: [remoting] firing request callback with null because of dispose
04/21 02:26:59 Warn: posting to shutdown SynchronizationContextThread

I’m also running two extentions that is freezing, and need restart.


  1. Do you want me to provide the roon database too?
  2. About the other issue I mentioned in my first post (I cannot connect in the morning), I have more information:
  • At night roon stays running, but my NAS shuts (scheduled)
  • I have to boot the NAS, and than I can start using roon again. Don’t think this needs to be like this

Hi @Kristof_Baute ---- Just a sample of content should suffice for now. Thanks!

Moving forward, I see you had provided some feedback about your network configuration/topology as requested in my post :thumbsup:

“Gigabit LAN between ST, NAS and endpoint”

Can you please expand on this information a bit more for me? What I am looking for specifically is a general over view of what the chain of communication looks like and the details of the links (i.e router, switches, repeaters, extenders, power line adaptors etc) that make up the chain. Having the make/model of these devices would be great to have as well!


I have sent a private message with the details of my network.
Will provide the music soon.


Could it be that you are hitting this Client disconnects after loading album [Resolved - Build 223]
which I encounter too, sometimes, when trying to load albums.

I think this is different. When the remote hangs on composers, there is no relevant log entry, at least not to my understanding.

Thanks for the link. Mine has been quite unstable for a while, or since 216/218. It’s not critial. Hopfully a couple of upgrades will take care of it.

I know i have an unstable server, so I’m not the best person to use for fault findings. They can ask for my logs if they like.

I’m loosing contact often with my Roon SonicTransporter i5 from my iPad. Or any other controller. I believe my network is good. As said may file server is not.
Which is one reason I like Roon to not stop working if local file is lost, when Tidal/network is ok.
Before Roon worked like that. It did not matter if I lost local files. Now it has changed.