Roon 1.5 build 333 will not play to paired Sonos zones [fixed in 334]


I just ran the upgrade to 1.5 build 333, and now nothing will play to my Sonos endpoints. When trying to play, I get the “Roon has lost control of the device” message.

I’ve tried restarting Roon as well as rebooting my Sonos speakers. Roon will play directly to my M24 Peachtree speakers (attached via USB) but will not play to Sonos.

My setup:
iMac running Roon Core
WD My Cloud EX2 NAS drive - connected to core via Ethernet
Peachtree M24 connected via USB - exclusive mode
Sonos Play 5 - stereo pair
Sonos Play 1 - 2 additional zones


Thanks for sharing your report with us, @Eric_Krums!

I’d like to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.

Thank you,

Hi, I just tried to play to my Play 5 stereo paired Sonos speakers at 9:26 AM Central Standard Time.

Thanks, @Eric_Krums Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

1 Like

OK should I try to play again in order to generate a log?

No need to play again, @Eric_Krums.

I have confirmed that the report has been uploaded. I’m passing it along to the team for review now and I’ll be sure to update you when I receive their feedback.



Thanks for your patience while we investigate, @Eric_Krums.

Can you try ungrouping these as a stero pair and play to one of the zones on it’s own? Do you still experience the same behavior?


If I unpair the speakers from the stereo configuration, they will work. I tried re-pairing them after testing, and I got the “lost control” error again.

Thanks for trying that out for us, @Eric_Krums!

I’ve discussed your findings with the team and we have submitted a ticket to the development team to track this behavior you’ve reported to us — they’re looking at it now. While I cannot make any commitments as to when this behavior you’ve observed will be addressed, I can however assure you that we will update you when any changes are made in a future release.

Thank you again for sharing this report with us, the feedback is always appreciated!


1 Like

I just tried testing my Sonos setup grouping 5 zones at once, excluding a Play5+Sub pair, and aside from a possible fluke streak of luck, everything went very well.
None of my other speakers are paired in any way.

• All zones grouped together very quickly.
• The stream was picked up and balanced very quickly, only 1-2 stutters at 5 zones.
• I was able to skip, seek, change artist and album all with quick succession with no issues.

At first I thought the stability patch made things worse, but avoiding the regression bug, this actually seems very promising.

Hey @Eric_Krums,

We made some changes that we believe will take care of this issue. The new build should be available now. Can you try updating and let me know if the experience improves for you?

More information regarding this release can be found here:


1 Like

Hi Dylan,

Yes, I just tried it out & it works great! Thanks for all the help!!!


1 Like