Roon 1.5 Build 334 - Endpoints not recognized (RoPieee and Chromecast Audio)

My Roon Endpoint - a Ropieee on a Raspberry Pi 3+ with a DAC on the USB Port - is not recognized as an Endpoint since the update to Build 334.

My Chromecast Audio is also not recognized as Endpoint but it is shown in the “Settings - About” Section as Version 1.0 Build 164.

The streaming to iOS devices and win10 Works just Fine.

All devices are restarted. Is there anything I‘m missing.

While we’re waiting for @support to come along, just an observation: your Chromecast Audio won’t be listed in the Settings - About section, only devices running Roon software are listed. That “Version 1.0 Build 164” device is almost certainly Roon Bridge on your RPi, as shown for example here:

Hi Geoff_Coupe,

thanks for your reply. You are right! It is my RoPieee!

1 Like

Hi @McB ---- Thank you for the report! The feedback and insight are both greatly appreciated. Sorry to hear of the troubles.

Moving forward, to help us better understand this behavior you are experiencing may I very kindly ask you for the following:

  • An expanded description of your current setup using this link as guide.

  • Since noticing this behavior have you tried rebooting all of your devices including your Roon core and the mentioned endpoints?

Lastly, I have went ahead and enabled diagnostics on your account so our techs can have a closer look into this behavior. What this action will do is the next time Roon is active on your core machine a diagnostics report containing a set of your Roon logs will automatically be generated/uploaded to our serves. We will be sure to confirm when the report comes in so you know we have it.


Hi Eric,

let me first provide alle the installation details:

The „About“ Page - please be aware that a RoPieee device is listed.

The Roon Core is runing on a Synology 218+ with the latest DSM (DSM 6.2-23739 Update 1), 10GB RAM, 250GB SSD, Intel Celeron J3355 - 2 Cores

The Music is stored on an local disk (10TB Ironwolf) on the same NAS as the Roon Core is running.

The Roon Catalog is stored on the 250 GB SSD atached to the NAS via USB3.0

I am storing ~7500 tracks.

The Problem:
The Endpoints are not listed (see screenshot below). There should be two of them: a Raspberry Pi3B with RoPieee and a Chromecast Audio. The RoPiee is even listed in the “About” page.

The Ropieee was working flawlessly before the update to Build 334. The Chromecast obviously not as it was not supported in the earlier builds.

The firewall of the NAS allows the Roon traffic. To be 00% sure that tis is not the root cause I tested with the firewall disabeled.

All devices are rebooted. There are no crashes or other strange behaviour. I cal play directly to iOS devices or my local PC.

Hope this helps & thanks in advance,

Hello @McB,

Thanks for providing those screenshots for us. I can confirm that we have received the necessary diagnostic info from your machine and have started a case for you with our QA team. One quick question regarding your screenshot, would you be able to also provide the second part of your audio settings page?

If you scroll down, the Chromecast Audio should appear under ‘Networked’ devices and will not appear under “Connected to this PC” as the connection to it is over the network. I assume the same goes for the RoPiee since it’s connected over the network. Please provide the screenshot for this aspect as well and then we can get your case submitted to QA for further analysis.


Hi Noris,

the „Network“ section is completely empty - there is no second page. This is consistent for all devices I use to look it up (iPad, iPhone, PC).

Best Regards,

Hello @McB,

Thank you for providing that screenshot for me. I’ve been taking a look at the diagnostic info we received from your machine and the logs are pointing to networking issues. Can you please provide an overview of how your network is set up here? Please be sure to include all model/manufacturer information regarding your Router, Any Switches you have, Range Extenders, Access Points and any other relevant networking equipment.

You mention that you turned off the NAS firewall, can you please let me know how exactly you performed that step? Are there any firewalls on your Router which could be blocking the multicast packets that Roon uses to communicate? Please let me know when possible.


Hi Noris,

My network hardware

looks als follows. All devices are rebooted, cabeling layout ist checked, all connections work with ping or http. The relevat devices are in bold. Some others but not all others are listed.

LAN Router: Fritz!Box 4040 connected to it is
–> Switch: TP-Link 8-Port Gigabit Home Switch (simple, unmanaged, 4 years old)
– --> Roon Core: Synology 218+, Firewall is disabeled!
– --> Roon Bridge: RoPieee connected via LAN cable
– --> PC with Roon App (is recognized by the Roon Core and can play music e.g on a hedphone)
– --> WLAN HotSpot: Fritz!Box 1750E (2nd floor)
– -- --> iPad with Roon App intended for remote control (it plays music on the iPad without problems)
– -- --> ChromeCast Audio: verified (it plays music with the Qobuz App but not with Roon)
– --> WLAN HotSpot FritzBox 1750E (1st floor)

WAN Router: Speedport (German Telecom)
–> it is connected to the LAN Router wih one cable and creates a DMZ, no Roon devices are connected to the WAN Router.

The IPv4 config:

LAN: One flat network for all the LAN devices
Internet: over WAN Router uses as the DMZ netwok

Btw did I mention that the exact same setup did work before the upgrade to Build 334 on the Roon Core.

Thanks for your help

Hello @McB,

Thank you for providing that network setup information. The next step for us here would be to start eliminating variables that could have been changed by the new installation, I kindly ask you to try to temporarily host the Roon Core on your Laptop to see if you have the same issues playing to the RoPieee. If it is working fine on the Laptop, then we can focus our efforts on the Synology. If it still does not play from the Laptop then we should take another look at the network and see if we missed something. I have also gone ahead and sent your networking information to our QA team who may have more suggestions. Please let me know your findings after temporarily hosting the Core on your laptop.


Hi Noris,

I did install the Roon Core on a Windows 10 machine which is in the same IP network an hooked up to the same switch. The results are surprising as the screenshots below indicate.

In the Roon Client on the PC (same PC as the Roon Core) the RoPieee and the Chromecast Audio do NOT show up (see below)

BUT on the Roon client on my iPpad the Chromecast Audio shows up an works just fine (see below). Both the iPad and the Chromecast are in the same WLAN.

Best regards,

Hello @McB,

Thank you for providing those screenshots for me, I am just as surprised as you are by the findings. Since you are able to find the Chromecast Audio on the Laptop but not the original Core, signs are pointing to networking issues here. The next steps would be to start methodically eliminating variables one by one and seeing where the issue lies.

Can I please ask you to temporarily connect your Ropieee and the Laptop directly into the Router via Ethernet and see if you have any communication issues that way? If you can confirm successful communication, can you please try to connect the Original Core (Synology) via Etherneet to the Router instead of the Laptop and see if there are still issues then?

Some other potentially useful tests, I have found this article regarding your Fritz!Box, can you please take a look at your IGMP settings on the Router/Access Points and see if you have anything that could be preventing multi-cast packets from being successfully delivered to devices?

To me it seems like there is a firewall somewhere, either in the Router or more likely in the 2nd Floor Access Point that had the allowed the previous version of Roon to communicate but now has blocked multicast packets in the new version. If you see IGMP or Jumbo Frames in the setup for the Router/Access Point, it may be worthwhile to try and enable/disable that feature to see if there is any change here. I hope that my suggestion help you but this is certainly a strange issue to say the least, please let me know your findings when possible.


Hi Noris,

I have done all the suggested test. The results are still not positive. See the details below.

In the meantime I was also testing the USB Interface to the DAC (Questyle 400i). It looks like the Interface is not workung corectly. I will contact my dealer and try a replacement.

What also is clear that the Chromecast Audio is fully supportrd on a Win10 Roon Core but not yet on the Synology Roon Core. Is there an updste to be expected soon?

To give you the complete details on the above topics you’ll find them here.

Router (Fritzbox 4040) + RoPieee + WIn10 PC with RoonServer and Roon App
–> NO RoPiee visible, but listed in the Info Section

Router (Fritzbox 4040) + RoPieee + WIn10 PC with RoonServer and Roon App + ChromeCast
–> NO RoPiee visible, but listed in the Info Section
–> Chromecast IS working

Router (Fritzbox 4040) + RoPieee + Synology 2018 with Roon Server + WIn10 PC Roon App
–> NO RoPiee visible, but listed in the Info Section
–> NO Chromecast visible

The Firewalls on the PC and the Synology were all disabeled. ALL other devices were detached from the network. All listed devices were rebooted and did respond to ping etc. I am happy to provide you with the screenshots in case needed.

I read the article on the Fritz!box you provided. It does not show ANY wrning in the syslog so no hints of any IGMP issues there.

The Internet connection is stable with high bandwidth.


Hello @McB,

Thank you for running those tests, and I do have to say I am a bit surprised by your findings. I was hoping that the connection directly into the Router would provide some more concrete results but it seems that this is not the case here.

Even though the syslog does not show hints of IGMP issues, can you please try the steps listed to see if that changes anything in the communication here? It is possible that the Roon application does not show up in syslog because it is internal IGMP and the syslog may only show external IGMP connection (ex. directly from your ISP provider)

Additionally, If you have an additional Router around the house, I would try to temporarily use that to see if your run into the same issue, it would be good to eliminate this variable from the equation just to be sure that it’s not the hardware blocking Roon here.

Please let me know your findings for the above suggestions.


Hi Noris,

Thanks for your help, the topic is now resolved. There were two root causes:

The RoPieee client was not found since the installation of Build 334: Well, the reason was a broken USB Port from the RoPieee to the DAC. The RoPieee is only listed as an endpoint when there is a device to play sound attached. Coincidently the USB broke the same day as the rollout of Build 334. A DAC replacement fixed the problem.

The ChromeCast Audio are not listed as endpoints. This is specific to the Synology implementation. Both Win 10 and Linux do not have this problem. An update of the Synology build would be much appreciated.

Again thanks for your help.

Hello @McB,

Glad to hear that you found the USB port & DAC to be the issue here! I will forward you request to update the Synology and see what we can do regarding that. If you have any other issues feel free to start a new support thread and we will take a look!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.