Roon 1.7 build 521 -- Help! My Roon Remote Controls doesn't work any longer!

I’m running Roon Rock 1.7 build 521 and I upgraded my Roon remote controls to the same build from build 511 and now none of them works any longer and I can’t connect to my Roon Rock core and play any music.

My primary Roon remote control is:
Asus T200TA Windows Tablet
OS: 32-bit Windows 10 Home build 1909 CPU Intel Atom Z3775

My secondary Roon remote control is:
Sony Experia SGP612 Android Tablet
OS: Android 6.0.1

None of them works and they simply hangs when connecting to the Roon Rock. I have re-installed the Roon software on the remote controls several times, but the result is the same.

I renewed my Roon subsription only 11 days ago and now I can’t use it!

Please, where can I download the build 511, which worked fine on the Roon remote controls?

Best regards


Please, where can I download the build 511, which worked fine on the Roon remote controls?

You can’t, Roon is auto updated, and you can’t download old version.

Did you restart your core & remote ?

After then, try to click “Help” on remote connection screen, and set the core server IP.


Yes the core is restarted several times. There is no issues with the core or the Roon bridge I have. It’s the latest software release build 521 which isn’t compatible with the hardware I have for the Roon remote control.

The remote control software (build 521) has been re-installed several times on this hardware, but it simply doesn’t work. I used the build 511 for some time after I upgraded the core to 521 and it worked perfectly on the same hardware.

It’s really strange that the previous build (511) isn’t available for download as a rollback for those people who have the same problem as I have. No, the new release isn’t automatically installed unless you have set so i the settings.

My biggest mistake was to upgrade to build 521 on the remote control. I now have an old phone which I now can use as a remote control and to check that my core and bridge work properly, but the user experience is really poor when using a phone as a remote control.

Please, just give me the installer for build 511 so I can use my regular remote control!


Try to connect to the core with IP (and not use network broadcast).

“Try to connect to the core with IP (and not use network broadcast).”

I guess you haven’t been following along the last week or so. Build 5.21 is broken in many ways, including the problem described by the OP. Many people are having the exact same issue. All we know at this point is that Roon is aware of the problem and “the team is working hard” to resolve the problem(s).
For whatever reason, they’re refusing to allow affected users to roll back Roon Remote to 5.11 so we can at least use the product we’ve paid for.

The problem with 521 version is about GPU rendering (computer & remote devices). Application fonts and images are broken on some devices.

But there’s no global concern about connecting the remote as far as I know.

I won’t be surprised that by pressing Help and putting the server ip, the android application would work :wink:

Well, now you do :sunglasses:


Thanks for the input!

Yes, to me it’s very strange that the support doesn’t offer the build 511 as a rollback for those who have the remote control issues with the build 521. I almost bought the lifetime subscription when I renewed the subscription about 11 days ago. I’m really glad I didn’t. At least, all subscribers should be always offered a rollback to a previous release if encounter problems with the latest release.

I haven’t had any issues before when upgrading to the latest release, but in this case the proper testing before release has obviously not been done and a quick fix or rollback option should be offered immediately!


1 Like

I agree with your observation, but it is not simple, even less on the play store or can only put one version at a time.

They could offer the Apk file for download, but it’s not friendly user.

In terms of strategy, software fragmentation is the worst thing that could happen (ask Google and Android …)

It’s frustrating, but the easiest thing to do is to wait for a fix (Roon is usually quite reactive), or to try my technique in your case.

For the problem of fonts and images, I think we’re going to have the same problem as when we switched to OpengL3… Obsolete or outdated devices are not and will not be supported over time.

Hi @Goran_Nireus

As @ComasSky mentioned, downgrading Roon versions is not supported due to the reasons mentioned in the article but we can certainly take a look at this behavior on the new build.

When you say “doesn’t work”, what exactly are you seeing when you open the Roon Remote app on your Android? Are you stuck on the “Searching for Core” screen? Are you able to connect but the display is “frozen” with no artwork showing? If you could share a screenshot of what you’re seeing that would help.

Have you tried clearing out the old Roon Remote database? I would give this a try (on your Windows tablet):

  • Exit out of Roon
  • Navigate to your Roon’s Database Location on the tablet
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Restart/Reinstall the Roon App to generate a new Roon folder

Hi noris,

Thank you for your response!

With “not working” I mean that I can connect to the core, but as soon as I’m connected and the main screen appears the Android version freezes and the Windows version says “not responding” ( see screenshots).

I followed your instructions for the Windows version and let it build up a new database, but the behavior is still the same.

Best regards


Hi @Goran_Nireus,

Thank you for the additional info!

We are aware of this behavior on Android and are working towards a resolution, please see the following thread for any status updates:

This seems a bit different than the Android issue. I suggest we take a look at your Roon and Windows Event Viewer logs, can you please provide a set of these? Instructions are as follows:

Roon Logs can be retrieved using these instructions, please be sure to send the ones from the Remote and not the Core.

Event Viewer:

  1. Press Win + R and type eventvwr.msc

  2. Press OK – this should open Event Viewer window

  3. From the left sidebar go to Windows Logs > Application

  4. Right click on the Application subsection and pick Filter Current Log... from the context menu

  5. On the Filter tab for the Logged section pick a parameter Last 30 days and press OK

  6. Right click on the Application subsection again and pick Save filtered log file as.. from the context menu

  7. Enter the log file name, for e.g. Roon_USERNAME , and press Save

  8. Upload the Event Viewer logs to our diagnostics servers, information has been sent via private message


I have now uploaded the eventlog from the remote control (Windows Tablet) according to the instructions!



I have some good news!

I’ve updated the graphics driver (Intel) for my Windows 10 Tablet and now everything seems to work again on this tablet!

This is the driver package I now installed win32_15.33.49.5100.exe

The old version 4358 doesn’t work with Roon build 521, but the new Intel driver 5100 does work.

I have upgraded the Windows 10 OS regularly, but haven’t done so for the graphics driver in a while and that’s my fault!

Best regards


Graphic%20driver_4358 Graphic%20driver_5100

1 Like

Hi @Goran_Nireus,

Great to hear that updating the Intel drivers has resolved the issue with Windows! As for the remaining Android behavior - we’re aware and working towards a resolution, as soon as we have further updates to share we will update the linked thread, thanks!


We’ve released a new update, Roon 1.7 Build 528, which contains improvements that we believe will help with the issues you are experiencing here. Please see our release notes below:

The Team At Roon Labs

Thank You!

I can confirm that Roon remote now works on my Android tablet.

Best regards



This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.