Roon 1.7 (Build 667) - No automatic file rescan anymore

Core Machine (Operating system/System info/Roon build number)

DiskStation DSM 6.2.3-25426 Update 2/Roon 1.7 (Build 667) stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

naim NDX2

Description Of Issue

Changing/moving audio files does not force file system rescan anymore (previous version did). SMB mounts from DiskStatiion on Catalina 10.15.7 (19H2) with Roon client.

Hello @Michael_Sicher, can you send me a screenshot of Settings>Storage? Also, do the files come in if you use the automatic scan interval setting?

Hello @nuwriy, I can’t find the automatic scan interval setting.

Had the same problem with my QNAP NAS and the latest Roon build, and added the following to the original post I did yesterday afternoon:

Did some testing and found out it has something to do with root level folders. My Roon NAS structure is as follows:


First two folders work properly, the last one doesn’t. Now when I pick a subfolder of Mixes, it does work like it should (and did before). So the workaround (at least for this type of NAS) is to create an extra subfolder in each root folder, move all files to that folder, and direct Roon to it.

Maybe you can try this by adding another (sub)folder to the storage and test it? You only seem to use root level folders too.

1 Like

All my folders (except one) have subfolders like MQ, HQ.

With the previous Roon version all changes were found immediately.

My QNAP now has the same issue, every now and again roon issue poor (IMHO) updates - this is one of them…

Same issue with my SYNOLOGY since the update it’s not us it’s a roon issue.

1 Like

I am sorry, but I am faced with the same issue. Watched Folder on my Synology does not work automatically anymore.
My workaround for a manual rescan is:
Deactivate the folder and than activate it again.

Poor improvement by Roon 1.7 (Build 667).

Restart of the Roon server did not help to solve that issue.

The issue isn’t a lack of subfolders, it’s the last version of Roon having trouble dealing with NAS root level folders as storage locations.

To test this: add a new storage location to:

Diskstation/Synology DS109+/Music/a test subfolder of Music you create with some music files

Or better a completely new location like

Diskstation/Synology DS109+/Test/Testfolder

Make sure you ádd that new location and not change the current one as it will have to rescan your entire library again afterwards if you do.

Now move a file from that last folder. Check if Room noticed it. Now move it back into the folder. Check again.

I’m pretty sure it is an issue in the latest build and it’s related to the fact that we’re using root level folders for storage locations but more than one needs to test this.

Observe my folder structure (last - test - storage location is not pointing to a subfolder of Web, hence doesn’t work)

1 Like

Btw not all complaints in this thread pertain to this particular issue

I added a couple of albums to my QNAP and had to stop and re start the Roon app for them to appear.

Same issue here. Tried all sorts of things to no avail.
It’s a problem with the 667 update. Doing a Force rescan on your music-folder after adding music is the only thing you can do while waiting for a fix.

Okay. I now know what you mean. The subfolder should be added as storage. So I could test adding Music/HQ

1 Like

Splitting into 2 subfolders worked for me. Was originally just Roon_data.

1 Like

Thanks Anthony_Miles. This was what I meant. Clearly a bug in the Roon build.

If you can test this as well, Michael, we can notify Roon support (if they’re not already reading).

Hello @Michael_Sicher, I have discussed this and similar threads with our team and we’d like to open an investigation into this issue. Could you please force a rescan of the main folder and reply here with a timestamp (in your local time) when you do? From there, I’ll enable diagnostics and create a report for the team. Thanks!

1 Like

Hello @nuwriy, starting rescan of 4 folders @ 09:00.

Same issue with my QNAP-TVS-471 since build 667.

I’ve had nothing but issues with the last build… is it possible to jump to an earlier build while you work this one out?

Same issue with my QNAP-HS-453DX since build 667.