Roon 1.7 (Build 667) - No automatic file rescan anymore

FMPOV i can’t believe its been a week and they’ve still not addressed the ■■■■■ issue 667

Hello all, and thanks for your reports! Our QA team has opened an investigation into the issue and is working towards a resolution. While I can’t offer any timelines, I have added your reports to the investigation.


@nuwriy @danny any idea how long this is going to take? its been almost 3 weeks now …

The problem starts getting annoying! What’s the status @nuwriy?

Sorry for the ongoing troubles, everyone. This remains a high priority issue that our team is investigating. We’ll be sure to keep everyone in the loop as soon as we have more information.

1 Like

Same problem over here… very frustrating… any idea for resolution times ?

Come on Roon… it’s been over 4 weeks @danny @dylan @nuwriy

I don’t know what’s worse. That this particular problem with build 667, released 35 days ago, hasn’t been fixed yet or that despite everyone who runs Roon on a NAS with a root music folder experiencing the same exact issue that support is still asking for screenshots like it’s some type of mystifying inconsistent phenomenon.

Perhaps it’s the irony that the whole point behind this maintenance release seems tailor made to address a problem such as this one as the bug and the affected group is so readily apparent.

“…they allow for more flexibility in the future for how we distribute releases to users, so we can test bug fixes with affected users before they go live to the wider Roon community.”

Personally, the thing that annoys me the most is that I’m very careful with software updates and read every release note and the release notes for build 667 seemed to imply that the affected changes were with how it interacted with Roon’s end and not how it worked locally.

“We have a maintenance release going live, with some infrastructure changes related to our updating system.
The changes in Build 667 should be largely invisible…”

If you had added some additional information in the release notes about changes to how local file directories were handled or released it as version 1.8, I would have never updated and waited for the next release. And I would be enjoying and listening to music right now instead of writing my first rant post since running Roon trouble free for nearly three years.


Same frustration here. And at least let people who are affected do a roll-back to the previous build.


Hi everyone,

I just wanted to reach out and let everyone know that we are still working on this, and that while I can’t provide specific timelines just yet, this remains a high priority issue for us. In the meantime, clicking the 3 dots next to the watched folder in Settings > Storage and choosing Force Rescan will allow any new files to be added to Roon.

You have our apologies for the ongoing trouble, and we’ll be in touch about this with further information as soon as possible.


Same issue here with a QNAP TS-473 running the latest QNAP firmware, Roon Build 667. Have to force Rescan for newly added files to show up. Removing an album from my library used to automatically show that it had been deleted from the library in real time but this no longer works.

1 Like

@danny @dylan Any update, news, resolution?

This was reported mid October.
This thread began 20th October.
It is now 7th December.

Do you folk at roon think leaving this unresolved is acceptable ???


My guess is that, since this is happening with a configuration they don’t like anyway, i.e. running Roon on a NAS, the folks at Roon are happy to wait to include the fix in some upcoming release.

1 Like

Fully supported on QNAP

Well the kb could’ve fooled me, and it’s very understandable that reasonable QNAP users who read something like that and bought a device based on RoonLabs’ advice might assume that maybe someone at RoonLabs should fix their problem already.

I was thinking more of this, just above what you linked to:

NAS devices are electrically and mechanically noisy, not optimized for high-performance audio, and not especially powerful (for their cost). With the arrival of 6TB and 8TB drives, most people no longer need a multi-disk NAS in the home because all their music can be stored on a single drive and less expensive machines for running your audio system exist.

I do run Roon on a NAS, btw. Moved it there while doing some maintenance, and never needed to move it back to the “official” core machine.

1 Like

Oh, totally.

Problem is the kb calls the TS-473 “pretty awesome stuff” a paragraph down…


Hi everyone,

Please give the latest update a try and let us know how it goes. Thanks!


Works fine here.