Roon 1.7 (Build 667) - No automatic file rescan anymore

No working for me, restarted both the Roon server and the NAS, no luck with this update, all devices have been updated as well.

Everything :ok_hand:, went quick and smooth!

1 Like

Hi @Fabio_Cicchinelli,

Can you try restarting your NAS once more and check to see if there is any change?

No luck @dylan , restarted the NAS three times with no success, restarted my iMac Pro with Roon Client and nothing update, any help is highly appreciated as I have been importing a large amount of new material to my library just in time for the holiday and some time off. I was hoping that the latest update would have addressed the issue.

Just updated to the new version on my QNAP TS-473 and this seems to have solved the “Wating for new files in real time” issue. Removed an album from the library and it was immediately removed, added the album again and it reappeared in real time just like it used to! (no need to manually update my library).

I did not need to restart my NAS or stop and start Roon App everything just updated as it should. Hopefully this has solved the issue and appreciate the effort from the Roon Team!

1 Like

Running on a decent spec synology and it works fine. Beta over, give it me haha :+1:

QNAP TS-253D here (running core + storage) and still not working. I restarted the QNAP and Roon server after installation but no. I still need to manually re-scan if I remove or add something.

One question though, should I add my storage location as local storage (since core is running on NAS also) or as network share? Does it matter in this case? I now have it added as local storage but I tried network share with Roon build 667, they both functioned same and both needed manual re-scan after changes in library.

I was also wondering that could it matter what kind of volumes for hard drives I use on QNAP? Options are static, thin or thick volume. Now using thick.

I my case both the Roon Core and all my music files are located on the QNAP. The Core is located on a M.2 SSD within the QNAP and the music on the spinning disks all of which are Thick Volumes.

As for the Storage Location this should be a simple matter of going to the Roon software – Settings – Storage – Add Folder – “Select your QNAP” – Browse for the folder where your “Music” is stored – “Select This Folder”, that’s it. No need to “Add Network Share” if you’ve already added your NAS and it’s visible, if not add it.

Everything is working properly for me now when adding/removing albums it’s all updated in real time, no need to force “Rescan”.

This may not help you resolve your problem but at least you know it’s working for others with this setup.

Thanks for your input. I have two slot QNAP and other slot has 250gb WD Blue SSD and storage drive is 4TB WD Red. All applications, including Roon core, is installed on the SSD obviously.

I’m now trying to relocate my library folder from root of storage drive to one step further as someone said earlier that this helped. So I made shared folder “Media” on the root and moved my Music, Movies etc. folders there. Let’s see if this helps, I’m rebuilding the library in Roon as I write this message.

Problem solved. Now after relocating the library, changes are automatically noticed. Not sure why Roon doesn’t like root folder libraries but this seems to be the problem.

1 Like

Same issue here with QNAP TS-251A which runs core and storage. Adding new file still not working :unamused:

Worked fine up to build 667 was installed.

Version 1.7 build 710 - works fine now on my QNAP TS251+ with 8GB RAM

Maybe the nas firmware (here 4.5.1.1465) makes a difference?

Newest QTS version is 4.5.1.1495. Try if updating helps.

My issue has been resolved disabling and re-enabling back the watched folder; it now update as it should, of course after the latest update.

1 Like

QNAP TS-251A, 8GB Mem. Updated QTS to version 4.5.1.1495, Roon core to build 710, rebooted and disabled/enabled storage. Still no luck.

Where on NAS do you keep your music folder? If on root folder, check my earlier messages and try to move the library from root folder to one subfolder further. This helped in my case.

Try reinstalling roon from the roon app itself.

Thanks @patouskii, already read your message. My music folder is “/share/Musik-HD”. So that should not be the problem.

Someone correct me if I’m wrong but I think share isn’t actually a folder when we talk about NAS storage? I guess you have your library as network share instead of local folder?

You can quickly try if this works by creating subfolder to some of the root folders, add that location to roon and test by adding/removing files there.

1 Like