Roon 1.7 causing MacbookPRO 2018 to run fans at high speed

It still is happening to me as well. I started Roon remotely on my MBP and when I got to the conputer several hours later the fans were screaming. I am not going to run Roon unattended on the MBP. Very annoying. It must be a graphics issue as 1.6 didn’t do this and I think graphics were changed with 1.7.

Hello @William_Gow,

QA is still investigating these reports at this time. I can certainly add your report to the investigation ticket, but can you please let us know:

  1. What is the model of the Macbook Pro and from what year is it?

  2. Do you notice consistent 200% CPU usage or would you define them more as “spikes” that go up and down?

  3. Does rebooting temporarily resolve this issue?

  4. What is your networking gear model/manufacturer and how is the Core connected to the network (WiFi/Ethernet)?

Hello There

MacBook Pro (13-inch, 2017, 2.3 GHz Dual-Core Intel Core i5, 8 GB 2133 MHz LPDDR3, Intel Iris Plus Graphics 640 1536 MB.

I tried rebooting and the problem remained, it wasn’t a spike. I am currently using Roon and for now the cpu is spiking at 58% though going up and down and is acting normally with no fan noise.

So it seems like an intermittent problem.

Hope this is helpful.
Regards

PS connected by WI Fi. A Netgear unit, sorry am not more technical than that. Regards

Hi @William_Gow,

Thank you for that additional information, I have added this to our investigation. If we have any further follow-up questions, I will be sure to let you know. I appreciate your patience while this investigation is ongoing.

Hi,

I have this same issue too on a Mac Mini, on which I opened [this ticket] (Roon and RAATServer consuming over 300% and 100% CPU on Mac Mini) with lots of debug info in it before finding this thread.

To answer the questions you posted above @noris

Mac Mini 2018 3.2GHz 6‑core 8th‑generation Intel Core i7
Mac OS Mojave 10.14.6
32Gb RAM 2666MHz DDR4
256GB SSD storage

Its consistent for hours no matter what you do in the app.

Yes it does

Ubiquity -
185Mbps DL via Comcast DOCSIS 3 connected to
Unifi Security Gateway In turn to
Unifi 16 port managed switch
1Gbps connections on wired Ethernet to the core and library
Library is on a 6 disk Netgear ReadyNAS with dual bonded 1Gbps to the Unifi switch

2 Likes

Juat checking back. the problem continues to persist. it’s a bit of a hassle to login to the NAS to restart Roon and it’s pretty temporary. For instance, it may only last 30 minutes and then the fans will start and the CPU usage will be >50%. Anyway, appreciate any efforts for a solution.

Hi @Jaap,

Thanks for the update. QA is currently investigating this behavior internally. I can’t comment on a timeline of when the investigation is complete, but we’re working on narrowing down what could cause this behavior.

I thought I had it licked. I had disabled Dropbox syncing and turned off Better Touch Tool (which had a Roon for the touch bar app). Roon worked for 3 days without hi fan usage. Then I closed down Roon and restarted it again after about 20 seconds. It went to over 300% CPU usage. I then stopped Roon again. So… 3 days with no problems after a reboot but then for no apparent reason it became a resource hog.

@Progisus your experiance echos mine, when it goes to 300% +CPU its right after Roon starts, never when it has been running for a while.

1 Like

I dont see the exact same scenario as you guys, but i do notice a high power consumption of Roon on my MacBook Pro (2017 model, i5)
But, the fact that Roon pulls three full cores after startup shouldn’t be a surprise? It does need to rescan your libraries and recheck any cahnges in metadataproviders if something is discovered?

I normally don’t use my MBP as Roon Core though, only when i’m on the go, along with an external 4Tb drive and some InEars.
At Roon startup, it does pull a lot of power. After a few minutes, when libraries are rescanned and no music playing it demands some 30-40% of CPU resources. Of course this requires that all audio analysis has been finished. While that is being done all fans are on and power is drained at an alarming rate. (CPU usage as you describe, 200-350%)

When all is done and ready though, music playing and powering the external 2.5" music drive, the batteries still are drained pretty quickly, around three/four hours i’d say.

Edit: I seem to have a similar issue, as of right now, playing back a single stream, a 16/44.1 file from the external harddrive, to one endpoint. This should not need a full core. Still Roon consumes between 70% and 100% of CPU resources. (One full core, out of four.)
Library scanning was finished, both Qobuz and Tidl connected.

Edit2:
I left the Roon Core one the MBP playing and did some chores while playing music. after an hour, the CPU consumption was normal, around 10-12%… Weird!

I’m going to have to review my assertion below

This morning after running for a day Roon kicked up to 300% + and won’t get its self back in order, despite restarting the app multiple times. On this Mac it’s a remote and browser only, the core is on a Linux box so its not media scanning.

Restarting the whole Mac Mini solved the issue, at least on a temporary basis.

1 Like

Mine is a control only and has been running smooth for a day and a half. It has not been stopped. I am watching carefully to see what may start it into high cpu. I really suspect a graphics issue as it is control only. I have a 2014 MBP as well with no issues. I think it has a different graphics chip though.

Same issue here, MB pro 2013 as remote, fans run and graphic’s performance falls down while roon is open.

same issue here (300%roon / 100%RAATServer)
mac mini, specs in screenshot (remote)
core is rock on nuc
network: wired to gigabit switch (dlink 1024d) both core and remote

I’m having the same problem as everybody else. The fan spins like crazy, Roon maxes CPU usage and on the energy tab in Task Manager the text turns red.

Roon 1.7 (Build 528)
Mac Mini (2018)
64GM RAM 2667Mhz DDR4
MacOS 10.15.4
Intel i7 3.2Ghz 6-core
Intel UHD Graphics 630 1536MB
Internet via 10Gbe port
Music on local hard drive
Endpoints: Opportunity UDP-205 and PS Audio DirectStream DAC with Bride II (connected via CAT6a ethernet
Streaming Services: Tidal & Qobuz

Well, not as everybody else.

Where are you in your process with Roon?
I mean, is your library already indexed, analysed and done with by Roon Core? Have you recently started the Roon application? Has it been running for a few days, while your lappy slept in between uses?

Give us some detail, please.

My company VPN seems to be the cause. Anytime I jump on the VPN for a work function, it’s Cisco AnyConnect, Roon will spin up to 300%. Every. Damn. Time. Reboot fixes. Tried quitting Roon before connecting to VPN and then restarting Roon after disconnecting, and it still goes gonzo. Only reboot resolves. I do have “Allow local (LAN) access when using VPN (if configured)” setting checked so I don’t drop my local NAS. Maybe I’ll uncheck that and see if it behaves differently next time I use the VPN.

Only a single test, but it seems that if I don’t have the “Allow local (LAN) access when using VPN (if configured)” setting checked when I get on my VPN, I don’t see the problem. It does take me a few tries to get my NAS remounted after killing the VPN, but once my NAS is connected and I relaunch Roon, it behaves normally and utilization is normal.

Hi Support,

Has any progress been made on this issue. It had disappeared for awhile but with the latest update it sems to be back. Shutting it down and restarting is not helping at present. A reboot did help.