Roon 1.8 Android hangs and have to force close app [Fixed in Build 795]

Just to throw some more troubleshooting fodder into the mix for @support, I’m sure there will be a broad set of back-end differences. For example, I’m running my Core on a Synology NAS rather than ROCK, Mac or Win10.

Essentially, I reckon it points to the Android app itself under a set of undetermined conditions (as it is not everyone suffering, but by no means isolated). The list of devices is not limited to a single manufacturer, so unlikely due to any OEM bloat-OS.

Same issue on my Samsung Galaxy S9 (hangs on splash screen), this started happening since the 1.8 updates and it happens daily. It’s pretty annoying.
I just booted the phone into recovery and wiped the cache partition, we’ll see what that does.

Yes I am as well, only since 1.8

My only 1.8 issue, Samsung Galaxy Note 9

Have cleared Cache, uninstalled, reinstalled etc

I’m also still experiencing the splash screen freeze. First posted about 8 days ago.
Have @support said anything else in another thread about this that I’ve missed?

Have tried the reboot ROCK and network, uninstall and reinstall apps, cleaning device cache and the 255 fix but nothing works.
Problem persists even when the devices have nothing other than core Android background processes running - ie processes you can’t kill.

Problem is getting worse if anything - took 3 attempts on tablet to open Roon this morning. Phone was on attempt 4 and still no Roon access before moving over to tablet.

All of our affected devices are running build 1.8 (756 stable).
Affected devices are
2 x Huawei mate 10 pro running Android 10 and
1 x Huawei mediapad M5 running Android 9

FWIW - Roon control via OSX is smooth. But OSX lives in the basement.

1 Like

There has been almost no acknowledgement in other threads I have read (but I will be honest and say I have been avoiding most of the 1.8 is *&$t threads since the night of the 9th). I helped a few people with the same network issues that had Samsung phones that had also updated around the same time, but these mostly would then connect.

Thankfully all my Android devices work fine (OnePlus 8, 7 Pro & Pixel C, with only the wake from sleeping screen redraw issues on the Pixel C

It will be interesting to see what the resolution to this is later, as it doesn’t seem too affect many people but it would be seriously annoying if it affected you.

Still no improvement infact it seems worse! Almost given up using my android phone and instead just use my ipad instead but its really annoying and disappointing that support hasnt even commented yet on what seems like a widespread issue after a major release. I work in software development for a large SAAS provider as a developer so i understand bugs happen especially with large relaeses but some kind of acknowledgement that they have at least looked at the issue would be appreciated.

1 Like

Yep restarted core a number of times also rebooted the server itself a few times for numerous reasons. Also reinstalled the android app just in case and non of it has had an effect.

In that case Daniel let’s hope they get an Android update out relatively quickly.
It’s sounds like the development team is working hard on trying to fix these and get some updates out.

In a scenario like this, you can see the benefit of what Apple, Google and Microsoft do of allowing people who look for it to get it earlier and when something goes horribly wrong they generally stop the rollout. But never to my benefit as I have always pressed that button as soon as possible.

Not had issues on Android but with Windows I am finding it to be really buggy and getting it hanging quite often when going back from areas. Never had issues with stability on windows priorto 1.8 it was rock solid unlike Android. The tides now turned the other way for me.

Same issue here. When I start the app it freezes in a black screen. I use a Samsung S10 (Android 10). Roon version is 1.8 (build 756).

Might have been better if you hadn’t said anything :pleading_face: but good news for the day so far :+1:t2:

Sim I got to play with my s20 phone again. The same issue: if I try to connect to the idle core, no game. But after I wake up the core with my iPad, all is fine.

Same here. Reinstalled the app no problems for a few days. S9 android 10

I experience it on a daily basis, Samsung S9+. It’s getting very annoying. It does not happen on my PC.

1 Like

Same issue here, with S9

Out of interest, how many of you are running Roon on WiFi?

When I first upgraded to 1.8, I was away from home and ran the core on my Dell XPS13, with remotes on a Samsung Galaxy S20+ and Samsung Galaxy Tab S7+.

Both failed to connect to the core many times, but since returning home and running the core wired on a NUC, I have no issues connecting. At worst there has been a few seconds delay before the remote connects.

Hope there is a solution for those who are still frustrated soon!

Glad it’s not just me then.

My app hangs on startup or focus constantly just like everyone else’. Samsung S8


I’m still experiencing the issue on my Samsung Galaxy S8.

I’m getting similar - s21 ultra. Regular freezing of app requiring force close. After restarting app usually ok, but sometimes have to restart app again before it responds

Samsung s9.