Roon 1.8 (Build 880) Feedback Thread

Roon updating doesnt affect your computer just Roon. It’s not going to change how your printer works or anything else other than Roon.

yep, i read that. But it was fine before this update.

only thing that worked was reinstalling roon and starting over with a fresh database.

lost history, album edits, playlists, audio zones.

Would be nice if Roon had a “database analyzer” that one could run beforehand to find issues before a new update destroys everything.

Still can not update my Fire HD 10 Pro Tablet, still showing the old version 831 and no where to update, if I go to the play store it says installed, and only shows devices avalible to isntal on is my Samsung phone, and hp Tablet.

I have tried uninstall install ect… reboted core x num time…

I am assuming the push to Amazon App store is delayed some how or still under review??

again love the new features, and the work

My Roon Rock just got killed by the latest update. The database is corrupted and I have to revert to a backup. What is going on?

Exact same issue here. Roon core is on one Windows 2012r2 server. I made a restore from an old backup. 10 minutes later…same issue… HELP !!

There are at least 3 people with the same issue. I don’t think we are talking about a real database/hard drive failure. I think there is a compatibility issue with some Windows versions, hardwares,… Can you please revert to the previous version of ROON?

1 Like

Nicely done @danny @enno and team! Thanks for the holiday cheer! All went smoothly for me with my Roon Nucleus and various control devices. Heck, even the SQ seems better!


Windows 11 Core server


Windows 10 Surface tablet
Windows 11 Laptop
RPi4 - diet pi, roon bridge
Rpi3b+ - Ropieee
iPad Air (old) - Roon Remote app
Samsung Note 10 - Roon Remote Android app
Stack Audio Link II
All working with no issues, all those that needed updates got them.

Hello Roon team. Incredible update, smooth interface, enhanced search etc., kudos!

Some of us are still concerned that the scrolling issue on the Apple Magic Keyboard has still not be fixed. We are wondering if you’re hearing our voices, it’s definitely an immense pain point. Please seriously consider fixing this issue - not sure why there’s been a lot of push back on this small fix. So team let’s just fix this once and for all, you’ll surely make Roon users very happy.
All the best.

Assuming there is a Feature Suggestion for this, have you added your vote there? And, if there is not, you might create a Feature Suggestion for it.

That’s the thing, though – it wasn’t fine. :slightly_frowning_face:

Your database was already corrupt, but the corruption only revealed itself when you took the update. This is why your backups are also corrupt, and is what we refer to as “latent” corruption.

This is essentially what we just released – Starting with Build 880, Roon is scanning for corruption on-the-fly instead of only during software updates that require a database re-scan. This ensures that you won’t carry on with undetected corruption or make corrupt backups.

1 Like

Horrible build quality. Kinda as expected. Many known issues got worse. Update did not work on my MacBook. Had to reinstall to get out of the update loop.

Most of the advertised network/library improvements got even worse.

What are you guys doing??? This is not even public beta quality. Seriously.


Great update Roon team. No doubt the sound quality has taken a nice step up in performance. Very pleased. Innuos Zenith 3 server.

I’ll add my disappointment to the list:

It continues to look for an update for the QNAP NAS.

My IOS devices which I haven’t updated still work.

1 Like

After installation of Roon 1.8 (Build 880) it’s not possible anymore to sort tracks in playlists on iPad mini 6. generation. Before the update it was possible. Please bring back this functionality.

I hate to say it, but really all I can say is: Wow. (I didn’t even want to update. But, could not access anything - forced update today). Yesterday, everything was just fine.

Today, my entire streaming platform is down. So, no tunes, lol. I’ve already spent a few hours trying - in vain - to get Roon up. Rebooted, numerous times, etc. (I’m admittedly no MAC - or PC for that matter wizard. Nor, am I, unfortunately, interested in becoming one. I am a music lover and audiophile who just wants to listen to music - easily and without hassle. Sorry, Roon, lol).

I’m running the Roon Core on a (dedicated and optimized - with all superfluous items turned off) Mac Mini (mid 2011) 2.5 GHz Intel Core i5, Memory 8GB 1333 DDRS, Graphics Card AMD Radeon HD6630M 256MB. The OS is MacOs High Sierra (I believe this is the most up to date os this will run).

Frustratingly, here’s all that I can accomplish:
Over and over again, The update (shown in Settings → About) on the Core shows “downloading” progress bar until about 3/4 of the way through the bar, then before reachin g the end of the bar, it reverts to “installing” and then - in a few seconds - “There was an error checking for an update” message appears.

Furthermore, on my Samsung Galaxy S2 (running the latest update (Android) software and used SOLELY as a remote for Roon, it doesn’t appear to “Open” the Roon update in Google Play. Not really sure, if it needs an update or already has it, but when I tap the touchscreen on OPen nothing will happen (in Google Play.

On the “Software Update needed” screen (which Roon forces me to be on when I opened Roon today) it says a few things:

"Software update needed
Roon is trying to connect, but it looks like one or more devices on your network need a software update.

(Icon of Mac Mini) Mac Mini
1.8 (build 790) stable

(Icon of Tablet) This Tablet
1.8 (build 880) stable


Thank you to all you great and knowledgeable people here on this forum community. I’m sorry that my computer technical ability, basically leaves me unable to contribute helpful advice to others, in any meaningful way. (With that said - and maybe I’m just too old school - it does strike me as a shame that Roon seems to have largely offloaded support to it’s customers. Maybe I’m wrong on this. Anyway, that’s a touchy topic best left alone, I fear. Would just like some tunes today while I ride Zwift, lol)

(Lol, if this keeps up might have to go back to near state of the art vinyl and “silver disc” spinning.

Best regards to all,

1 Like

Did you guys change the default ports? I’m running core under Fedora and the firewall rules that worked before this update no longer do.

1 Like

It does appear that this problem isn’t widespread. It happens for me on both Windows and IOS remotes, and happens intermittently with no discernible pattern that I can see. I haven’t tried using different scaling settings in Windows, and although an interesting suggestion, it doesn’t feel as though the problem is scaling related for a number of reasons.

Roon Radio can sometimes offer 5 or 6 perfect metadata page renditions in a row before the first problem page manifests itself. Thereafter, problems can be intermittent or there can be 4, 5 or more pages in a row with intermittent and ‘different’ metadata problems. Sometimes missing album data, sometimes missing album covers, sometimes missing lyrics or background photo and sometimes two or more of these.

During my first year of using Roon, Roon Radio functioned perfectly without any missing metadata issues whatsoever. The problem was first introduced on my setup by a specific software release (I can no longer remember which specific release), remained in place for almost a year before being resolved briefly for a few months by another specific software release and finally re-introduced by a specific 1.8 build some time ago.

During this whole time, my Windows 10 Desktop PC, monitor and network have remained unchanged, as has my iPad Air remote that I use with a second system. My broadband provider has remained the same over this period, and I currently get a download bandwidth of some 80 Mbps. In fact, when I first installed Roon, my bandwidth (from the same ISP) was a paltry 3.5 Mbps, and I didn’t experience any problems at that time. Roon worked pretty much flawlessly.

The fact that my Roon setup has operated for periods of up to a year without an issue, and the fact that the alternate occurrences and resolution of the issue have coincided on each occasion with a Roon build release lead me to believe that the issue is not a scaling issue.

It has been suggested to me that switching to a different DNS lookup server could be a resolution, but this is not an option for me with my particular ISP and other than this one specific problem with Roon, I have no issues whatsoever with my Internet access.

I still love Roon and will continue to subscribe for as long as Roon is available. Nothing else compares for me, but this one issue is definitely something of a nagging pain and I wish it would go away or be resolved!

well, when i said it was fine, i meant that Roon appeared to run without issue.

Nice that with this update roon scans for corruption… does it “fix” the corruption, or just notify you, or what?