Roon 1.8 on linux Streaming of TIDAL works but TIDAL integration does not

Hello Roon experts,

I am running roon 1.8 latest on linux (debian). Streaming of TIDAL albums which have been added works but TIDAL does not display contents in Main menu TIDAL. Furthermore, when I want to select an Album recommendation from overview I receive "Unexpectet error, try again later (unauthroiezed).
I have already tried to delete the cache in /var/roon and I also disconnected and reconnected to the TIDAL account. Furthermore the Metadata optimizer is paused.

Since Streaming of TIDAL albums works I have no clue about the cause of the error. Please advice.

Thank you

Quick thing to try is log out and back in for Tidal, in the services section of Roon.

1 Like

Thank you. I tried to disconnect and reconnect to Tidal several times. It does not solve the problem.

1 Like

Please find error log:
06/21 22:00:37 Error:
Local Time: 06/21/2021 22:00:37 +02:00
Device Serial Number: xxxx
Roon Version: 1.8 (build 795) stable
OS Version: Linux 4.19.0-6-amd64
Mono Version: (tarball Fri Apr 30 22:53:11 UTC 2021)

Application Domain: RoonAppliance.exe
Assembly Codebase: file:///opt/RoonServer/Appliance/RoonAppliance.exe
Assembly Full Name: RoonAppliance, Version=, Culture=neutral, PublicKeyToken=null

Exception Source: Roon.Broker.Core
Exception Type: System.NullReferenceException
Exception Target Site: State…ctor
Exception Message: Object reference not set to an instance of an object
Exception Data: none

–[ Stack Trace ]------------
Sooloos.Broker.State…ctor(BrokerConfig config, StorageManager storage)
Roon.Broker.Core.dll, IL 265, N 1387
Sooloos.Broker.Modules.Core.Create(BrokerConfig config, String platform)
Roon.Broker.Core.dll, IL 130, N 407
Sooloos.Application.Main(String[] argv)
RoonAppliance.exe, IL 1284, N 5763

Hey @kkaaii,

I’m sorry that we’ve taken this long to get back to you. Sorry about the trouble!

I was wondering if you could try one more thing, if this is still an issue:

  • Close Roon
  • Navigate to Roon’s Database Location
  • Delete the tidal_account file in Database/Registry/Core/tidal_account
  • Try to start Roon again

Please, let me know how it goes :pray:

1 Like

A post was split to a new topic: This track is not currently available from TIDAL + Too many errors