Roon 17.0 610 will crash, slow and do weird display

Roon 17.0 build 610 on QNAP
I have just updated to this latest version and i’ve been struggling with weird and unacceptable issues.
Until now, Roon Core has been working like a charm, always up-to-date with the latest build.

Since I updated to this morning, the Roon Core :slight_smile:

  • will slow down
  • will crash (always)
  • will show artefacts/display glitches on the buttons interface

Obvisously, i have restarted Roon, the Nas, the network…

Can you please help / advise ?

Thank you,

Sorry for the troubles here, @Fabrice75017.

Does this issue occur for all remotes? Does it show that RoonServer is running on the QNAP?

What kind of remotes are you using?

Hi Dylan,
It occurs on the remote where the update has been installed (win 10).
My other remote / PC Win 10 with Roon 1.7 build 555 runs fine
Hope that helps (i should have added that to this conversation first…)

Hi @Fabrice75017,

This is an older build of Roon, I suggest you update this one as well.

Since you are running Roon on the QNAP, is there any change in behavior if you try to reinstall Roon on the problematic Windows Remote?

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location (On the Windows - uner %localappdata%.
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Connect to the QNAP Core
  • Verify if issue is the same

Hi Noris,

Just to be sure to understand (as i have not checked yet):
There is a database or sort of on the Windows remotes ? Is it linked in some way with the Roon server/core database ?

Basically, you are just asking me to rename a folder and reinstall the Roon remote, all this on my failing W10 machine, right ?


Yes, that is correct, remotes also have their own Roon directory, because it needs to be installed somewhere. It is linked to the Core, yes, but since all of the database info resides on the Core, this will have minimal impact on your database (still though, make a backup as per item #1 in my list).

Yes, Roon is installed under the %localappdata% directory as per the guide:

Find the Roon folder from list -> rename.

Hi @noris, @dylan,

I have gone through the steps (reinstall Roon remote) as advised and there are still the same graphics glitches and general behavior (freeze and crash)

If that helps, please find below an extract of the application logs:
Faulting application name: Roon.exe, version:, time stamp: 0x5f3d3abf
Faulting module name: ntdll.dll, version: 10.0.19041.423, time stamp: 0x06701e03
Exception code: 0xc0000374
Fault offset: 0x00000000000fed79
Faulting process id: 0x31a8
Faulting application start time: 0x01d677159295ff3e
Faulting application path: C:\Users\cousc\AppData\Local\Roon\Application\Roon.exe
Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll
Report Id: 5dc26ab0-f0eb-4738-b209-83c385240836
Faulting package full name:
Faulting package-relative application ID:

Attached you will find some screenshots of what and where those glitches are (let’s say everywhere on front/first display of albums for example and every contextual menu or scrolling)

In addition, please find a link to the Roon logs if they can help as well!ApLXH4L27b0bsZIrqKFmQQZHkBfb3w?e=SevN01

Latest update,
After some investigations and setting up some graphics / display parameters, i ended up with enforcing the use of Nvidia RTX2080 card instead of the Intel UHD for Roon.exe + forced the hardware accelerated GPU scheduling on Windows side (new feature from 2004 build).
It is doing the trick actually even if i’m a bit surprised that would be the definitive solution.

The logs that you uploaded are from your core. To help diagnose graphics issues, please provide logs from Roon running on the affected remote.

It’s possible that you need to update the drivers for your Intel graphics. You can download the most recent Intel drivers here, though I personally use the Intel Driver & Support Assistant to keep all my Intel drivers up-to-date. If you have a laptop, I would check for updated drivers from the manufacturer before using the Intel generic drivers.

Sure, i agree about the logs, those are from the server, just in case they could help in some way.

You will find there 2 sets of logs from the Roon remote
The old : yesterday to this morning until the reinstall of Roon with the Database folder suppression. Since this morning, i have been only investigating on the graphics/display side…!ApLXH4L27b0bsZImxFvXXcmcabe6dQ?e=BXckMQ

All the drivers are consistently updated, and I’m also using the Intel Driver clerk. Then, the Intel UHD 630 is in the very latest version available, as well as almost every component in my machine (MSI GE75 RTX 2080), from MSI and other manufacturer where required , like the Nvidia GPU drivers for example.


1 Like

I have just added a log file (timestamped at 8:33pm)
Roon was freezing and I closed it after 1 minute.

(The issues are then still occurring as one might have guessed)

To clarify, so the forced hardware accelerated GPU scheduling on RTX2080 did not workaround this issue?

Nope, it did not.

Try downloading the latest nVidia driver, uninstall your curent driver, reboot (this is important), then reinstall the nVidia drivers again.

I have done this a couple of times, with no result.
BTW, i can observe that the issues (at least the graphical glitches & artifacts) don’t occur when nVidia drivers are totally wiped out from my W10 machine.
I would say that nVidia is the culprit somewhere…

I’ve given some other tries.
On my machine MSI GE75 + RTX2080
Situation is:

  • W10 2004 build 120.2212.31.0 + nVidia latest and only one compatibles drivers (452.06) + remote Roon 610 = KO
  • W10 2004 build 120.2212.31.0 + nVidia latest and only one compatibles drivers (452.06) + remote Roon 571 = OK (the situation before the latest update…then the crisis begins with 610…) but i cannot revert back to Roon 571 (i would love that…)
  • W10 2004 build 120.2212.31.0 + no nVidia drivers installed + remote Roon 610 = OK but not acceptable !
  • W10 2004 build 120.2212.31.0 will not me install older nVidia drivers (i’ve tried a couple of versions up to 451.77)

Could you stop Roon and run some 3D stress tests for several hours, to verify the nVidia setup?

I have already done some, still i’ll be happy to proceed if you can recommend a specific test
thank you!

GpuTest, Furmark and memory tests