Roon 2.0 and Linux (Wine) .. is 32bit needed? [answer: no, wine supports 64bit]

It is my understanding that 32bits versions of Roon are no longer available. Is this the end of Wine compatibility?

1 Like

I believe Wine 7 has 64bit arch?

1 Like

Although 32 bit Roon is no longer available, you can still use Roon in Wine; just be certain you use a 64 bit Wine config. I’m currently running Roon 2.0 using Bottles, others may provide guidance using Wine / Winetricks.

These are the steps I took to install Roon on Ubuntu 22.04.

flatpak install bottles
sudo flatpak override com.usebottles.bottles --filesystem=xdg-data/applications

Create a Windows 10 64-bit bottle, and add .NET 4.7.2 dependencies. Add the following Launch Option: -scalefactor=1`.

If the shortcut fails, change it as follows. [You may not need this, but check before copying verbatim.]


[Desktop Entry]
Exec=flatpak run --command=bottles-cli com.usebottles.bottles run -p Roon -b 'Roon'
Comment=Launch Roon using Bottles.

If Flatpak isn’t installed…

sudo -i
apt update
apt upgrade --yes
apt install --yes gnome-software flatpak gnome-software-plugin-flatpak
flatpak remote-add --if-not-exists flathub
flatpak update

Are you using the Ropiee setup to get Roon 2.0 working on Linux desktop or were you able to just install it using Wine 7 and Bottles?

I’m using Bottles only; I didn’t use @spockfish’s script nor installed Wine. Everything you need is in my earlier post.

Other’s have used Wine to successfully install Roon 2.0, and may post here at some point.

Thanks, just tried to run the installer with Bottles and .NET 4.7.2 and it said not compatible so I am thinking there are more dependencies needed. A list would be nice if anyone gets it working.

To be clear, you do not install .NET, you enable the dependencies in Bottles.

I had problems with Roon remote not updating to 2.0 under Wine with the beta versions. Tried bottles with the same result. Went back to a standard Wine install making sure that it was a 64-bit prefix and did not install mono. I was still stuck on 1.8 until today when it updated to 2.0, but it is on the production release and not the beta channel now.

I’ve tried installing the latest PC version under Bottles in a clean 64 bit environment Bottle with just the .net 4.7.2 dependencies, and it just complains “This device is not compatible with Roon 2.0”.

Found it, it worked with sys-wine 7.0 instead of soda-7.0. Seems to be working now.


For those who were ’ Running Roon on Linux with Wine’ with the spockfish script. A solution to 2.0 compatibility has been posted on the github issues section of the project.

To summarise these solutions that have worked for me.

  • Change win7 to win10 in the because Roon2.0 wants Windows 10 or 11 :

_winetricks “Setting Windows version to 10” -q win10

  • In the, comment out _winetricks "Installing .NET 4.0" -q --force dotnet40 and uncomment _winetricks "Installing .NET 4.5.2" -q --force dotnet452

The above worked perfectly for me on both Fedora 36 and Ubuntu 22.04 machines. A mention of needing to change the scale factor to 1 in the ‘’ script was mentioned but everything scaled correctly for me on first run. This needed addressing in the previous versions so no change here.

Credit to kotonbu and tokr1 on github for the solutions. Just reposting here for visibility.


A simple fix for running a Linux Roon remote with Roon 2.0 is at Linux Roon Control GUI Please [not on roadmap, you may try to use Wine] Go to the end of the thread and follow the directions from @Robert_Andersson and @vlad_k and thank them both.

Or read this thread from the top (that’s what you’ve indirectly linked.) :slightly_smiling_face:

Thank for your replies.

I confirm Roon 2.0 works within Bottles with sys-wine.

1 Like

Thanks a ton for the guide @Martin_Webster! I also needed to install .NET 4.5.2 as a dependency and it worked fine with sys-wine. I did not need to change the -scalefactor flag.

1 Like

@Con_Kolivas , did you have to make any other changes other than changing the runner to sys-wine 7.0 ? I continue to have the same “This device is not compatible” error with both options.

My previous bottle failed to work after the last Roon update so after multiple different attempts with new bottles I found a combination that worked.
Create a new bottle using the cafe-6.23 runner in 64 bit.
Add dotnet 452 dependency.
Run Rooninstaller64.exe


I wanted to report success running Roon under Wine by way of Bottles on Fedora 36.

TLDR: it was necessary for me to use the Bottles as packaged by flatpak/flathub. The version of Bottles as packaged by Fedora 36 did not work for me.

What follows are the detailed notes I took for myself, because having used neither Wine nor Bottles before I was confused multiple times by this process. Hopefully they are useful to others.

Uninstall Fedora 36’s bottles RPM. I used Gnome Software to do it via the

Set up flatpak. Fedora does not ship with the usual flathub remote
configured. See or just do this:

flatpak remote-add --if-not-exists flathub

Then install Bottles from flathub. I used Gnome Software to do this.

Compared to Fedora’s version of Bottles, the flathub version has a slightly
different user interface.


  1. Run Bottles, taking care to ensure it is the one from flathub.
  2. Create a new Bottle.
  3. Choose the “Application” environment.
  4. Select the “Gear” icon, which should bring up a file selection dialog. Find and select “RoonSetup64.exe”, previously downloaded from Roon’s website. It should bring up a window telling you it needs .NET and will offer to install it for you. Don’t say “yes”, instead cancel to quite the installer.
  5. On the bottle, press the “>” icon, then “Dependencies”, then install “dotnet48”.
  6. Either back out and press the “gear” icon again, or select the “Details & Utilities” tab and press “Run Executable”. Either way, find “RoonSetup64.exe” again and run it. It should install Roon, and when it finishes offer to run it. I chose “No.”
  7. Under “Details & Utilities” → Programs “Roon” should now be listed. Run it. It should work.
  8. Under “Details & Utilities” → Programs click the “hamburgur” icon, which looks something like “☰”. Then choose “Add Desktop Entry”. Flatpak will probably open a browser showing Programs - Bottles, which tells you to run the following command, which you should:
flatpak override com.usebottles.bottles --user --filesystem=xdg-data/applications:create
  1. Now exit Bottles, restart Bottles, and re-attempt step 8. You should now have a “Roon” entry in your desktop environment’s launcher.

Thank you for the detailed post.

Before I wipe my Rock core to tinker, how does it compare in performance compared to Rock or Ubuntu Roon Server? Don’t worry if you aren’t sure.

I can’t give you a definitive answer. I’m running Roon via Wine/Bottles to get the desktop client functionality only. This machine is not directly connected to any audio devices. I can tell you that I just tried to enable this Roon’s “PulseAudio” output, which did show up among its “Connected to this machine” audio devices, and it did not go well. No output, and errors cascaded such that Gnome informed me that Bottles was no longer responding, etc. Because running games on Wine is a common thing, I suspect that audio could be made to work, but I’m not going to be experimenting with it.

I read elsewhere on this forum that someone installed Roon Bridge on their Linux desktop to actually play audio from it. So they had both installed on one machine: Wine+Roon and Roon Bridge (running natively). Worked for them.

1 Like