Roon 2.0 and Linux (Wine)

It is my understanding that 32bits versions of Roon are no longer available. Is this the end of Wine compatibility?

1 Like

I believe Wine 7 has 64bit arch?

Although 32 bit Roon is no longer available, you can still use Roon in Wine; just be certain you use a 64 bit Wine config. I’m currently running Roon 2.0 using Bottles, others may provide guidance using Wine / Winetricks.

These are the steps I took to install Roon on Ubuntu 22.04.

flatpak install bottles
sudo flatpak override com.usebottles.bottles --filesystem=xdg-data/applications

Create a Windows 10 64-bit bottle, and add .NET 4.7.2 dependencies. Add the following Launch Option: -scalefactor=1`.

If the shortcut fails, change it as follows. [You may not need this, but check before copying verbatim.]

~/.local/share/applications/Roon--Roon--1660488254.903902.desktop

[Desktop Entry]
Name=Roon
Exec=flatpak run --command=bottles-cli com.usebottles.bottles run -p Roon -b 'Roon'
Type=Application
Terminal=false
Categories=Application;
Icon=/home/<userid>/.var/app/com.usebottles.bottles/data/bottles/bottles/Roon__116/icons/Roon.png
Comment=Launch Roon using Bottles.

If Flatpak isn’t installed…

sudo -i
apt update
apt upgrade --yes
apt install --yes gnome-software flatpak gnome-software-plugin-flatpak
exit
flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
flatpak update
2 Likes

Are you using the Ropiee setup to get Roon 2.0 working on Linux desktop or were you able to just install it using Wine 7 and Bottles?

I’m using Bottles only; I didn’t use @spockfish’s script nor installed Wine. Everything you need is in my earlier post.

Other’s have used Wine to successfully install Roon 2.0, and may post here at some point.

Thanks, just tried to run the installer with Bottles and .NET 4.7.2 and it said not compatible so I am thinking there are more dependencies needed. A list would be nice if anyone gets it working.

To be clear, you do not install .NET, you enable the dependencies in Bottles.

I had problems with Roon remote not updating to 2.0 under Wine with the beta versions. Tried bottles with the same result. Went back to a standard Wine install making sure that it was a 64-bit prefix and did not install mono. I was still stuck on 1.8 until today when it updated to 2.0, but it is on the production release and not the beta channel now.

I’ve tried installing the latest PC version under Bottles in a clean 64 bit environment Bottle with just the .net 4.7.2 dependencies, and it just complains “This device is not compatible with Roon 2.0”.

Found it, it worked with sys-wine 7.0 instead of soda-7.0. Seems to be working now.

2 Likes

For those who were ’ Running Roon on Linux with Wine’ with the spockfish script. A solution to 2.0 compatibility has been posted on the github issues section of the project.

To summarise these solutions that have worked for me.

  • Change win7 to win10 in the install.sh because Roon2.0 wants Windows 10 or 11 :

_winetricks “Setting Windows version to 10” -q win10

  • In the install.sh, comment out _winetricks "Installing .NET 4.0" -q --force dotnet40 and uncomment _winetricks "Installing .NET 4.5.2" -q --force dotnet452

The above worked perfectly for me on both Fedora 36 and Ubuntu 22.04 machines. A mention of needing to change the scale factor to 1 in the ‘start_my_roon_instance.sh’ script was mentioned but everything scaled correctly for me on first run. This needed addressing in the previous versions so no change here.

Credit to kotonbu and tokr1 on github for the solutions. Just reposting here for visibility.

3 Likes

A simple fix for running a Linux Roon remote with Roon 2.0 is at Linux Roon Control GUI Please [not on roadmap, you may try to use Wine] Go to the end of the thread and follow the directions from @Robert_Andersson and @vlad_k and thank them both.

Or read this thread from the top (that’s what you’ve indirectly linked.) :slightly_smiling_face:

Thank for your replies.

I confirm Roon 2.0 works within Bottles with sys-wine.

1 Like

Thanks a ton for the guide @Martin_Webster! I also needed to install .NET 4.5.2 as a dependency and it worked fine with sys-wine. I did not need to change the -scalefactor flag.

1 Like