Roon 2.0 - cannot import backup

Roon Core Machine

Qnap TVS-1282, 32 GB, i7

Networking Gear & Setup Details

Fritzbox 7590, Asus

Connected Audio Devices

Number of Tracks in Library


Description of Issue

Hi everyone,

I’m still having problems with Roon.

  • I have now reset my NAS,
  • use a different network adapter,
  • network cable instead of WLAN
  • used different routers,
  • used different backups
  • different Clients (Windows, iOS)

and yet the client always loses connection to the core during recovery - according to the client. As a result, I can’t import a single backup.

In the end it always says that the restore was successful, but after the restart it turns out that nothing happened…

The backups and Roon are on a SSD, so no speed issue and 2 TB space available.

I can install older software versions and they will be updated to the latest version on the NAS, on Laptops (Windows 10 &11) and “I” devices without any problems, can start a backup, but in the end it will not finalize the database.

According to the network resource monitor, the network connection is always active during the import, never stops.

A couple of months ago I restored from the latest backup, without any problems.

It seems that it is either a Core or a Client problem…
Unfortunately I can’t used any older versions (Core & Client), they refuse to work

Does anyone have an idea how I could continue here?

Thanks in advance.

Maybe the problem is because your backups are on the same drive as Roon. I’m not sure if that’s a problem or not.

Obviously, as importing a backup requires a restart (including possibly lengthy startup checks) of the Roon processes on the Core.

Why is that? You yourself write that “In the end it always says that the restore was successful”.

What do you look at to come to that conclusion / What changes would you have expected?
What is the reason for you to go through all this hassle?

Hi Jim,
thanks for the tip, the backups are now on a hard drive. Unfortunately it didn’t work. I’ve tried a few variations, none of them were successfully.

The more times I tried to import the same backup, the faster it finished. Almost two minutes and after the restart you could read that the connection to two minutes ago had been lost.

According to the monitoring, data was copied. Unfortunately, I have no way of controlling the core.

Two weeks ago, a message appeared regarding an update that I started. In retrospect, it turned out that the update to 2.0 did not work.

But there was the possibility to go back to the Roon Legacy, which unfortunately also failed due to the import of the backup. As a result, however, the old, functioning system was deleted.

Since then I’ve been trying to get Roon to run.

Judging by the ability for you to to see “In the end it always says that the restore was successful”, Roon is actually running. You can also check the Roon Server app on your NAS where the status for the software should be displayed (feel free to post a screenshot of that window here as well).

I posted already last week (including screenshots), unfortunately there was no response. So I tried by myself…

Roon 1.8 and Roon 2.0 on QNAP




Roon Core Machine


Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Last week there were “compatibility issues” with the server update when updating. Since nothing worked, I went back to 1.8. To do this, however, I had to uninstall the server, including data.

After connecting I can either log in or start a trial. When trying to log in, I get the message that I’m already logged in.

So the only option available is restoring from a backup. After the restoration, a relaunch had to be made.

And the system was reset to zero because obviously no connection to the server could be established.

After several unsuccessful attempts, I returned to version 2, which suddenly installed without any problems (without any compatibility problems).

A database update was required for the new version, which was also carried out. But after that it was exactly the same situation: Restore from a Backup. Afterwards the relaunch and everything is back to zero because no connection to the server could be established.

Any idea how do I get out of this loop?

Which doesn’t answer much. Judging by that, most part of that post and the screenshots were taken before “I returned to version 2, which suddenly installed without any problems”. Note: Make sure that the client version matches the version of the server (both 1.8 or both 2.0). It also doesn’t contain a screenshot from the window of the Roon Server app on your NAS.

And what does that mean now exactly?

Then de-authorize whatever logged in Core/machine is displayed or show a screenshot of that message too.

Sorry, I tend to “jump”.

After getting stuck with the legacy version, I upgraded to 2.0 (which was now available).
The problem was the same, so I didn’t update the screenshots.

When I open the client I have to choose my Roon Core whichever is found.

The next window is the login screen. Here I can choose the option of backup.

After the update is complete, a reboot is required. Here comes (after resetting the NAS) the message that the client is waiting for the Roon Core.
Screenshot 2022-10-07 172258

Screenshot 2022-10-07 172102

After this restart, “Connection failed” appears

And I’m definitely in the right network with the right IP range.
When I reconnect, I’m back to square one with no backup in place.

After going wired, resetting the NAS, trying different routers, changing network cards…

The NAS works, I can see the traffic during the backup and also the network traffic. What I can’t verify is if the core actually has a connection the whole time.

You have more than one?

Why, if all Roon asks for is for you to login? PS: There should be the option to restore a backup, not create one (just for clarification).

What update? You wrote that you already updated to Roon 2.0. Why restarting the NAS at all?

Again a restart. Restart of what? Why?

So why does your screenshot read 1.8 then?


Nothing you have written so far makes much sense.

So in general:
Do not restore a backup if it is not needed. Follow the directions given by the Roon software (login to your account when asked to for example). De-authorize devices if you have to, to get your new Core installation authorized (very likely you have to do that at some point). Make sure you use the same version of client as the server is at.

Why do I need a backup?

After the failed update attempt to 2.0 I had to go to the Legacy 1.8. In order to do this, the old Roon Core had to be removed from the NAS and unfortunately the data too. Due to the missing database, Roon stopped working afterwards.

So I need a backup to have a working Roon again.

I follow the software. Why the login option appears is puzzling, because when you try to log in it only says that you are already logged in. You can also log out and log in with another core.

However, I only have one core, so I only have the option to import a backup and that doesn’t work.

I have tried everything I can do as a user. Now that I’ve run out of ideas, hence I turned to the forum again.

Core and client are both up to date with 2.0 build 1128.

It looks like I have to wait for the next update or the one after that and can only hope that it will solve my problem.

This is not true. If you install Roon new, you get a new empty database. There is no Roon stopped working because of a missing database.
Sure if you want your old data back, you need to restore a backup at some point.

So what now? “another core” implies that you have more than one – or do you mean de-authorize a registered Core? Note: I already told you that you likely have to do that.

Not true, you just described the other option that is there. If you already restored a backup, restoring a (the same) backup over and over again doesn’t do anything for you.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.