Roon 2.0 not ready for prime time?

Roon Core Machine

Macbook Pro Mid 2012 running OS Catalina 10.15.7
8GB memory 500GB SSD

Networking Gear & Setup Details

Fiber optic internet 1GB down and 200MB upload
Ethernet to core/ Orbi mesh router to endpoints, including NAD C658, iPad, iFi Audio Hip Dac 2, Chromecast Audio (typically running only one zone). Tried various zones, including internal speakers (Ethernet connected) for testing- results were same with all endpoints.

Connected Audio Devices

See above.
Remotes, including iPhone 13 and iPad Air 2 had Roon Remote 2.0 installed. ARC installed on iPhone 13.

Number of Tracks in Library

3136 tracks on SSD

Description of Issue

After 2.0 install, Roon didn’t find any local files. After re-adding location of locals, Roon took 18 hours to add 3136 tracks and crashed once during process.

Can’t perform search function- can’t locate search error message.

Playing full album, Roon takes 30 seconds to 2 minutes to play next track, often skipping after playing partial track.

In Radio (either Artist or single track seed) queue will “spin” between" several" tracks before eventually stopping on a track after previous track completed, but again, resuming play after an extended period of silence- or simply quitting altogether.

ARC does not function at all, with error message “poor connection”, regardless of signal strength.

Reinstalled 2.0 four (4) times- including after deleting the program. Rebooted Roon, MBP, router, and end points several times during testing with no improvement.

Per Activity Monitor: With Roon 2.0- Roon was 130-150% CPU and an average of 35% system. With Roon 1.8- CPU was 15-30% and an average system of 8%.

Finally, moved back to Roon 1.8 and the program is working flawlessly, as before.

Something (or several things) is amiss- leaving Roon unusable with 2.0 installed.

Would like to utilize 2.0, but simply can’t at this point in time. Are these issues being worked on and resolved before legacy 1.8 is no longer being supported (12/2022)?

I’m sorry to hear that you are having problems and I wish I had a simple solution that would solve your issues. However, I think that you should take heart from the fact that once it works, it works well.

I am running my core on a stripped down Mac Mini (late 2012) which has an Ethernet connection to the router, with a selection of end points around the apartment connected by Wi-Fi.

Your title is a tad sweeping

My library is 130k tracks .

I recently added 1 tb of other albums to my library, other than the analysis phase which we know takes time, the albums appeared almost immediately as the copy process completed the file.

I would look to your implementation before sweepingly condeming the software

Just saying

I supect logs to @support would be a good start

The title was with a question mark. Therefore, not meant as “condemnation”, but a query based upon my experience.
As far as implementation goes, the only variable I am aware of is version 2.0 vs. version 1.8.
I welcome any constructive suggestions and @support assistance.

My first look would be at the Roon db , with so few tracks rebuilding should be quick.

All of what you describes sounds like nothing is working so the db being central to all is a likely candidate.

I am not Mac, but find the Roon folder and rename the datase folder to _old then restart Roon it will create a fresh db . If no joy simply delete the new one and rename the old one back

Suggestion much appreciated. A couple questions- as 1.8 is working perfectly there appears no issue with db within that folder, right?
Therefore, is it your suggestion I move again to 2.0, and rename the db there to _old then restart to create the new db?
Happy to try, just asking for clarification. Thanks again.

Is your OS Catalina? Is Catalina native to a 2012 machine or has a patch been used to get it on the device? There are a few here who have employed that method and report 2.0 working well so maybe they could offer advice.

Thanks Henry- Catalina 10.15.7 running on the machine. I updated to that OS prior to 2.0 install. The update was via Apple web site. According to what I could find (again via Apple), that OS is the latest that will run on the Mid 2012 Macbook Pro I have. If there is a trick/patch or other thing that needs to be added before 2.0 works properly, I would welcome hearing about it.
Again, Roon 1.8 works perfectly on the MBP running Catalina 10.15.7.

Tried the renaming of the Roon Database/ restarting- no difference. Looks like Roon 2.0 is not an option for me at this time…
Although they are no doubt very busy, it would be nice to hear from @support.

More testing done pending support intervention:

Maybe it’s your MacBook Pro (older, not enough memory, corrupted OS etc): Nope. Installed 2.0 on 2019 MBP with 16 gig and running Monterey 12.6. Although loading of iTunes took just a fraction of the time compared to the 2012 MBP- Roon Radio queue spins exactly the same as the older machine. In fact, after a reboot, queue immediately added 375 unrelated tracks, mostly full albums. Rebooted again and the spinning queue continued, even skipping after partial tracks and repeating tracks in Radio.

Maybe it’s your modem, router, internet speed…: Again - Nope. After experiencing above with direct Ethernet connection- connection was made via Hotspot from iPhone 13 (107mb down/10 mb up)- thereby bypassing modem and router. Same issues as above and with 2012 MBP- just slower transition to next song- 30 seconds or more.

Any help would be appreciated. I know, I know- First World Problems here. And finally- as a reminder, Roon 1.8 working great.

Is there a difference between M1 native Roon and the Intel stuff? A different download file?

Can’t answer your question. Neither of my machines use M1 processor.
I downloaded links for both 1.8 and 2.0 entitled: MacOS All-in-one / MacOS Remote.

Required Roon remote apps were installed as instructed prior to download/installation on core MacBook Pro.

The ‘all in one’ probably answers it. A single file that can work with Intel or M1 hardware but should behave differently for each?

Downloaded latest version of 2.0. Same issues as before. Have heard nothing from @support and it’s been 2 weeks. I believe I’ve been patient waiting for help- this is disappointing.

Hi @crummwoody,

Please accept our patience for the delay. I understand you’ve been waiting some time for a staff response; we’ve been working through the uptick in the queue since the release, but there’s no excuse for having pushed you to the point of frustration.

If your patience will allow for some more troubleshooting, please first try the following steps to refresh the database:

  • If you don’t have one already, make sure you’ve Created a Backup of your current Roon database
  • Exit out of Roon 1.8 and uninstall Roon
  • Navigate to your Roon’s Database Location
  • Find the folders titled “Roon” and “RAATServer”
  • Rename “Roon” to “Roon_old” and “RAATServer” to “RAATServer_old”
  • Reinstall Roon 2.0 from our Downloads Page

Diagnostics indicate there are errors mounting your internal storage location - in particular, .xml content isn’t mapped properly, according to the logs. Refreshing the database with the steps above will eliminate any mapped filepaths that were carrying over to Roon 2.0 and throwing this error.

Please share a screenshot of your Watched Folder settings by clicking on the three dots and selecting “Edit” next to your local storage location in Roon → Settings → Storage. Also verify that you have no illegal characters in any .xml file names, as these are generating the error. The team will investigate why it’s causing UI hangs and crashes (that obviously shouldn’t happen with an illegal playlist name).

We’ll be standing by for your response. The team will continue to investigate logs in the meantime, so please keep your Roon Core online for the next several hours, if possible.

Followed instructions- 2.0 seems to be working at this point.
Roon ARC does not work off of home wireless “poor connection” error message.emphasized text.


1 Like

Great to hear, @crummwoody.

It looks like port forwarding didn’t automatically configure with your Orbi network; we’ll need to enable port forwarding for cellular data use of ARC.

The port forwarding error diagnostic you shared suggests that the router can see NAT-PMP enabled, but there’s an issue with the Core reaching the broader internet. Not to worry - this is a simple and (usually) easily resolvable issue, likely arising from some settings in the Orbi router.

A few things to check from here to enable port forwarding:

  1. Do you have a modem/router in your setup in addition to the Orbi router? Usually, the error you’ve reported is due to a second routing providing redundant network address translation (NAT), which prevents Roon from reading your routable IP address accurately.
  2. If you have only one router in your setup, please see this post: ARC Not Connecting (ORBI Mesh). I recommend you try enabling Bridge mode on the Orbi router web administration page.
  3. If you above steps don’t work, please let us know your internet service provider. We want to rule out that there is carrier-grade NAT at the level of the ISP blocking the port, as this might require you to contact them and request some settings changes to your account.

We have a list of solutions for known issues with routers, ISPs, and other difficulties encountered by ARC users in the support section here:

We’ll proceed from there and the team will be watching for your response.

1 Like

Shortly after your latest response the ARC started to work. This Ready status was confirmed in settings, both on the core machine and ARC app on the iPhone 13. Tested a few times last evening and this morning with same results (including outside of range of wifi). Weird, right?
Did you or your team see anything that changed in diagnostics? I made no changes to the router setup, nor did I reboot the core.

1 Like

Hi @crummwoody,

Glad to hear that it’s running and on-the-go playback is working now. Were you hardwired to the router still via ethernet when the automatic configuration began to work? If not, it’s possible that settings just had to refresh the Orbi mesh system. It’s not uncommon for UPnP to fail initially and then succeed, and mesh networks in particular are finicky with port forwarding when the local server is on WiFi.

In any case, it sounds like you have sufficient upstream internet speed and mobile connection to use ARC on the go without issue. We’ll keep this support request open for a few weeks just in case other issues pop up. Thank you again for your patience!

This topic was automatically closed after 9 days. New replies are no longer allowed.