Roon 2.0 not supported on my tablet

Ooh this looks good, Roon on the move!

Checked that UPnP was enabled on the router, installed the app on my phone - “Your Core isn’t configured for outside of your network” - Oh dear, sounds serious, no idea what I might need to do to my ROCK core to make it work. Same for Android Tablet remote.

Oh well, at least I can install 2.0 on my other endpoints.

Windows tablet - “Your device is not compatible with Roon 2.0, learn more here” This is ‘here’
{"{“statusCode”:404,“error”:“Not Found”,“message”:“Not Found”

Great, ARC doesn’t work, my dedicated and most used remote is now useless and they can’t even get a link to a URL to function.

You expected the Roon app to forward a port for you? Yikes


Try a manual port forward UPnP doesn’t work everytime on every router. Check the faq on it.

1 Like

Could it be you are “the Amateur.” As for now it works like a charm. Just open portno. 33295 on your router and allow traffic to your Roon Core. Best Practice is to give your Roon Core a fixed IP-address. After that you’re good to go… :wink:


Mine works flawlessly. I didn’t have to do a thing to Core or the network. Even works in my car. Nice!

This is a good point, what about those of us who CAN’T open a port on our routers because our routers aren’t ours, they belong to our ISP and they won’t let us in? I’ve recently install fast fibre and my router now is inaccessible to me, if I want to make a change I need to call the helpline and they do it remotely.

…port forwarding, fixed IP address - do I have to be a network geek to use Roon now?


Won’t be a problem for you because you’re ignoring the update according to an earlier post. If you signed up to having no control over your home network you might want to review your own priorities rather than blame Roon.


Port forwarding should be able on your router. Almost all ISP’s allow endusers to forward ports. You have problably a user account to log into your router. And if not consult your ISP, And for giving your core a fixed IPaddress. Just browse to your core. You can arrange this there,. After that’s done call you ISP.


Nope, no access at all… I’m fine with that, I’m not into that stuff and don’t want to have to be.

Edit; Oh unless I do that on the wifi router? I can’t access the ISP router but that doesn’t deal with wireless I have my own mesh set-up for that.

1 Like

For giving your core a fixed IPaddress. Just browse to your core. http:// You can arrange this there,. After that’s done call you ISP. Ask them to allow traffic from any outside to your core with the fixed ipaddress just assigned.
All clear.?

Only on the router that also does ip-assigning (DHCP server) the forwarding should be made possible,
All clear?

Is the isp one a router or just a modem? If you have two routers on the network then you have a double NAT and that won’t work for ARC without fiddling. You can’t blame Roon for your choice of device that can’t be changed without your isp.

Yes I do have a double NAT (when they put their router into bridge mode it screwed up completely!) … solved that by plugging all the Roon bits into the wifi router via a switch so they are all on the same subnet.

Read the multiple postings Roon put up to explain all this.

No, just don’t use Roon ARC. It was free.

I just updated on Australia’s Telstra FTTC the crappiest internet in the world… went to ARC setting in my MBP core (Roon Server) on wifi…Dont ask but its working OK…and it did the uPNP port thing I assume as its all working perfectly.


Hey @Nick_Walker. Sorry to hear that you ran into difficulties. In checking your system diagnostics, it looks like you may have missed some important details in the release notes.

We’ve also added resources to our Help Center to help with all this stuff.

Your tablet doesn’t appear to be either 64bit or Windows 10, with that it’s not going to work with Roon 2.0. Your other devices seem to have updated just fine. Success with 5 out of your 6 devices seems a good start to me.

If you feel otherwise, sticking with 1.8 might be the way to go. :+1:t2:


Disclaimer: I am the LAST person in the world to take advice on Routerology from. That said, Throw it into Bridge Mode and relaunch the mothership!!

What an exercise in frustation! Urg. I’m running a Late 2012 Mac Mini with Catalina Mac OS 10.15
After installing Roon 2.0, could not figure out how to configure the UPnP function of my AT&T Wireless Router/Gateway. In fact, I don’t think it’s even possible for me to access UPnP functionality on my AT&T Wifi Router/Gateway. Alternatively, I should be able to configure version 2.0 so that I DON’T need UPnP for remote access, because quite honestly, I have zero interest in accessing my Roon library remotely. That’s what Qobuz is for. Ultimately, could not get Roon 2.0 to see my endpoint in my system at home, regardless of what I did. Spent two hours in futility only to end up completely exasperated. Went back to 1.8 and I can actually listen to music now. Hey Roon Labs, I should not have to be a LAN Engineer to get 2.0 to work. What an unmitigated disaster, good lord. No thank you. :grimacing:


I have AT&T U-Verse with a Pace router and it does not do UPnP. I had to figure out how to go into the router Firewall settings and input pinhole settings for my Nucleus. For you, that’s moot if you don’t want to use Roon ARC.

However, I don’t know any reason Roon 2.0 would not work perfectly well for you. It’s almost identical to Roon 1.8 except for the ability to use Roon ARC and a much better package for Mac computers.

1 Like

Hey Jim,
Yep, I have that Pace router also. Regardless I couldn’t get it to work with my Mac Mini running Catalina, no matter what I did. It would not see my endpoint nor the attached volume with music. Also, I find the rationale for and the actual installation protocol set to be very confusing. Why do I need to install the iOS version of the app first when…I NEVER use the iOS version of the Roon app? What does that have to do with the Roon Core? I always use my Macbook Pro for remote access. My view is Roon should provide a protocol to set up 2.0 without Roon ARC. This should be as seamless as installing Audirvana, and it’s not.

I appreciate your taking the time to reply, so thank you for your reply.

1 Like