Roon 2.0 Sonos stop playing after few seconds [Roon Investigating]

Roon Core Machine

Ubuntu Server 22.04.1 LTS
Roon 2.0

Networking Gear & Setup Details

Core with hardwired ethernet

Connected Audio Devices

Different Sonos devices

Description of Issue

Music to all of my Sonos devices stop after few seconds.
Naim NDX2 zone works without these problems.
With Roon 1.8 I don’t have these issues.
The Remote App show show following error ar the bottom.
I can start via play button again and the music play one more 4-5 sec cycle.

Reboot my core and firewall disable didn’t resolve the problem.

I reboot all devices, roon core and sonos with no result :frowning:

But I disabled the ufw firewall and I must correct myself.
Without firewall the sonos devices play music.

I searched the hole www and didn’t find the necessary port config for roon > sonos communication.

I added all ports from the sonos documentation and all ports I found from roon documentation:

[code]
To Action From


22/tcp ALLOW IN Anywhere
22 ALLOW IN Anywhere
2222 ALLOW IN Anywhere
40229/tcp ALLOW IN Anywhere # roonarc
9003/udp ALLOW IN Anywhere # roon
9330:9339/tcp ALLOW IN Anywhere # roon
8008:8009/tcp ALLOW IN Anywhere # roon
30000:30010/tcp ALLOW IN Anywhere # roon
1194/udp ALLOW IN Anywhere # roon
135/tcp ALLOW IN 192.168.178.0/24
139/tcp ALLOW IN 192.168.178.0/24
445/tcp ALLOW IN 192.168.178.0/24
137/udp ALLOW IN 192.168.178.0/24
138/udp ALLOW IN 192.168.178.0/24
9003/udp (Roon) ALLOW IN 192.168.178.0/24
9100:9200/tcp (Roon) ALLOW IN 192.168.178.0/24
1900/udp (Roon) ALLOW IN 192.168.178.0/24
9330:9339/tcp (Roon) ALLOW IN 192.168.178.0/24
30000:30010/tcp (Roon) ALLOW IN 192.168.178.0/24
32768:65535/udp (Roon) ALLOW IN 192.168.178.0/24
5353/udp (Roon) ALLOW IN 192.168.178.0/24
55000/tcp ALLOW IN Anywhere # roonarc
80/tcp ALLOW IN Anywhere # sonos
443/tcp ALLOW IN Anywhere # sonos
445/tcp ALLOW IN Anywhere # sonos
3445/tcp ALLOW IN Anywhere # sonos
1400/tcp ALLOW IN Anywhere # sonos
3400/tcp ALLOW IN Anywhere # sonos
3401/tcp ALLOW IN Anywhere # sonos
3500/tcp ALLOW IN Anywhere # sonos
136:139/udp ALLOW IN Anywhere # sonos
1900:1901/udp ALLOW IN Anywhere # sonos
2869/udp ALLOW IN Anywhere # sonos
10243/udp ALLOW IN Anywhere # sonos
10280:10284/udp ALLOW IN Anywhere # sonos
6969/udp ALLOW IN Anywhere # sonos
4070/tcp ALLOW IN Anywhere # sonos
4444/tcp ALLOW IN Anywhere # sonos
5353/udp ALLOW IN Anywhere # sonos
880/tcp ALLOW IN Anywhere # sonos
[\code]

Please let me know the missing config to enable my ufw.

No other user with this problem?

Dear Roon Support,
please help me and let me know the ports wich used by roon to play music to my sonos devices.

Did you check the ufw log? That will tell you exactly which ports/IPs are being blocked.

Yes I did.
After stop, there are always different ports.
I manually add port by port from the log to the rules - with no result.
I also searched the roon community forum and didn’t find the necessary ports / ports used by roon.
Tried also the ports from sonos documentation.

Daniel

For example

Sep 30 10:15:02 ubuntuserver kernel: [ 917.467559] [UFW BLOCK] IN=eno1 OUT= MAC=xyz SRC=192.168.178.191 DST=192.168.178.11 LEN=478 TOS=0x00 PREC=0x00 TTL=64 ID=0 DF PROTO=UDP SPT=55467 DPT=45708 LEN=458
Sep 30 10:15:23 ubuntuserver kernel: [ 937.638171] [UFW BLOCK] IN=eno1 OUT= MAC=xyz SRC=192.168.178.144 DST=192.168.178.11 LEN=370 TOS=0x00 PREC=0x00 TTL=64 ID=17872 DF PROTO=UDP SPT=5353 DPT=50313 LEN=350
Sep 30 10:15:53 ubuntuserver kernel: [ 967.634606] [UFW BLOCK] IN=eno1 OUT= MAC=xyz SRC=192.168.178.144 DST=192.168.178.11 LEN=370 TOS=0x00 PREC=0x00 TTL=64 ID=19538 DF PROTO=UDP SPT=5353 DPT=50313 LEN=350
Sep 30 10:16:02 ubuntuserver kernel: [ 977.505214] [UFW BLOCK] IN=eno1 OUT= MAC=xyz SRC=192.168.178.1 DST=192.168.178.11 LEN=333 TOS=0x00 PREC=0x00 TTL=64 ID=27425 DF PROTO=UDP SPT=1900 DPT=45708 LEN=313
Sep 30 10:16:23 ubuntuserver kernel: [ 997.639261] [UFW BLOCK] IN=eno1 OUT= MAC=xyz SRC=192.168.178.144 DST=192.168.178.11 LEN=370 TOS=0x00 PREC=0x00 TTL=64 ID=21237 DF PROTO=UDP SPT=5353 DPT=50313 LEN=350
Sep 30 10:16:47 ubuntuserver kernel: [ 1022.040352] [UFW BLOCK] IN=eno1 OUT= MAC=xyz

sudo ufw allow 5353/udo comment sonos
sudo ufw allow 50313/udp comment sonos

is this correct?

If it was a firewall issue it’s more likely you wouldn’t be able to start playing audio rather than stopping after a few seconds.

But with disabled firewall the music didn’t stop

If you need to see what ports are used, disable the firewall and then run a packet capture (tcpdump) on the core. Open that in wireshark and you can see which ports are being opened to the sonos endpoints.

then use those for the rules.

If there are too many ports involved, just specify IPs and protocol.

I don’t have enough context to answer that.

What devices are 192.168.178.1/144/191 (I’m assuming .11 is your ubuntu core?).

Plus, 5353 only shows up as a source port while 50313 only shows up as a destination port but your syntax appears to be the same for both (directionality matters). It would help to see your exact syntax when entering these rules. Also, what about port 45708?

Hi,
thanks for your help.
Please note: I am not a linux professional.

roon (ubuntu) core ip is: 192.168.178.11
router ip is: 192.168.178.1
sonos devices: 192.168.178.191/192/193

Ok, so try something like:

sudo ufw allow proto udp from 192.168.178.191 to any port 50313
sudo ufw allow proto udp from 192.168.178.192 to any port 50313
sudo ufw allow proto udp from 192.168.178.193 to any port 50313

If 50313 changes you will have to update those rules with a range. If it continues to change or the range is all over the place then don’t define any ports.

Is 192.168.178.144 not a Sonos device? It is clearly trying to hit the same port (50313) on your Core as .191.

port 50313 is more than likely the random high ephemeral port used as the source port.

192.168.178.144 is my Naim NDX2 streamer

I know the list from sonos an added rules for all ports from the list…

Then the OP can adjust the rules accordingly (define a source port (5353) instead of a destination port) or omit ports entirely. It all depends on how locked down the OP wants things.

I will try it again but currently I’m out for vacation