Roon 2.0 vs 1.8 Legacy vs 1.8 ... avoiding being bricked

Roon Core Machine

Mac mini server 2011 running High Sierra
Controllers - iPhones, iPads, MacBooks. Mac minis etc.

Connected Audio Devices


Description of Issue

So this reminds me of when Sonos bricked all my physical controllers back in the day… I’m hoping though that this time we can solve the issue with software as I really like Roon and am a happy user for quite a few years.

So started working today and my MacBook version of Roon asked me to update, fine I thought as this usually goes smoothly.

After the update I find that the laptop is at 2.0 and the core (on my Mac mini) is 1.8 and so incompatible.

At this point I thought I should simply downgrade the Mac to 1.8 so went to which gave a 404, eventually found which I thought directed me to legacy 1.8 remote… installed this on the MacBook and now still get an incompatible error between 1.8 and 1.8 legacy.

Must have not had enough coffees but a re-read of the faq kind of indicates I can’t downgrade to 1.8 … have to upgrade everything to 1.8 legacy? I’ll get a coffee and see if this makes any more sense post caffeine. All I do know is that I wish the 2.0 upgrade screen had indicated it would brick your setup if you have an old core.

Anyone got back up and running on a Mac controller they shouldn’t have upgraded to 2.0?

I seem to be where you are. iPad updated, but Core hasn’t so I can’t see the core. A simple return to 1.8 is all we need – I don’t want to spend hours creating folders etc. Come on Roon guys!

Stuart… think we have a few options that come to mind… however, definately in your camp where don’t want to spend much time fixing something that worked yesterday.

Option 1 - buy new hardware - prefer not to do this as the old Mac mini is a trooper
Option 2 - run a vm on the macmini with a recent version of linux running a v 2.0 core
Option 3 - dig out an old MacBook and see if I can bodge v1.8 from that onto my main MacBook Pro
Option 4 - just use my iPhone and not worry about it for a while

I’ll try Option 3 later and see how we go…

Same here, incompatibility between 1.8 and 1.8 legacy. Can’t go back to my perfectly working Roon. My Synology Nas won’t upgrade to 2.0 with the message ‘incompatible’. Downgrading doesn’t work either. I am trapped, what now?

My very same experience!

Hi @Peter_Vandendriessch,

I’m sorry you’ve had these issues. We certainly didn’t want the latest and greatest version to do this to you either.

You should be able to use the page to find the 1.8 legacy installer for your NAS. In fact, the link above will take you right there. The general idea being is that there cannot be a version mismatch. If you stay on 1.8, all devices need to be 1.8 legacy. As it sits now, diagnostics show me that you’re on 2.0 across the board EXCEPT for the NAS. You can either try to install 2.0 on the NAS or downgrade all of the devices to 1.8 legacy and then convert the NAS from 1.8 to 1.8 legacy.

Hopefully, this helps. I know there’s some work ahead of you so please drop me a line if you get stuck. I will be monitoring our thread in case you do.


Hi @Jeremy_Nevill

Did any of the suggestions work for you?

Let me know.


Same here, really annoying.
I usually don’t check updates for my IOS apps in detail, so this upgrade really did me in.

Finally got round to fixing the issue.

All my IOS devices auto-updated quicker than I could stop them so I decided a downgrade of the core wasn’t worth the effort as I’d still be stuck with version mismatch from the clients.

The interim solution was run the 2.0 core on my MacBook … and the final solution was to install Parallels on the Mac mini server and create a brand new Ubuntu 20.04 VM to host the Linux version of Roon 2.0.
It appears to work (listening now) so I’m happy and can get a few years more out of the 2011 Mac mini server! :grinning:

Interestingly I tried to live without Roon for a week just using the Naim app but I missed the navigation, volume control and slick UI of Roon.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.