Roon and android phone

Hi Guys,

I gave up on the Roon Iphone app and decided to install roon on an android phone (One plus 8). when I open Roon, its not even finding the roon core. Should I chance any settings or something like that for the android phone to discover roon core?


You sure it’s on the same WiFi / Lan network as your core? I have a one plus 5 it works fine there is nothing to do to setup other than choose the core. If its not finding it then it’s network related. The android network stack can be odd with some routers or WiFi systems or some setting that does not effect iOS may effect the Android device

Hi @Roon_Superuser

In order for Roon’s @support team to better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they can have a clear understanding of how your devices are communicating.

So I was looking up some articles from 2018

And per the advice of @TerryD I put and hit scan and it worked immediately! So is it a bug thats not fixed since 2018?

The underlying issue is the network not forwarding the call for service, putting in that 255 etc just allows the Android app to do the broadcast it was trying to do anyway.

Hi @Roon_Superuser,

When the 255 address works and regular connection does not, I would suspect a multicast issue somewhere along the line. I would try enabling IGMP Proxying / IGMP Snooping on your router to see if that helps with automatic connections.

Could u explain this a little more? How do I enable it? Also why was this not an issue with the iphone and just android?

Hi @Roon_Superuser,

From what we have seen, Android is a bit more susceptible to multicast issues. IGMP Proxying/Snooping helps with this by directing the multicast traffic better, it should be an option in your router web administration page, I suggest you give it a try.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.