Roon and jriver media center

Roon Core Machine

windows 11 64 bit

Networking Gear & Setup Details


Connected Audio Devices

lumi u1 mini aes to topping D90se, pc to topping D90se via usb, pc to ps audio direct stream jr.via usd, node via arc from lg t.v. optical from p.c out to mac preamp mx 132and optical out fro. tv to mx 132

Number of Tracks in Library

oh man i dont knowi a lot lol

Description of Issue

i had to update jriver to 31 and now when selecting it from roon there is no longer any audio that can be heard

sorry if i didn’t reply in a timely manner im a newbie with terrible p.c. skills, but if there is anyone that can give me any advice on getting jriver back up and playing oon roon it would be appreciated,

I had deleted previous my post because I had not understood that the “it” that you were selecting in Roon was the jriver media center. I have no experience with that, so won’t be able to help with this, but someone else will show up, probably soon. Good luck :slight_smile:

Are you talking about playing roon through the jriver virtual soundcard driver?

thanks im sure someone will, until then ill keep tinkering with it.

i think lol lets just say before i upgraded to jriver 31 from 29 if i choose to select jriver when i was on roon it would automatically go to jriver and play the music i selected from roon ,now one thing you must know about me i like to have choices so i can try different things, its fun for
me and stops boredom issues, regards David

This may be relevant…

thanks ,nothing is working yet

Have you got the WDM Driver installed

Look in Tools>Options>General>Features and see if its checked


If its not checked , check it then restart JRMC , i must admit it’s checked on my setup and doesn’t show in Roon. I am on V 31 , it should appear in Settings>Audio> This PC

look at the post above @SKBubba , Uncheck the WDM driver , restart JRMC , go back and re-check WDM Driver then Restart JRMC again and it appears in Roon where it should :sunglasses:

that worked thank so much if i may what are your setting for jriver in roon

I don’t use the WDM driver , I have a Naim Uniti Atom HE which is Roon Ready and UPnP compliant streamer so I just use the network , the streamer sorts out the input automagically. I use 99% Roon anyway these days

For both apps I use minimal changes just Volume Levelling in JRMC , not even that in Roon

I am pretty much 100% Headphones

well guess what it stopped again, i will try checking and unchecking the box and i need to say that when useing it before the system would totally switch over to jriver now it shows that its play from jriver while still in roon, hope that makes since for you

thanks yes that worked but it reverted back so ill do that again jriver is glitchy but dang it does sound great when you rip your c.d.,s in 512 DSD

Maybe post on the JRiver forum if WDM isn’t staying checked

ok mike thanks

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.