Roon and Node 2i not playing well together

I am a new Roon user who has been trying it out for the last 2 weeks. Before I explain the issues I am facing, I want to say that Roon is a concept / product that has most revolutionized my music experience since Sonos came out over 15 years ago.

Sonos revolutionized how I could access all my music and play it anywhere from my phone. Roon has taken it to a totally different level wherein it has allowed me to engage with music and discover music based on my tastes like no other service can do.

I am impressed and delighted by Roon, would like to make it work, and have there fore spent quite some time on it.
I have also read all the prior posts on this topic and believe this needs attention.


I have 12 Sonos products (bundled into 7 zones), one node 2i, one MacBook (using bridge) as the end points and the only place where this issue occurs is with node 2i. This happens every time I use node end point with roon while it doesn’t happen with any other end point. At the same time, Node works perfectly without roon. I would like to make them work together as that is the way to get hassle-free high res streaming which Sonos doesn’t provide.

Issue Details:

The music starts very slowly (takes several seconds to start), or straight away gives a message that Qobuz (or my library) is taking too long to load. It moves to another song and the same thing happens. It happens with Qobuz, Tidal, my library on Synology NAS, with high res and with CD quality source.

When reloading the same song, Node 2i itself disappears for some time and then comes back but shows the same slow loading issue again.

There is no time of day or internet usage patterns, that correlate with this issue. And at the same time, if I use BlueOS iOS app to load the same music in the same place, it works perfectly.

I will describe in great detail all the steps I have taken to fix this issue, to no avail.


My current setup is as follows:


Core is roon running on Rock on a NUC (i7 machine). SSD is 128 GB. RAM 8GB.


Music source is Qobuz and Synology NAS.

Both the core and the NAS are hard wired to the network.


I have a Google Wifi router with 3 additional mesh points providing a stable and strong network to a large home in a very large lot; external network traffic from neighbors’ networks do not cause any interference.

Also want to add that there are over 50 network devices connected to this network which shows a stable 50-100 M download and 15-35M upload speed across the entire house.

Audio devices:


Instead of detailing ever audio device, I want to highlight just three of them.

Zone 1: Peach Tree Nova 150 as the DAC/Amp connected with

Zone 1A: MacBook Pro (i5) using only a bridge and nothing else running directly connected with Nova 150. Using Wifi.

Zone 1B: A Sonos Connect connected with the same peachtree. Sonos devices are using Sonosnet as one of the Sonos zones is wired to the router directly.

Zone 2: Node 2i using wifi connected to a Harman Amp. No subs or interfering devices in the same location. This location gets constant 75 / 100 mb upload 30 M download speeds.

Zone 3: Reflects all other Sonos zones including Connects, Amps, Play devices, Move and so on. As this doesn’t have any issue, I am combining all of these zones as one.


Initially I thought it could be wifi, Qobuz, core using wifi rathe than ethernet, so I did the following:

  1. Moved from Roon Core on Mac using wifi to a wired ethernet connection. Didn’t help.
  2. Moved from roon on Mac to roon on Rock on a Nuc (i7) wired to ethernet. This really made access to the app from various controllers very quick - almost instantaenous. But Not help on node end point.
  3. Added one extra Google mesh point to the network in Zone 2. No difference.
  4. Combined two Sonosnets into a single network so that there aren’t too many mesh networks in the house. No difference to node end point performance.
  5. Tested the system at various times of the day (and night) to control for all other network traffic. No pattern emerged.
  6. Stopped Tidal and logged out from it to keep Qobuz as the only streaming service. Not change to Node issue.
  7. Moved the node to different locations to rule our all issues as below:


At no point does Zone 3 (any end points in it) ever have a problem playing Qobuz with Sonos end points. No time of the day, no matter what else is streaming on various TVs, Music systems or anyting.

Zone 1b (connect) has no issue ever playing music from roon. Zone 1a (i5 MacBook using bridge) has shown some drop-offs but very rare. It may have happened once or twice in the entire time I have used. This is the location that serves as my office so I use the system throughout the day there. Since I started keeping a log of when this issue happens I noticed that in an 8-9 hour streaming session, this happened only twice yesterday. At that time, there was an issue with the Wifi as the wifi in the main computer became unresponsive. I suspect an interference may had led to it. This is not an issue in my opinion.

Since the issue is with Zone 2 (Node), I took the Node 2i from Zone 2 to Zone 1 and connected it to peachtree and noticed the same issue there. That’s how I zeroed in on Node 2i working with Roon as the core issue.

Summary : So Node 2i works perfectly with Qobuz and my NAS when not using roon but drops off regularly (is unreliable and unusable) with roon. Every other end point words flawlessly.


I checked into the Node 2i logs and noticed the following errors when this happened:

Jul 8 16:33:29 (none) user.warn RAAT: dropout of 242 samples at 144958 2

Obviously the node log files is very long so I am just putting a relevant line here.

The picture of screen shot from controller at that time:

Roon log
I also checked the Roon log files to see what is happening there and found the following which I think is relevant here. Its a 8.5 mb file which I can send to roon support if someone reaches out to me. It seems the trace program is already sending the needed data to roon servers so this may not be needed.

The times stamps are not the same but the issue should be visible here.

– SignalPath ---------------------------------------------

SignalPath Quality = Lossless


Source Format=Flac 192000/24/2 Quality=Lossless

Raat Device=Bluesound NODE 2i

Output OutputType=Local Analog Digital Quality=Lossless SubType= Model=

07/07 23:34:14 Trace: Bluesound NODE 2i @ GOT 112 “message”:{“signal path":{“method”:"analog digital”,“quality”:“lossless”,“type”:“output”]},“status”:“OutputMessage”}

07/07 23:34:14 Trace: Bluesound NODE 2i @ raatclient GOT 112"audio port":0,"audio port tcp":46033,"clock port":35961,“status”:“Success”

07/07 23:34:14 Trace: Living Room zoneplayer/raat Endpoint Bluesound NODE 2i State Changed: Idle => Prepared

07/07 23:34:14 Trace: Living Room zoneplayer/raat synced to endpoint Bluesound NODE 2i clock: realtime=582076593 rtt=3000us offset=-115362923us delta=-115362923us

07/07 23:34:14 Trace: Bluesound NODE 2i @ raatclient SENT 114"request":“stream”,“stream id":907408749,"first seq”:-1,“nak port":-1,"buffer size”:10,"ready threshold":0.2

07/07 23:34:14 Trace: Bluesound NODE 2i @ raatclient GOT 114 “status”:“Buffering”

07/07 23:34:14 Trace: Living Room zoneplayer/raat Endpoint Bluesound NODE 2i State Changed: Prepared => Buffering

07/07 23:34:14 Trace: Living Room zoneplayer/raatzoneplayer/raat selected Bluesound NODE 2i as clock master

07/07 23:34:14 Debug: raat/tcpaudiosource connecting to

07/07 23:34:14 Debug: raat/tcpaudiosource connected

07/07 23:34:14 Warn: raat/tcpaudiosource send failed: The socket has been shut down

07/07 23:34:14 Warn: raat/tcpaudiosource disconnecting + retrying

07/07 23:34:14 Debug: raat/tcpaudiosource disconnecting

07/07 23:34:14 Debug: raat/tcpaudiosource connecting to

07/07 23:34:14 Debug: raat/tcpaudiosource connected

07/07 23:34:14 Warn: raat/tcpaudiosource send failed: The socket has been shut down

07/07 23:34:14 Warn: raat/tcpaudiosource disconnecting + retrying

07/07 23:34:14 Debug: raat/tcpaudiosource disconnecting

07/07 23:34:24 Warn: Living Room zoneplayer/raat Endpoint failed to become ready in 10s. Proceeding in state Buffering


My conclusion here is that something between roon and Node 2i is not working and it is related to how RAAT works.

The Node has latest firmware and so does roon.

To conclude, I think Roon is so awesome that I spent this much figuring out what is going on which I have not done for any other product. And that shows how much I would like this to work for me.

I would be happy to send the log files if you email me.

It’s quite a long post so apologies if i missed this. Is the 2i connected via wire or wireless?

Hi @Ankush_Chopra,

Welcome to the forum and thanks for reaching out!
Glad to hear that you’re enjoying Roon except for this issue.

Is the behavior the same if you connect the Node 2i via Ethernet instead of WiFi?
There’s a known issue with WiFi on 2i devices that we’re working with Bluesound to investigate:

Hi Ged,
Node is on wifi not wired.

Hi Norris

Thanks for getting back.
Core and NAS are wired but Node and all end points are wireless. I have not tried with ethernet connection to Node as that is not feasible solution for me.

Since the Google Wifi is pretty strong and reliable, everything works well on wifi (including 4K video streaming and wifi portable Sonos end points even in the pool area which is almost 150 feet away from the nearest wifi point). I had earlier (before roon) tried range extenders and power line solutions but google works better. It provides stable 90/35 connection in the room where Node is.

The reason I have not tried Node with ethernet is that even if it works, it is of no use to me as there is no way for me to add ethernet points anywhere in my house except in the central location where there is a wired connection.

So either node 2i works as a wifi end point for roon or I need to find alternate solution like CXN etc.

If the issue with wifi on Node 2i is a known issue and a solution is underway, I can wait for sure. Good to know that a solution would be available soon.

thanks again for a prompt response.

1 Like

Hi @Ankush_Chopra,

Are you unable to connect it to one of the Google WiFi nodes?
Do the ones you have not have an Ethernet out option?

We’re looking into it, but development takes time, so it would be hard to say when the changes + QA testing will be complete. I suggest that you at least have the Node 2i conneted via Ethernet in the interim.

I don’t have a way to use Node with an ethernet point. My google points have no ethernet capacity; and the room with ethernet point has a Sonos bundle acting as a home theater. Putting Node there will not work as Node is meant for the room where I need a DAC and a streamer in a compact form.

This leaves me with an orphan Node in an otherwise well functioning roon home. I wish I had know about this issue - would have picked up a CXN or something that works. I am glad I only bought one BlueOS Node 2i - wanted to try one before buying more of them.

I will just wait for the Node solution before doing anything at all - and I totally get that it takes time to fix / QA some of these issues. Will use Node without roon until that comes.

Thanks again.

1 Like

Hi Norris

After sending the previous message it occurred to me that I have older mesh network points (open mesh) that I replaced with Google Wifi. They have wired network capability in mesh points but a lot lower speed. Their wired speed is 25/10 vs wifi speed of 100/35 that I normally get.
So I added one of them to my router to get ethernet capability to Node 2i.

I tried playing some music and it started with a slight delay but then the Node disappeared in the middle of the song. I wasn’t looking at the roon controller so I couldn’t see what the message was. The BlusOS app itself wouldn’t work after that. So I rebooted the Node.
I tried again after rebooting the node and it seemed to have worked the next time.

Give me a few days to see if this works. This is not an ideal solution because it adds a dirty looking point and some wires in an otherwise pristine set up. It also adds an unnecessary mesh network in addition to two others (Google and Sonos) that are currently working.
But if this works, I can use it until you have a wifi solution that makes Node 2i work with Roon.

I will take a few days to see if this makeshift solution works. Even if this does work, I will be very wary of buying another Node for the time being.


1 Like

Have you tried CPL? I have been using a node 2i with Roon for months without a single issue. The Roon core is on a Mac mini connected to the network via WiFi. The node 2i is connected to the same network via Ethernet through a CPL plug. Never encountered any delay or disruption of any kind.

1 Like

Thanks for a great suggestion. You have an interesting reverse setup. I can see how it would work well. when I used Roon Core on an i5 Mac on wifi it worked pretty well except for Node which was also wifi. Also, I noticed that a wifi in and wifi out clogged up the home network at times (especially on a 192/24 Qobuz stream) and thus wired works better for the larger network to function well.

I have looked into power line networking too. Since I live in a 100 year old home, it doesn’t have the needed distortion free line from the place where I have the ethernet to where the Node 2i is. It also doesn’t have the kinds of hollow dry walls that would allow me to easily put a wired line between zones. Thats why powerline doesn’t work in this house. In fact, I am on 5th network iteration and finally got the place where everything works. With Google Wifi.

1 Like

Are you running 5 Ghz or 2.4 Ghz?

Wifi has both but Node is using 5Ghz. The distance to the router or the bandwidth are really not the issue here as the WiFi speed is very good and reliable.
Essentially, Node works flawlessly when not going though roon. Node 2i is brilliant product in my opinion with a very good sounding DAC, great app, and many good features.
If I had not bought it as a roon endpoint i would have been very happy with it as a streamer and DAC.

The issue is only when roon sends a stream to Node. It doesn’t stream, skips, mostly doesn’t play at all, eventually giving up and even losing node as an end point.

Also, I have read about issues with the Node switching between mesh points.

Daniel - this is really good to know. I will try it with 2.4GH over the weekend and let you know if it helps in any possible way at all. Will also check the wired piece and see if it helps. I did try wired ethernet but somehow the Node didn’t connect itself (didn’t get an IP address -- ). Didn’t get time to dive deeper during the week.

I have some good news on my end due to great advice from Daniel. My Node 2i is finally working flawlessly with Roon. It is indeed an amazing DAC and streamer. I was almost going to give up on Node.

The solution was to use Openmesh points to create a 2.4 wifi network (wired to the main Google Wifi) as a separate network and make the Node join it. The IP came from the main router and roon could discover it. It doesn’t drop connection or take any time to start.
So the solution for me was to find a way to get a 2.4Ghz network to make Node work.

Also, what didn’t work was using ethernet with OpenMesh. Last night I was able to get it to work but this morning Node point was gone from Roon and I had to restart the node for it to reconnect with Roon. That wasn’t a good solution. So I tested Daniel’s advice and set up the OpenMesh 2.4 Ghz network.
Also, the Google network has a speed of 120/35 while Openmesh has a speed of 15/10 as it is a few years old networking equipment. So it works with a slower speed 2.4 network.

This solves the problem for me. Didn’t think 5GHz would be the problem (as it worked perfectly without roon on 5 Ghz ) and it never even occurred to me. Hopefully, this will continue to work.

Thanks everyone for chiming in and helping me out.


Fantastic News; glad you got it sorted out. Time to relax and enjoy the music!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.