Roon and PS Audio Sprout100

Hi there,

I’m having trouble playing back music on my Sprout100 integrated amp.

My setup: Roon ROCK on Intel NUC8i7 --> router --> Allo USBridge --> Sprout100 USB input

When I try to playback music, I get no sound. The progress bar does not advance, and Roon skips to the next song in the playlist. Here is my signal path:

I have read some forum posts about trouble with the Sprout100 and maybe it being related to driver issues with the Allo USBridge, but at this point I just don’t know.


Your signal path doesn’t show the Allo. Another thread had a path in it as below.

Hello @paulie,

Are your Allo and Sprout on the newest firmware versions? Also, can you please post a screenshot of your Audio Devices Tab? It should looks something like this:


Hi Noris,

Thank you so much for your reply.

The Allo is updated:

The Sprout doesn’t have an option to update the firmware, so I’m assuming it’s OK. It was purchased recently.

Here’s my Audio Devices tab for the Sprout:

Hello @paulie,

Thanks for posting those screenshots. I’d like to perform a test here to see if this helps, can you please:

  1. Select the DSP setup for the Sprout100 zone by right-clicking the zone name in the bottom right (next to the volume controls) and then pressing DSP

  2. Turn “Headroom Management” to On

  3. Set the headroom adjustment to -1 dB

  4. Reboot your Core, Allo USBridge and Sprout100 and try to reproduce this issue

  5. Note the exact local time that you perform this test (e.g. 12:18PM) and let me know



OK, I set the DSP Headroom Management to -1dB and rebooted everything. The error still occurs–music does not play, no progress bar advancement, and skip to next track.

Test was done at 1628 local time.

Hello @paulie,

Could you try plugging the PS Audio Sprout100 into the NUC running ROCK and reporting if you’re able to get playback to work?


I also found problems. When I connected a Raspberry Pi it found it fine.

It’s almost like the USB driver in the Allo doesn’t work with the Sprout, parhaps due to the outdated kernel certainly interested to find a solution.

I flashed Volumio onto the Allo USBridge, then installed Roon Bridge. It says the Sprout100 is recognized, but the exact same problem happens: no music playback, no progress bar advancement, skip to next song:

As @john has asked, tomorrow I will connect the Allo directly to my ROCK and see if that changes anything.


OK, I’ve directly attached my Sprout100 to my ROCK via USB. As before, Roon recognizes the Sprout:

However, the same problem persists: no music playback, no progress bar advancement, but this time it cycles through the queue much faster haha

Honestly I’m surprised. I figured connecting it directly to ROCK would work. This test was done at 1758 local time.

Just in case, I rebooted ROCK, but same problem persists.

I ran 2 more tests:

Installed Sparky Linux on an old PC laying around, then Roon Bridge. Same playback issues.

Hooked the Sprout100 directly up to my MacBook Pro acting as a Roon endpoint (same ROCK), OS X 10.14.3…it works fine! I’m so confused. I’m not sure what it is about Linux, even newer kernels, and this Sprout100. I’m really hoping @john or @noris can help!

Hello @paulie,

Thanks for the extensive testing, we’re going to reach out to PS Audio and see if we can find a solution. I will keep you updated on our findings.


Interestingly, I tried things out with an RPi 3 running Ropieee…no dice. Same issues. I’m now wondering what USB controller the Sprout100 is using…

Hello @paulie,

We are seeing a few reports of USB DAC functionality not working with Linux on the PS Audio Sprout100. Here is a thread on the PS Audio community site with a similar report.

We’re engaged with PS Audio to see what can be done here. We’ll be sure to keep you updated on the process.


Does anybody have anything new to report on this issue?

Hello @Bob_Worley, @paulie, and @bevan_court,

It appears the PS Audio has found the cause of the issue and has a new firmware available to enable playback from Linux USB hosts. From what I can gather, this firmware would require you to send your unit to PS Audio for the firmware update procedure.

More information can be found here:


Thanks @john, just received mine back from PS Audio. They fixed the static on powering on and off while it was back. I will be trying the USB connection tomorrow to see if that is working as well. They were very helpful and communicative.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.