Roon and tidal errors - track not available

Core Machine (Operating system/System info/Roon build number)

Imac 3.1ghz Core I5 MacOS 10.13.6

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

route is AmpliFi Router HD [firmwear up to date] to netgear network switch with ethernet to Kef LS50w

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Kef LS 50w and Bluesound node both via ethernet connection

constantly getting message on tidal tracks - track not available too many errors
can play local library with no problems
I have tried rebooting roon, rebooting modem, rebooting computer to no effect. This occurs for whatever end point I try including the core
Have checked router and wireless speed and all else working normally.Can play tidal from tidal app on same computer
Hope someone has some ideas as I am very frustrated and currently regretting my recent upgrade to lifetime subscription

Hi @Geoff_Greig,

Does the same TIDAL content give these errors or will some content work sometimes but not others?

Does the same issue occur if you play to System Output of the Core machine?

A post was split to a new topic: Can’t play TIDAL tracks on ROCK

All tidal content MQA and standard redbook quality tracks

And yes the core machine has same issue

Hi Dylan
Answered your questions as requested - do you have any ideas as to what to do ? delete and reinstall

Hi @Geoff_Greig,

Where are you playing these tracks from? Are they all from a playlist or are you searching for the artist/track directly in Roon?

From both. Anything form tidal not working
Anything form local data base no problems. Can stream via blue sound and kef apps to end points with no problems so this is a roon problem

I can stream tidal via the native app, blue sound and Kef app but not roon

Hi @Geoff_Greig,

Can you please try logging out and back into TIDAL via the Roon Settings -> Services tab? You can click the Edit button next to TIDAL to perform the logout/login.

I would also confirm that the TIDAL web player ( works as expected from the Core PC using the same account credentials.

I have tried the logout and login to tidal to no change
Yes tidal plays fine via same computer and credentials

Hi @Geoff_Greig,

We just released Roon build 528, can you please check to see if the new version changed this behavior?

If the behavior is still the same, as for the next step I would advise clearing your TIDAL cache:

  • Exit out of Roon
  • Find and open your Roon database
  • Navigate to /Library/Roon/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting Roon and verify if the issue still occurs

I have updated to latest version of roon to no effect. I am unsure where to find the roon database on my mac - can you give me some guidance of where to look
Thanks Noris

Hi @Geoff_Greig,

As per the article I linked, you can access your Roon database location by using these instructions:

OS X Core

You can find your Roon folder (or RoonServer folder) by following these steps:

  1. Open Finder and click Go in the top bar
  2. Hold down the Option key (or Alt)(⌥) to unhide the Library folder
  3. Click the Library folder
  4. Locate the Roon folder

Once you have located the Roon folder, please move the contents of Cache else where and start the Roon app again. Does the TIDAL cache clear change anything with regard to the behavior?

Hi Noris
Have opened library folder but no roon folder exists ?
Any ideas where else to locate this

Hi @Geoff_Greig,

There should be a Roon folder in the Library folder, if you’re not seeing it do you mind sharing a screenshot of your Library folder contents?

Hi Noris please find attached screen shot

Hi @Geoff_Greig,

Thank you for the screenshot. That’s very strange, usually there’s a Roon folder there. Do you have another Library folder on this Mac? Can you also please check the Applications folder?

Hi Noris
checked for another library and can’t find one
The applications folder has no library tab or similar .
Would and uninstall and reinstall fix this and if so what is the best way to delete roon without contaminating a re-install

Hi @Geoff_Greig,

First, I would advise making a Backup of your Roon database for safe keeping.

After, can you please check to see if you are able to uninstall the Roon app by using any of these other ways and then re-install it?