Roon app constantly crashing

Roon Core Machine

NUC i5 with ROCK

Networking Gear & Setup Details

Remote: Asus AiMesh WiFi
Core: Ethernet
Endpoints: Ethernet

Connected Audio Devices

Topping E70 over USB, ropiee Xl on RPi

Number of Tracks in Library


Description of Issue

Roon app keeps crashing all the time on iPad and Samsung Galaxy tablet, especially when scrolling through the library and when unlocking the screen with the Roon App opened. Got worse with the latest software update.

A post was split to a new topic: Roon app crashing after selecting song, and then constantly crashes on restart

Hey @Martin_Albrich,

Ben here following up on your thread. Are you still running into issues with your remote devices crashing?

If so, I would suggest updating to the newest Roon build, and let me know if your problem persists. Thanks! :+1:

Hey Ben, thanks for the follow-up! Since I upgraded to an i7 NUC it has gotten a little bit better, but it still crashes at least two or three times a day. I always update all devices immediately, when a new version is available.

Hey @Martin_Albrich,

Thanks for the update! And to confirm, you only experiencing crashing on your tablet remote devices? Or, does this happen on your Macbook remote as well?

If possible, can you please fully remove Roon on both devices, power down the devices, and reinstall Roon?

It may be helpful to grab a set of manual Roon logs from one of the affected tablets. Your iPad would probably be easiest with this. Please use the directions found here under iPad, and send over a set of logs to our File Uploader? Please be sure to reproduce the issue after enabling logging. :pray:


The apps are only crashing on tablet devices. The were a couple of freezes on MacOS, but not enough to be an issue. I’ll reinstall everything (done that before, because I thought it might help) and turn on logging. Haven’t used the iPad in a while because the app, apart from crashing all the time, also empties the battery really quickly. Seems to be better on Android.

I’ll get back to you as soon as I have reproduced to problem with logging switched on.

I just uploaded a log from my iPad, crashed a few minutes after startup.

Hey @Martin_Albrich,

Thanks for sending logs over. As a next step, could you please head into your Roon Settings>Setup and clear your image cache?

If your issues continue after clearing this cache, lets refresh your RAATServer database on your core device. Steps to follow below:

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the Roon App to generate a new RAATServer folder

Let me know how things run after the above.

Hi @benjamin,

I cleared the image cache on all my devices and generated a new RAATServer, it still crashed three times in the first half hour of listening and scrolling through the library (Samsung Galaxy tablet).

I bougt the Android tablet specifically for Roon, because I hoped it might be better than the iPad. I already upgraded my core to an i7 and also upgraded my home network, both wireless and wired. Am I at the end of the road here? It’s really frustrating.

Hey @Martin_Albrich,

Thanks for letting me know. It may be helpful to grab a set of logs from the Galaxy tablet as well. Accessing these logs can be done by connecting the Android device to a computer via USB and using ADB (Android Debug Bridge).

To retrieve logs please:

  1. Install ADB from the link here (all platforms)

  2. Connect the Android device before reproducing the error

  3. Type adb shell in terminal

  4. Type logcat v (ref: Logcat command-line tool  |  Android Developers)

  5. Reproduce the problem and let terminal print logs for 3-5 more seconds

  6. Select the output from the moment the reproduction of the issue started until the very end

  7. Save and send support the logs to our File Uploader .

I realize this is a tedious ask, and so I appreciate your understanding while we continue to troubleshoot. :+1:

1 Like

Thank, I’ll try that. In the meantime: Is it possible, that it could be a networking issue? I use Asus gear and I’ve heard that those AiMesh routers can be quite difficult… Are there any specific ports that need to be open for Roon remotes to work properly? Or security measures or protocols that need to be activated or deactivated?

Hi @benjamin,

I uploaded the logs from my Android device. I hope it helps.

Hey @Martin_Albrich,

Thanks so much for your patience here. After taking this issue to the team, we have a few follow up questions for you:

  • Does this issue occur when just scrolling local content?
  • When scrolling through Qobuz playlists, does the experience get slow/laggy?
  • Can you reproduce this issue on a PC? Or, does it still only crash on your tablet devices?

At this time, your crashing does not sound like a network issue.

Hello @benjamin,

thank you really focusing in on this issue!

  • It happens whenever I scroll through the library, unimpressed by other variables. I tried to isolate the problem, I switched from Tidal to Qobuz, switched off all the streaming services, moved my local content from my NAS to a USB-drive attached to my Roon Core. I tried with the music playing with my preferred settings (about 11x processing speed with DSP and upsampling) switching off upsampling (100x) or all DSP and with no music playing. Didn’t make any difference.

  • I only use Qobuz with Roon, so I don’t really have any Qobuz-only playlists. But one thing I noticed is, that Qobuz can be really slow with loading new tracks, sometimes it even stops playing for a while in the middle of a song. (I always checked my internet connection right away) Tidal was better in this regard, but the library crashes still happened at the same rate.

  • I use my MacBook as a backup remote, since the tablets keep crashing. On MacOS it sometimes freezes or gets really slow, but the app always recovers and doesn’t crash. There were some crashes on my iPhone but way less frequently than with both the iPad and the Android tablet.

Thank you for everything and if you need more logs or need me to do some experiments, I’m ready!

Hey @Martin_Albrich,

I really appreciate your patience here! As a next step to test, can you please remove roon from your Tablet, and try downloading it from the APK manual link here:

Let me know if your issue persists while we continue to investigate your logs and core diagnostics. :+1:

Hi @benjamin,

yes, I’ll do that ASAP.

I noticed today, that it has gotten worse somehow? Now I also have frequent crashes on my iPhone, I had to songs stutter and then skip to the next song and the Android app won’t stay open for more than a minute at a time. I restarted everything, including the network and ran diagnostics on it, couldn’t find anything. The playback issue might be Qobuz and not Roon, though.

I noticed that I listen less and less because this issue is so frustrating, I hope it gets resolved…