Roon app crashing. FIXED in build 1.0.8

UPDATE: FIXED in 1.0.8

After installing and launching Roon, it imported my library and linked up to my Tidal account fine. Everything seemed to be working fine - at least once I figured out how to do what I wanted to do. The interface is confusing but fortunately I watched a video on Computer Audiophile before I installed the service. I am glad I did that.

Suddenly Roon stopped working and Apple displayed a notice “Roon Quit Unexpectedly” with a window showing what I think is a text file showing a system status snapshot. There’s a button to select “Relaunch Immediately” but it doesn’t work. When I relaunch Roon, it goes through the launch sequence which is pretty much watching a small icon. (Looks like an alien dentist.) Then the message appears again: “Roon Quit Unexpectedly”

And we were getting along so well it seemed…

Then I tried to log onto your support service and it turns out to be this community based service that is really only useful for people who use it all the time. A forum for support? Really? Please understand that I don’t want to use something whether it’s software or a service or a lawnmower that I have to log on and try to find a similar topic so I can ask a question I know has been asked many times before. Your development team may be enamored with forums but this user isn’t. After perfecting Roon, try improving this ubiquitous software used for “forums.” (Now the Romans, they knew what a forum was for. I’m only saying…)

Oh, and I had to register to use the support even though I already registered with the software. This is really confusing and unnecessary, isn’t it? (Trying to register was a circle of h***. )

So hopefully my message will reach a human and y’awl get me fixed up over here so I can use the software that shows such promise.

Will someone email me or do I check back from time to time?

So now I’m sitting here having written this and faced with a “+ New Topic” button or cancel" button.

Not a “Send” button. I’m not trying to create a Topic. I’m trying to report a problem. I don’t want to be in your “community;” I just want to use your software and have reasonable few glitches and hangups.

Hey @dbtom2, we went with forum-based support because we think it works better for all involved. We have a great, passionate community growing by the minute, and we’ve already seen evidence of others helping out newcomers with their questions, way before any of us staff members had a chance to respond.

By posting a topic in this support forum, or anywhere else, you are reporting a problem. The whole team hangs out on the forums all day long, and we’ll make sure you’re taken care of. I think this is preferable to submitting an email form to an automated email address and not being sure when you’re going to get a response, or if you’re buried in everyone else’s support requests. By employing the community, we can avoid sluggish response times, and you’ll always be talking to someone willing to help, even if they’re not part of the staff.

I’m super bummed we have you in this state though, we hate to hear that you’ve been unhappy so far and are experiencing a crash. I’m going to follow up with you via email with instructions so we can pull some more information from your machine and get you running smoothly, thanks Tom!


Thank you for your reply. Don’t be too bummed out. This customer is simply in that semi-distressed state where reality meets expectations. As an Apple user, I understand how a community of users can help and I appreciate it.

Some of us want simply to be good customers. Low maintenance. Able to figure things out on our own and look for answers. When I have a computer or software issue, my feeling is that surely someone has had this problem before and I only have to find the same remedy.

Even though I want to be low maintenance, it’s hard for me to explain why forums are daunting to me. The organizational philosophy on some forums mystifies me. When I am confronted with a forum I am always concerned about whether my search criteria will be able to find the info I’m looking for without an unreasonable amount of effort. All those topics. Threads that go on and on for pages. Is my query specific enough? Too narrow? I just want to find my info and be gone. The last thing I want to do is create another topic or another thread if a pertinent one exists. It’s about being low-maintenance and knowing there’s a knowledge base that has the answer I am looking for. I guess I shouldn’t worry about making a chaotic information source a little less chaotic. I try not to litter too. Just remember please, your best customers may not be the avid users on your forum. Your best customers are the ones who expect the correct answer to come from you, not another customer.

Far better minds than mine will come up with a forum software solution that has a innate and growing intelligence and thus be able to organize itself in a way that is meaningful to the users who may need it most because they use it least.

So thanks for taking time to acknowledge my pain. I apologize for being a curmudgeon. Music mellows me out. And my Roon was broken. There, that’s my excuse.


Roon behaved wonderfully last night. I transferred the queue that was playing to the bedroom Apple TV and fell asleep listening to Tidal’s Mad Men playlist.

This morning however, I was greeted with a “Roon Quit Unexpectedly” message at the computer screen. I rebooted the MacMini and Roon launched okay, but crashed before I had the chance to review whether the entire Tidal playlist was finished.


Had this issue too, but it’s happening on a remote pc.

It’s been a minor inconvenience so far, but one I know you do not want to happen at all.

Really enjoying the product otherwise.

I had a couple of crashes too.
Two different PCs, both Windows 8.1
Usesd as remote and server.
The remote sometimes crashes when starting the application.
The server as a player suddenly crashes during playback without any error message. It just disappears.

Is there an way I can provide you further information to find out the problem?


Hey @Matty, I’m going to follow up with you shortly to grab logs, PM incoming…

Roon still crashing. Waiting for resolution. Is there something I should be doing?

Roon open and behaved well for about an hour this morning. Then crashed (“Roon Quit Unexpectedly”)

Haven’t read of any fix to this issue.

Other than standing by, Was there something I am supposed to do?

Hi @dbtom2, I took a look at your logs and we have a fix for this issue coming in the next release, which isn’t far off. Thanks!

Thanks. That’s all I needed to know. I will await.

I was very cheered by dbtom2 initial rant as it mirrored my feelings exactly…one of the reasons that I am an unreserved apple fan-boy is their multi faceted approach to customer support…there are forums and user groups if you like that way of doing things ( Free but time consuming ) and then there is the Genius Bar if you are near a store, Applecare if you want two years worth of reassurance and even the regular phone support which is often free if its a simple request, but even the service charge is worth paying if it avoids another two hours of trying to get the printer to work ( or whatever). Sometimes I despair of the software industry practice of releasing a 90 something per cent sorted product in the hope that the community of enthusiastic beta testers will help get it completely sorted. I am certainly not suggesting that Roon did this and there will be many problems that only emerge when you launch the product into the big wide world of users, and they do seem to be assiduously trying to resolve the issues that are popping up . My dilemma is that the time clock on the free trial is ticking away, and if the issues I have , which are similar to yours, are not sorted by the end of the trial, it wont feel good to press the button on the annual subscription for a product which is very promising and well designed

@diw We take customer support very seriously, and we want to make sure everyone gets a chance to fully try out the app before making a decision.

If you’re having a crash that’s impacting your ability to fully enjoy your trial, please send me a private message right here in our forums, and I’m sure we can make it right somehow. This is our genius bar… and I’m here too :wink:

@diw – We have over 600 new users running Roon in the first week (today is 1 week since we launched!), and most are running fine. This is what we get for releasing non-web software… instead of having to support 10 browser versions, we have to support 10000 software setups.

That said, we’ll make sure you can trial the software to your satisfaction. Thanks for even sticking around so long and being patient, we know you could have passed on us completely and we appreciate that you haven’t.

Yesterday, we released a new build. It fixed a few issues, including one of these types of crashes. Have you given it a shot yet? We pinned the message to the top of the Software category so no one would miss it.

Yesterday I canceled my trial period thinking the clock would stop ticking until I got the new version Kevin promised.

This was not a good idea. Now I must buy to use. Be advised.

However, I feel confident - based upon the responsiveness of Roon Labs in keeping me updated on the fixes on the first version - that when the software will work as promised.

Roon spoiled me for a few days. Tidal via Roon ran without a glitch. I loved the new way my library opened up and felt inspired to do some hardware upgrading on my stereo system. Going back to iTunes/Bitperfect/Tidal was kind of a bummer. Like I got caught sneaking into 1st Class and sent back to coach.

Soon Roon soon.


1 Like

@dbtom2 – talking to @kevin, he’s going to get back to you with something.


I ran Roon, selected the “Update Software” from a blue box that appeared at the bottom center of my screen. As I recall, it relaunched and I assumed it had been updated.

It ran for about an hour or so. Checked out some music from a band named Drenge and had some Morrissey queued up when it crashed. Again with the “Roon Quit Unexpectedly” message box. (There’s a button to select Relaunch/re-open but it doesn’t do anything.)

Tried to run a few more times. Gets through the quote window, which are very good, but would be better if it stayed onscreen a few more seconds: the background reverses from white to black with white letters and it takes a second for this user to find the words and read them. Then after a few more seconds of that little tunnel digger icon thingy, (Rooney?) the app quits unexpectedly.

I rebooted and tried again with very little else running. Some Finder windows and the Activity Monitor. But it quit again a few more times.

There you go. Hope this helps.


Hey guys,

Up until a few moments ago Roon was running without a glitch. However, it just “Roon Quit Unexpectedly” moments after I authorized the Developer Tools Request. It had been running fine until then. The prompt for the tools came up, I gave it my admin password and Roon quit immediately. Unable to restart Roon at this point.

Hi @dbtom2 - sorry about that. I’m going to follow up with you on PM so we can get a little bit more information.

Okay. Okay. (Seond okay to meet 10 character requirement. Not sarcastic.)