"ROON app is damaged and should be removed to trash"

Roon Core Machine

New mac mini M1 16 GB RAM

Networking Gear & Setup Details

Spectrum as my WiFi and older Apple time capsule

Connected Audio Devices

Schiit Yggdrasil GS DAC

Number of Tracks in Library

Description of Issue

suddenly when i open my desktop app a message comes up that the app is damaged and should be moved to trash.

only thing new with my very simple ROON set up is my OS is now Ventura and ROON worked ok when i upgraded several weeks ago

my other apps ie Audirvana TIDAL app Qobuz app all work

as I said everything else works fine
what do i do to correct this?
thanks

Hello there, I’m not with support but no music isn’t cool.

Have you tried moving it and reinstalling the application?

In an ideal world we can figure out what happened, but Microsoft exists in this world so: reboot, reinstall are trouble shooting techniques.

Give the reinstall a whirl and hopefully it “fixes” your issue.

If you’ve done any curation, then when you reinstall Roon you will need to do a Restore of the database.

1 Like

I believe to remember that there have been other reports of the very same problem under Ventura. No reinstall necessary. I believe the app must be authorized to run under Control Panel—Privacy.

1 Like

Excellent, thank you for the info. I’ll give better advice moving forward too.

:slight_smile:

@MamaTried thanks but i do not use microsoft did reboot my apple mac mini and same thing came up
@

1 Like

In a case like this, one must trust the error message.

If @Andreas_Philipp1’s advice doesn’t work, remove and reinstall Roon app.

Hope you have Roon (not Time Machine) Backups.

Look for example here … you can easily Google for many more related info.

Hey @bobbmd,

I wanted to check in on this thread to see if you were still running into issues with Roon? What OS are you running on your Mac Mini?

I would run through the info @Andreas_Philipp1 has shared above as it is steering you in the right direction for next steps.

Do you run into the same issue when running Roon Server?

I’ll be on standby for your reply :+1:

@benjamin hi thanks for reaching out. What I did was download a new ROON app and it worked so I have 2 ROON icons in my dock. I did not move to trash the original icon as was suggested-I was too scared! I have all my playlists and of course TIDAL and Qobuz etc. The sound remains great etc. This all happened with newest update of Ventura 13.01(I think) This all happened before we left for Florida and I believe the culprit was VENTURA and I saw others had same/similar problem, you folks should notify Apple of this(and it also corrupted my wireless printer and i will have to decertify it and reinstall it when we return home in 6-8 weeks__I have had do this once before with the printer(with Ventura). Surprisingly there was no problem with my standalone desktop apps for TIDAL or Qobuz nor any problems with Audirvana Studio. I don’t understand what you mean by my ‘server’ —I just use ROON to play all my music so the I guess it is my server. FYI it is 82 and sunny where we are and it’s going to be -41 where we live (with wind chill) in upstate NY so I hope none of my equipment is affected !
It was so nice of you to reach out sorry this a late reply but we were driving
Thanks again bobbmd

I also live upstate. Today the wind chill is -12. Last night it was worse.

You left the heat on, right?

@xxx I certainly hope so LOL

@Andreas_Philipp1 thanks see my post to @benjamin — i don’t use use any of apps in @HiS 22 august but using the new downloaded ROON app worked for me just hope ‘support’ tells Apple about this ‘bug’ in Ventura

It’s not a bug in Ventura, it’s a security ‘feature’. Apps that do not originate in Apple’s app store and are not signed by the developers, by default don’t run on Ventura. Or such is my understanding, I don’t have a Ventura machine to do testing.

What I posted are links to info about this and on how to overcome this limitation.

1 Like

@MamaTried see my other post to@benjamin I did exactly what you suggested and it worked !! Thanks and I think i did it before your reply or not but in any event thanks.

@xxx FYI thanks but I did not have to restore the database but thanks.

@Andreas_Philipp1 thanks for the input but to me it’s still a ‘bug’ for Ventura and this problem didn’t exist/happen with my standalone apps for TIDAL/Qobuz and it certainly did not occur on Audirvana my other excellent ‘player’ but thanks for your thoughts and suggestions.

For their part Apple should have explained this if this was a so-called security issue — it also did not happen with my very secure Electronic Medical Records which is not available on the Apple App Store which I use on Safari the rest of my’ stuff’ is on Google Chrome.

bobbmd

2 Likes

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.