Roon App loads but cannot get past select core on this PC

I have a Dell laptop with windows 64. I have loaded the correct software. I run the app and it loads. when I click on select this PC to run core. The software hangs and the circle keeps spinning. top left corner says roon not responding.

Please assist

Try installing the 32 bit version instead of the 64 this sometimes helps.

perhaps some more details with the specs on the machine will help…all the specs, ram cpu ssd/hdd graphics card details etc

Hi @Alex_Pappas,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Since installing Roon have you tried rebooting your Core machine?

Hi Dylan,
Installing the 32 bit version worked for a while. Now I have a blank white screen when I launch roon.
I have a Intel i7-7700HQ CPU @ 2.80GHz 32GB 64 Bit operating system. Windows 10 Home.Let me know if you require additional information.


Alex Pappas

Does the PC have an inbuilt Intel graphics card? I think that is one of the symptoms.

Hi @Alex_Pappas,

Can you try updating your graphics drivers and let us know if the same behavior still occurs?


Yes I updated the graphics drivers use the intell website. They are now up to date.
Let me know next steps.


Hi @Alex_Pappas,

You mentioned that this was working for you for some time with the 32bit version but it started exhibiting this problem too. Was there any change to your setup around this time? Was there a Windows update or anything that coincided with this occurring?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.