Roon app on iPhone (iOS 13.1.2) crashes

App on iOS 13.1.2 crashes all the time, unusable.
App on iPadOS 13.1.2 is stable.

Latest Roon app working flawlessly for me on both:
iPad Pro 10.5 w/ iPadOS 13.1.2
iPhone 11 Pro w/ iOS 13.1.2

@support the Roon iOS app on iPhone (iOS 13.1.2) crashes ALL THE FECKING TIME! Clear?

1 Like

Nice. That will get it fixed faster…


Delete and reinstall. It’s working for most people.

I’m having the same problem on my iPhone (iOS 13.1.2) Roon app. crashes after 15 seconds operation

Deleted and re-installed Roon on my iPhone (iOS 13.1.2) a the app quits and still returns to the home screen after 15 seconds! When I click on the Roon app I’m returned to the roon screen I was using before the roon app quit. Having to re-run the app every 15 seconds to select music or read details is very frustrating. So I’m hoping a fix to this problem is found soon.

I’ve had 3.1.2 on my iPad for little over 24 hours and it seems OK but I have only had stuff on in the background. I haven’t played with search and discovery much on it yet.

Thanks Henry.
I’m using an iPhone 8 (iOS 13.1.2).
My problem only happened in the today, when I went to show my wife how to select music and read about the musician/composer. Can’t show anyone much in 15seconds and then restarting the app for another 15 seconds before it quits again.

1 Like

Actually posted on this MANY times before. Frustrated.

iPad version works fine.

1 Like


I’ve merged some posts and tagged support for you in your previous post, who should follow this up with you.

In the meantime have you tried uninstalling the Roon app and reinstalling and also what version of Roon Core and iOS app you are running?

(I know most likely the latest builds but it’s best not to assume.)

I just tried deleting the app on the phone and reinstalling. I’ll test.

I’m running all the latest versions (except for Catalina):
macOS: 10.14.6 (on mini with 16GB RAM)
Roon Core: 1.6 (build 416)
iOS (iPhone XS Max) and iPadOS (iPad Pro): 13.1.2
iOS and iPadOS Roon app: 1.6 (build 438)

The solution to roon remote quiting/crashing on my iPhone 8 (iOS13.1.2) after 15 seconds of operating perfectly was to power down and restart my iPhone. Un-installing and re-installing the roon remote app had not resolved my 15 second quit problem of the roon remote app.
I had no problem with roon remote app using my wife’s iPhone 6 (iOS 12.4.2).
In future if I have a problem with roon remote working on my iPhone I will firstly power down and restart my iPhone and see if my problems are resolved.

1 Like

It still crashes. I have both deleted/reinstalled and restarted my iphone.

Hi All,

Thank you for your reports surrounding this issue.

We have been investigating this issue internally for some time and have been trying to reproduce this behavior in the lab, but unfortunately it seems that we are not able to do so reliably.

It appears that there may be some distinguishing factors that cause this issue to occur on some iOS devices, but not all, and we have not located any patterns to the reports so far.

This is not suggested as a permanent solution, but we have heard reports that upgrading to the newest beta iOS version has helped customers resolve this behavior.

If you are affected by this issue and the beta iOS version resolves the crashes on your end, please do let us know as it would be a valuable data point.

I will be sure to keep this thread up-to-date as new information regarding this issue surfaces. Thanks!

Exactly the same problem for me :frowning:
Ok on iPad , not ok on iPhone …
Both on iOS 13.1.2 !

It certainly appears to be O/S version specific as since upgrading to 13.2 I’ve not had a single crash whereas on 13.1 I had constant issues.

It happens to me, all the time. Here’s a console log:

default	10:02:05.712961 -0400	ReportCrash	Process RoonMobile [5206] killed by jetsam reason per-process-limit
default	10:02:05.715867 -0400	ReportCrash	starting prolongation transaction timer
default	10:02:05.740818 -0400	ReportCrash	Launched ReportCrash to service -
default	10:02:05.740895 -0400	ReportCrash	Trying to create CR directory structure as root
default	10:02:05.759732 -0400	ReportCrash	cr_update: Parsing corpse data for pid 5206
default	10:02:05.759908 -0400	ReportCrash	cr_update: Parsing corpse data for process RoonMobile [pid 5206]
default	10:02:05.779410 -0400	ReportCrash	__crash_info: [<private>] '(null)'
default	10:02:05.803025 -0400	ReportCrash	Report of type '298(298)' not saved because the limit of 25 logs has been reached
default	10:02:06.016545 -0400	ReportCrash	Formulating fatal report for corpse[5206] RoonMobile
default	10:02:06.032111 -0400	ReportCrash	report not saved because it is non-actionable (ie: extension hangs or internal-only)
default	10:02:15.749751 -0400	ReportCrash	ReportCrash is exiting
default	10:02:25.717701 -0400	ReportCrash	releasing expired transaction
1 Like

My iPad has just received an update to 3.1.3. It was unaffected by the problem but it would be interesting to see if it has any impact on those it did affect. If the problem persists perhaps an exact phone model of those affected might help narrow this down.